All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Roger Pau Monné" <roger.pau@citrix.com>
To: Jan Beulich <jbeulich@suse.com>
Cc: "xen-devel@lists.xenproject.org" <xen-devel@lists.xenproject.org>,
	Andrew Cooper <andrew.cooper3@citrix.com>,
	Paul Durrant <paul@xen.org>, Wei Liu <wl@xen.org>
Subject: Re: [PATCH v2 07/18] IOMMU/x86: perform PV Dom0 mappings in batches
Date: Fri, 10 Dec 2021 10:36:28 +0100	[thread overview]
Message-ID: <YbMfnFWIlSN+GXH9@Air-de-Roger> (raw)
In-Reply-To: <2a3a0a37-525d-e2aa-b396-b01d97434d56@suse.com>

On Fri, Dec 03, 2021 at 01:38:48PM +0100, Jan Beulich wrote:
> On 02.12.2021 15:10, Roger Pau Monné wrote:
> > On Fri, Sep 24, 2021 at 11:47:41AM +0200, Jan Beulich wrote:
> >> @@ -689,7 +763,8 @@ int __init dom0_construct_pv(struct doma
> >>          l1tab++;
> >>  
> >>          page = mfn_to_page(_mfn(mfn));
> >> -        if ( !page->u.inuse.type_info &&
> >> +        if ( (!page->u.inuse.type_info ||
> >> +              page->u.inuse.type_info == (PGT_writable_page | PGT_validated)) &&
> > 
> > Would it be clearer to get page for all pages that have a 0 count:
> > !(type_info & PGT_count_mask). Or would that interact badly with page
> > table pages?
> 
> Indeed this wouldn't work with page tables (and I recall having learned
> this the hard way): Prior to mark_pv_pt_pages_rdonly() they all have a
> type refcount of zero. Even if it wasn't for this, I'd prefer to not
> relax the condition here more than necessary.

Right. Page tables will have some types set but a count of 0.

> >> @@ -720,6 +795,17 @@ int __init dom0_construct_pv(struct doma
> >>      /* Pages that are part of page tables must be read only. */
> >>      mark_pv_pt_pages_rdonly(d, l4start, vpt_start, nr_pt_pages);
> >>  
> >> +    /*
> >> +     * This needs to come after all potentially excess
> >> +     * get_page_and_type(..., PGT_writable_page) invocations; see the loop a
> >> +     * few lines further up, where the effect of calling that function in an
> >> +     * earlier loop iteration may get overwritten by a later one.
> >> +     */
> >> +    if ( need_iommu_pt_sync(d) &&
> >> +         iommu_unmap(d, _dfn(PFN_DOWN(mpt_alloc) - nr_pt_pages), nr_pt_pages,
> >> +                     &flush_flags) )
> >> +        BUG();
> > 
> > Wouldn't such unmap better happen as part of changing the types of the
> > pages that become part of the guest page tables?
> 
> Not sure - it's a single call here, but would be a call per page when
> e.g. moved into mark_pv_pt_pages_rdonly().

I see. So this would result in multiple calls when moved, plus all the
involved page shattering and aggregation logic. Overall it would be
less error prone, as the iommu unmap would happen next to the type
change, but I'm not going to insist if you think it's not worth it.
The page table structure pages shouldn't be that many anyway?

> >> @@ -840,22 +928,41 @@ int __init dom0_construct_pv(struct doma
> >>  #endif
> >>      while ( pfn < nr_pages )
> >>      {
> >> -        if ( (page = alloc_chunk(d, nr_pages - domain_tot_pages(d))) == NULL )
> >> +        count = domain_tot_pages(d);
> >> +        if ( (page = alloc_chunk(d, nr_pages - count)) == NULL )
> >>              panic("Not enough RAM for DOM0 reservation\n");
> >> +        mfn = mfn_x(page_to_mfn(page));
> >> +
> >> +        if ( need_iommu_pt_sync(d) )
> >> +        {
> >> +            rc = iommu_map(d, _dfn(mfn), _mfn(mfn), domain_tot_pages(d) - count,
> >> +                           IOMMUF_readable | IOMMUF_writable, &flush_flags);
> >> +            if ( rc )
> >> +                printk(XENLOG_ERR
> >> +                       "pre-mapping MFN %lx (PFN %lx) into IOMMU failed: %d\n",
> >> +                       mfn, pfn, rc);
> >> +        }
> >> +
> >>          while ( pfn < domain_tot_pages(d) )
> >>          {
> >> -            mfn = mfn_x(page_to_mfn(page));
> >> +            if ( !rc )
> >> +                make_pages_writable(page, 1);
> > 
> > There's quite a lot of repetition of the pattern: allocate, iommu_map,
> > set as writable. Would it be possible to abstract this into some
> > kind of helper?
> > 
> > I've realized some of the allocations use alloc_chunk while others use
> > alloc_domheap_pages, so it might require some work.
> 
> Right, I'd leave the allocation part aside for the moment. I had actually
> considered to fold iommu_map() and make_pages_writable() into a common
> helper (or really rename make_pages_writable() and fold iommu_map() into
> there). What I lacked was a reasonable, not overly long name for such a
> function.

I'm not overly good at naming, but I think we need to somehow find a
way to place those together into a single helper.

I would be fine with naming this iommu_memory_{setup,add} or some
such. Marking the pages as writable is a result (or a requirement
might be a better way to express it?) of adding them to the IOMMU.
Would you be OK with one of those names?

> >> @@ -372,16 +372,30 @@ void __hwdom_init arch_iommu_hwdom_init(
> >>                                          perms & IOMMUF_writable ? p2m_access_rw
> >>                                                                  : p2m_access_r,
> >>                                          0);
> >> +        else if ( pfn != start + count || perms != start_perms )
> >> +        {
> >> +        commit:
> >> +            rc = iommu_map(d, _dfn(start), _mfn(start), count,
> >> +                           start_perms, &flush_flags);
> >> +            SWAP(start, pfn);
> >> +            start_perms = perms;
> >> +            count = 1;
> >> +        }
> >>          else
> >> -            rc = iommu_map(d, _dfn(pfn), _mfn(pfn), 1ul << PAGE_ORDER_4K,
> >> -                           perms, &flush_flags);
> >> +        {
> >> +            ++count;
> >> +            rc = 0;
> >> +        }
> >>  
> >>          if ( rc )
> >>              printk(XENLOG_WARNING "%pd: identity %smapping of %lx failed: %d\n",
> >>                     d, !paging_mode_translate(d) ? "IOMMU " : "", pfn, rc);
> > 
> > Would be nice to print the count (or end pfn) in case it's a range.
> 
> I can do so if you think it's worth further extra code. I can't use
> "count" here in particular, as that was updated already (in context
> above). The most reasonable change towards this would perhaps be to
> duplicate the printk() into both the "if()" and the "else if()" bodies.

Maybe. The current message gives the impression that a single pfn has
been added and failed, but without printing the range that failed the
message will not be that helpful in diagnosing further issues that
might arise due to the mapping failure.

> > While not something that you have to fix here, the logic here is
> > becoming overly complicated IMO. It might be easier to just put all
> > the ram and reserved regions (or everything < 4G) into a rangeset and
> > then punch holes on it for non guest mappable regions, and finally use
> > rangeset_consume_ranges to iterate and map those. That's likely faster
> > than having to iterate over all pfns on the system, and easier to
> > understand from a logic PoV.
> 
> Maybe; I didn't spend much time on figuring possible ways of
> consolidating some of this.

I can give it a try after your code is merged. I think it's getting a
bit messy.

Thanks, Roger.


  reply	other threads:[~2021-12-10  9:41 UTC|newest]

Thread overview: 100+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-09-24  9:39 [PATCH v2 00/18] IOMMU: superpage support when not sharing pagetables Jan Beulich
2021-09-24  9:41 ` [PATCH v2 01/18] AMD/IOMMU: have callers specify the target level for page table walks Jan Beulich
2021-09-24 10:58   ` Roger Pau Monné
2021-09-24 12:02     ` Jan Beulich
2021-09-24  9:42 ` [PATCH v2 02/18] VT-d: " Jan Beulich
2021-09-24 14:45   ` Roger Pau Monné
2021-09-27  9:04     ` Jan Beulich
2021-09-27  9:13       ` Jan Beulich
2021-11-30 11:56       ` Roger Pau Monné
2021-11-30 14:38         ` Jan Beulich
2021-09-24  9:43 ` [PATCH v2 03/18] IOMMU: have vendor code announce supported page sizes Jan Beulich
2021-11-30 12:25   ` Roger Pau Monné
2021-12-17 14:43   ` Julien Grall
2021-12-21  9:26   ` Rahul Singh
2021-09-24  9:44 ` [PATCH v2 04/18] IOMMU: add order parameter to ->{,un}map_page() hooks Jan Beulich
2021-11-30 13:49   ` Roger Pau Monné
2021-11-30 14:45     ` Jan Beulich
2021-12-17 14:42   ` Julien Grall
2021-09-24  9:45 ` [PATCH v2 05/18] IOMMU: have iommu_{,un}map() split requests into largest possible chunks Jan Beulich
2021-11-30 15:24   ` Roger Pau Monné
2021-12-02 15:59     ` Jan Beulich
2021-09-24  9:46 ` [PATCH v2 06/18] IOMMU/x86: restrict IO-APIC mappings for PV Dom0 Jan Beulich
2021-12-01  9:09   ` Roger Pau Monné
2021-12-01  9:27     ` Jan Beulich
2021-12-01 10:32       ` Roger Pau Monné
2021-12-01 11:45         ` Jan Beulich
2021-12-02 15:12           ` Roger Pau Monné
2021-12-02 15:28             ` Jan Beulich
2021-12-02 19:16               ` Andrew Cooper
2021-12-03  6:41                 ` Jan Beulich
2021-09-24  9:47 ` [PATCH v2 07/18] IOMMU/x86: perform PV Dom0 mappings in batches Jan Beulich
2021-12-02 14:10   ` Roger Pau Monné
2021-12-03 12:38     ` Jan Beulich
2021-12-10  9:36       ` Roger Pau Monné [this message]
2021-12-10 11:41         ` Jan Beulich
2021-12-10 12:35           ` Roger Pau Monné
2021-09-24  9:48 ` [PATCH v2 08/18] IOMMU/x86: support freeing of pagetables Jan Beulich
2021-12-02 16:03   ` Roger Pau Monné
2021-12-02 16:10     ` Jan Beulich
2021-12-03  8:30       ` Roger Pau Monné
2021-12-03  9:38         ` Roger Pau Monné
2021-12-03  9:40         ` Jan Beulich
2021-12-10 13:51   ` Roger Pau Monné
2021-12-13  8:38     ` Jan Beulich
2021-09-24  9:48 ` [PATCH v2 09/18] AMD/IOMMU: drop stray TLB flush Jan Beulich
2021-12-02 16:16   ` Roger Pau Monné
2021-09-24  9:51 ` [PATCH v2 10/18] AMD/IOMMU: walk trees upon page fault Jan Beulich
2021-12-03  9:03   ` Roger Pau Monné
2021-12-03  9:49     ` Jan Beulich
2021-12-03  9:55       ` Jan Beulich
2021-12-10 10:23         ` Roger Pau Monné
2021-12-03  9:59     ` Jan Beulich
2021-09-24  9:51 ` [PATCH v2 11/18] AMD/IOMMU: return old PTE from {set,clear}_iommu_pte_present() Jan Beulich
2021-12-10 12:05   ` Roger Pau Monné
2021-12-10 12:59     ` Jan Beulich
2021-12-10 13:53       ` Roger Pau Monné
2021-09-24  9:52 ` [PATCH v2 12/18] AMD/IOMMU: allow use of superpage mappings Jan Beulich
2021-12-10 15:06   ` Roger Pau Monné
2021-12-13  8:49     ` Jan Beulich
2021-12-13  9:45       ` Roger Pau Monné
2021-12-13 10:00         ` Jan Beulich
2021-12-13 10:33           ` Roger Pau Monné
2021-12-13 10:41             ` Jan Beulich
2021-09-24  9:52 ` [PATCH v2 13/18] VT-d: " Jan Beulich
2021-12-13 11:54   ` Roger Pau Monné
2021-12-13 13:39     ` Jan Beulich
2021-09-24  9:53 ` [PATCH v2 14/18] IOMMU: fold flush-all hook into "flush one" Jan Beulich
2021-12-13 15:04   ` Roger Pau Monné
2021-12-14  9:06     ` Jan Beulich
2021-12-14  9:27       ` Roger Pau Monné
2021-12-15 15:28   ` Oleksandr
2021-12-16  8:49     ` Jan Beulich
2021-12-16 10:39       ` Oleksandr
2021-12-16 11:30   ` Rahul Singh
2021-12-21  8:04     ` Jan Beulich
2021-12-17 14:38   ` Julien Grall
2021-09-24  9:54 ` [PATCH v2 15/18] IOMMU/x86: prefill newly allocate page tables Jan Beulich
2021-12-13 15:51   ` Roger Pau Monné
2021-12-14  9:15     ` Jan Beulich
2021-12-14 11:41       ` Roger Pau Monné
2021-12-14 11:48         ` Jan Beulich
2021-12-14 14:50   ` Roger Pau Monné
2021-12-14 15:05     ` Jan Beulich
2021-12-14 15:15       ` Roger Pau Monné
2021-12-14 15:21         ` Jan Beulich
2021-12-14 15:06   ` Roger Pau Monné
2021-12-14 15:10     ` Jan Beulich
2021-12-14 15:17       ` Roger Pau Monné
2021-12-14 15:24         ` Jan Beulich
2021-09-24  9:55 ` [PATCH v2 16/18] x86: introduce helper for recording degree of contiguity in " Jan Beulich
2021-12-15 13:57   ` Roger Pau Monné
2021-12-16 15:47     ` Jan Beulich
2021-12-20 15:25       ` Roger Pau Monné
2021-12-21  8:09         ` Jan Beulich
2022-01-04  8:57           ` Roger Pau Monné
2022-01-04  9:00             ` Jan Beulich
2021-09-24  9:55 ` [PATCH v2 17/18] AMD/IOMMU: free all-empty " Jan Beulich
2021-12-15 15:14   ` Roger Pau Monné
2021-12-16 15:54     ` Jan Beulich
2021-09-24  9:56 ` [PATCH v2 18/18] VT-d: " Jan Beulich

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=YbMfnFWIlSN+GXH9@Air-de-Roger \
    --to=roger.pau@citrix.com \
    --cc=andrew.cooper3@citrix.com \
    --cc=jbeulich@suse.com \
    --cc=paul@xen.org \
    --cc=wl@xen.org \
    --cc=xen-devel@lists.xenproject.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.