All of lore.kernel.org
 help / color / mirror / Atom feed
From: Greg KH <gregkh@linuxfoundation.org>
To: Grzegorz Szymaszek <gszymaszek@short.pl>,
	Larry Finger <Larry.Finger@lwfinger.net>,
	Phillip Potter <phil@philpotter.co.uk>,
	linux-kernel@vger.kernel.org, linux-staging@lists.linux.dev
Subject: Re: [PATCH 3/3] staging: r8188eu: make driver metadata macro names more consistent
Date: Fri, 5 Aug 2022 08:39:41 +0200	[thread overview]
Message-ID: <Yuy7Lc/TJMinuupA@kroah.com> (raw)
In-Reply-To: <7cc838a1e7f64c9aa88deffdb7986fbe55753be8.1659565180.git.gszymaszek@short.pl>

On Thu, Aug 04, 2022 at 12:29:10AM +0200, Grzegorz Szymaszek wrote:
> Rename DRIVERVERSION to DRV_VERSION so that it looks more alike the
> other macros, DRV_NAME and FW_*, and matches the most popular (as it
> seems from a quick review) conventions in other drivers.
> 
> Signed-off-by: Grzegorz Szymaszek <gszymaszek@short.pl>
> ---
>  drivers/staging/r8188eu/include/drv_types.h | 5 ++---
>  drivers/staging/r8188eu/os_dep/os_intfs.c   | 2 +-
>  2 files changed, 3 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/staging/r8188eu/include/drv_types.h b/drivers/staging/r8188eu/include/drv_types.h
> index f51b83515953..3328c66d1ef1 100644
> --- a/drivers/staging/r8188eu/include/drv_types.h
> +++ b/drivers/staging/r8188eu/include/drv_types.h
> @@ -10,8 +10,6 @@
>  #ifndef __DRV_TYPES_H__
>  #define __DRV_TYPES_H__
>  
> -#define DRV_NAME "r8188eu"

This should just be KBUILD_MODNAME, no need to create yet-another-macro
for this one.

> -
>  #include "osdep_service.h"
>  #include "wlan_bssdef.h"
>  #include "rtw_ht.h"
> @@ -36,7 +34,8 @@
>  #include "rtl8188e_hal.h"
>  #include "rtw_fw.h"
>  
> -#define DRIVERVERSION	"v4.1.4_6773.20130222"
> +#define DRV_NAME	"r8188eu"

Again, KBUILD_MODNAME

> +#define DRV_VERSION	"v4.1.4_6773.20130222"

As the driver is now in the kernel, this "version" string can just go
away.  Can you redo this patch to do the DRV_NAME thing first, and then
drop the DRV_VERSION field after that?

thanks,

greg k-h

  reply	other threads:[~2022-08-05  6:39 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-08-02 13:17 The r8188eu kernel module does not depend on the rtlwifi/rtl8188eufw.bin firmware file Grzegorz Szymaszek
2022-08-02 14:07 ` Greg KH
2022-08-02 14:17   ` Grzegorz Szymaszek
2022-08-02 15:01     ` Larry Finger
2022-08-02 17:18       ` [PATCH] staging: r8188eu: add firmware dependency Grzegorz Szymaszek
2022-08-02 18:03         ` Larry Finger
2022-08-02 19:02         ` Phillip Potter
2022-08-03  6:08         ` Greg KH
2022-08-03  6:33           ` Grzegorz Szymaszek
2022-08-03  6:37             ` Greg KH
2022-08-03 22:28           ` [PATCH 1/3] staging: r8188eu: set firmware path in a macro Grzegorz Szymaszek
2022-08-03 22:29             ` [PATCH 2/3] staging: r8188eu: make use of the DRV_NAME macro Grzegorz Szymaszek
2022-08-05  6:40               ` Greg KH
2022-08-03 22:29             ` [PATCH 3/3] staging: r8188eu: make driver metadata macro names more consistent Grzegorz Szymaszek
2022-08-05  6:39               ` Greg KH [this message]
2022-08-04 20:11             ` [PATCH 1/3] staging: r8188eu: set firmware path in a macro Philipp Hortmann
2022-08-04 22:23               ` Grzegorz Szymaszek
2022-08-05  4:13                 ` Greg KH

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Yuy7Lc/TJMinuupA@kroah.com \
    --to=gregkh@linuxfoundation.org \
    --cc=Larry.Finger@lwfinger.net \
    --cc=gszymaszek@short.pl \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-staging@lists.linux.dev \
    --cc=phil@philpotter.co.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.