From: Nicolin Chen <nicolinc@nvidia.com>
To: "Tian, Kevin" <kevin.tian@intel.com>
Cc: "jgg@nvidia.com" <jgg@nvidia.com>,
"will@kernel.org" <will@kernel.org>,
"corbet@lwn.net" <corbet@lwn.net>,
"joro@8bytes.org" <joro@8bytes.org>,
"suravee.suthikulpanit@amd.com" <suravee.suthikulpanit@amd.com>,
"robin.murphy@arm.com" <robin.murphy@arm.com>,
"dwmw2@infradead.org" <dwmw2@infradead.org>,
"baolu.lu@linux.intel.com" <baolu.lu@linux.intel.com>,
"shuah@kernel.org" <shuah@kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"iommu@lists.linux.dev" <iommu@lists.linux.dev>,
"linux-arm-kernel@lists.infradead.org"
<linux-arm-kernel@lists.infradead.org>,
"linux-kselftest@vger.kernel.org"
<linux-kselftest@vger.kernel.org>,
"linux-doc@vger.kernel.org" <linux-doc@vger.kernel.org>,
"eric.auger@redhat.com" <eric.auger@redhat.com>,
"jean-philippe@linaro.org" <jean-philippe@linaro.org>,
"mdf@kernel.org" <mdf@kernel.org>,
"mshavit@google.com" <mshavit@google.com>,
"shameerali.kolothum.thodi@huawei.com"
<shameerali.kolothum.thodi@huawei.com>,
"smostafa@google.com" <smostafa@google.com>,
"ddutile@redhat.com" <ddutile@redhat.com>,
"Liu, Yi L" <yi.l.liu@intel.com>
Subject: Re: [PATCH v2 03/13] iommufd: Rename IOMMUFD_OBJ_FAULT to IOMMUFD_OBJ_EVENTQ_IOPF
Date: Thu, 12 Dec 2024 13:15:43 -0800 [thread overview]
Message-ID: <Z1tSf+z0fvl2wTGU@Asurada-Nvidia> (raw)
In-Reply-To: <BN9PR11MB5276F92171A516C2A17839458C3E2@BN9PR11MB5276.namprd11.prod.outlook.com>
On Wed, Dec 11, 2024 at 07:40:52AM +0000, Tian, Kevin wrote:
> > From: Nicolin Chen <nicolinc@nvidia.com>
> > Sent: Wednesday, December 4, 2024 6:10 AM
> >
> > The fault object was designed exclusively for hwpt's IO page faults (PRI).
> > But its implementation can actually be reused for other purposes too, such
> > as hardware IRQ and event injections to user space.
> >
> > Meanwhile, a fault object holds a list of faults. So it's more accurate to
> > call it a "fault queue". Combining the reusing idea above, a "fault queue"
> > can further rephrase to an "Event Queue for IOPF".
> >
> > Rename the struct iommufd_fault to struct iommufd_eventq_iopf that holds
> > a
> > common Event Queue struct, similar to hwpt_paging holding a common
> > hwpt.
> >
> > Roll out a minimal level of renamings to all the related functions.
>
> could we keep iommufd_fault? Internally it will use the new eventq
> common struct but external facing names are all still around fault.
> the size of changed lines will be much smaller.
>
> Then later for virq it could be iommufd_viommu_virq instead of
> iommufd_eventq_virq to explicitly draw its connection to viommu.
>
> this is unlike hwpt where 'paging' or 'nested' is just decorative while
> 'fault' or 'virq' is noun on its own.
It's a personal preference, though I don't have a strong opinion
about it. I can change them to iommufd_fault and iommufd_virq --
feels nicer to align with the other iommufd_v*: iommufd_vdevice,
iommufd_vqueue..
> > +static ssize_t iommufd_eventq_fops_read(struct file *filep, char __user *buf,
> > + size_t count, loff_t *ppos)
> > +{
> > + struct iommufd_eventq *eventq = filep->private_data;
> > +
> > + if (!eventq->ops || !eventq->ops->read)
> > + return -EOPNOTSUPP;
> > + return eventq->ops->read(eventq, buf, count, ppos);
> > +}
>
> the check on ops can be done in iommufd_eventq_init()
Ack. I think that's fine since we don't have a !ops->read case.
Thanks
Nic
next prev parent reply other threads:[~2024-12-12 21:17 UTC|newest]
Thread overview: 32+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-12-03 22:10 [PATCH v2 00/13] iommufd: Add vIOMMU infrastructure (Part-3: vIRQ) Nicolin Chen
2024-12-03 22:10 ` [PATCH v2 01/13] iommufd/fault: Add an iommufd_fault_init() helper Nicolin Chen
2024-12-11 7:27 ` Tian, Kevin
2024-12-12 21:10 ` Nicolin Chen
2024-12-03 22:10 ` [PATCH v2 02/13] iommufd/fault: Move iommufd_fault_iopf_handler() to header Nicolin Chen
2024-12-11 7:30 ` Tian, Kevin
2024-12-03 22:10 ` [PATCH v2 03/13] iommufd: Rename IOMMUFD_OBJ_FAULT to IOMMUFD_OBJ_EVENTQ_IOPF Nicolin Chen
2024-12-11 7:40 ` Tian, Kevin
2024-12-12 21:15 ` Nicolin Chen [this message]
2024-12-03 22:10 ` [PATCH v2 04/13] iommufd: Rename fault.c to eventq.c Nicolin Chen
2024-12-11 7:43 ` Tian, Kevin
2024-12-03 22:10 ` [PATCH v2 05/13] iommufd: Add IOMMUFD_OBJ_EVENTQ_VIRQ and IOMMUFD_CMD_VIRQ_ALLOC Nicolin Chen
2024-12-11 7:55 ` Tian, Kevin
2024-12-12 21:20 ` Nicolin Chen
2024-12-03 22:10 ` [PATCH v2 06/13] iommufd/viommu: Add iommufd_viommu_get_vdev_id helper Nicolin Chen
2024-12-11 8:02 ` Tian, Kevin
2024-12-12 21:21 ` Nicolin Chen
2024-12-03 22:10 ` [PATCH v2 07/13] iommufd/viommu: Add iommufd_viommu_report_irq helper Nicolin Chen
2024-12-11 8:05 ` Tian, Kevin
2024-12-12 21:23 ` Nicolin Chen
2024-12-03 22:10 ` [PATCH v2 08/13] iommufd/selftest: Require vdev_id when attaching to a nested domain Nicolin Chen
2024-12-03 22:10 ` [PATCH v2 09/13] iommufd/selftest: Add IOMMU_TEST_OP_TRIGGER_VIRQ for vIRQ coverage Nicolin Chen
2024-12-03 22:10 ` [PATCH v2 10/13] iommufd/selftest: Add EVENT_VIRQ test coverage Nicolin Chen
2024-12-03 22:10 ` [PATCH v2 11/13] Documentation: userspace-api: iommufd: Update EVENTQ_IOPF and EVENTQ_VIRQ Nicolin Chen
2024-12-11 8:11 ` Tian, Kevin
2024-12-12 21:28 ` Nicolin Chen
2024-12-03 22:10 ` [PATCH v2 12/13] iommu/arm-smmu-v3: Introduce struct arm_smmu_vmaster Nicolin Chen
2024-12-11 8:15 ` Tian, Kevin
2024-12-12 21:31 ` Nicolin Chen
2024-12-03 22:10 ` [PATCH v2 13/13] iommu/arm-smmu-v3: Report IRQs that belong to devices attached to vIOMMU Nicolin Chen
2024-12-11 8:21 ` Tian, Kevin
2024-12-12 21:34 ` Nicolin Chen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Z1tSf+z0fvl2wTGU@Asurada-Nvidia \
--to=nicolinc@nvidia.com \
--cc=baolu.lu@linux.intel.com \
--cc=corbet@lwn.net \
--cc=ddutile@redhat.com \
--cc=dwmw2@infradead.org \
--cc=eric.auger@redhat.com \
--cc=iommu@lists.linux.dev \
--cc=jean-philippe@linaro.org \
--cc=jgg@nvidia.com \
--cc=joro@8bytes.org \
--cc=kevin.tian@intel.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-doc@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-kselftest@vger.kernel.org \
--cc=mdf@kernel.org \
--cc=mshavit@google.com \
--cc=robin.murphy@arm.com \
--cc=shameerali.kolothum.thodi@huawei.com \
--cc=shuah@kernel.org \
--cc=smostafa@google.com \
--cc=suravee.suthikulpanit@amd.com \
--cc=will@kernel.org \
--cc=yi.l.liu@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.