From: Nicolin Chen <nicolinc@nvidia.com>
To: "Tian, Kevin" <kevin.tian@intel.com>
Cc: "Liu, Yi L" <yi.l.liu@intel.com>,
"joro@8bytes.org" <joro@8bytes.org>,
"alex.williamson@redhat.com" <alex.williamson@redhat.com>,
"jgg@nvidia.com" <jgg@nvidia.com>,
"robin.murphy@arm.com" <robin.murphy@arm.com>,
"baolu.lu@linux.intel.com" <baolu.lu@linux.intel.com>,
"cohuck@redhat.com" <cohuck@redhat.com>,
"eric.auger@redhat.com" <eric.auger@redhat.com>,
"kvm@vger.kernel.org" <kvm@vger.kernel.org>,
"mjrosato@linux.ibm.com" <mjrosato@linux.ibm.com>,
"chao.p.peng@linux.intel.com" <chao.p.peng@linux.intel.com>,
"yi.y.sun@linux.intel.com" <yi.y.sun@linux.intel.com>,
"peterx@redhat.com" <peterx@redhat.com>,
"jasowang@redhat.com" <jasowang@redhat.com>,
"shameerali.kolothum.thodi@huawei.com"
<shameerali.kolothum.thodi@huawei.com>,
"lulu@redhat.com" <lulu@redhat.com>,
"suravee.suthikulpanit@amd.com" <suravee.suthikulpanit@amd.com>,
"iommu@lists.linux.dev" <iommu@lists.linux.dev>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"linux-kselftest@vger.kernel.org"
<linux-kselftest@vger.kernel.org>,
"Duan, Zhenzhong" <zhenzhong.duan@intel.com>
Subject: Re: [PATCH v2 04/11] iommufd: Pass parent hwpt and user_data to iommufd_hw_pagetable_alloc()
Date: Fri, 19 May 2023 12:09:16 -0700 [thread overview]
Message-ID: <ZGfJXFls5uNi3ziH@Asurada-Nvidia> (raw)
In-Reply-To: <BN9PR11MB527662C871DD8351E9F507D18C7C9@BN9PR11MB5276.namprd11.prod.outlook.com>
On Fri, May 19, 2023 at 09:06:20AM +0000, Tian, Kevin wrote:
> > @@ -73,14 +77,22 @@ int iommufd_hw_pagetable_enforce_cc(struct
> > iommufd_hw_pagetable *hwpt)
> > */
> > struct iommufd_hw_pagetable *
> > iommufd_hw_pagetable_alloc(struct iommufd_ctx *ictx, struct
> > iommufd_ioas *ioas,
> > - struct iommufd_device *idev, bool
> > immediate_attach)
> > + struct iommufd_device *idev,
> > + struct iommufd_hw_pagetable *parent,
> > + union iommu_domain_user_data *user_data,
> > + bool immediate_attach)
> > {
> > const struct iommu_ops *ops = dev_iommu_ops(idev->dev);
> > + struct iommu_domain *parent_domain = NULL;
> > struct iommufd_hw_pagetable *hwpt;
> > + bool type_unmanaged, type_nested;
> > int rc;
> >
> > lockdep_assert_held(&ioas->mutex);
> >
> > + if ((user_data || parent) && !ops->domain_alloc_user)
> > + return ERR_PTR(-EOPNOTSUPP);
>
> Do we allow specifying parent w/o user_data?
I don't think so. Perhaps we should do a double check:
+ if (!!user_data ^ !!parent)
+ return ERR_PTR(-EINVAL);
+ if (user_data && !ops->domain_alloc_user)
+ return ERR_PTR(-EOPNOTSUPP);
> > @@ -99,6 +117,15 @@ iommufd_hw_pagetable_alloc(struct iommufd_ctx
> > *ictx, struct iommufd_ioas *ioas,
> > goto out_abort;
> > }
> >
> > + /* It must be either NESTED or UNMANAGED, depending on
> > parent_domain */
> > + type_nested = hwpt->domain->type == IOMMU_DOMAIN_NESTED;
> > + type_unmanaged = hwpt->domain->type ==
> > IOMMU_DOMAIN_UNMANAGED;
>
> no need of one-time used variables. Just put the conditions directly
> in WARN_ON.
It is to improve the readability. Otherwise, we'd have:
if (WARN_ON((parent_domain &&
hwpt->domain->type != IOMMU_DOMAIN_NESTED) ||
(!parent_domain &&
hwpt->domain->type != IOMMU_DOMAIN_UNMANAGED)))
> > + if (WARN_ON((parent_domain && !type_nested) ||
> > + (!parent_domain && !type_unmanaged))) {
> > + rc = -EINVAL;
> > + goto out_abort;
> > + }
> > +
>
> probably just WARN_ON_ONCE() to mark that driver has problem?
Yea. I think we could do that.
Thanks
Nic
next prev parent reply other threads:[~2023-05-19 19:09 UTC|newest]
Thread overview: 64+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-05-11 14:38 [PATCH v2 00/11] iommufd: Add nesting infrastructure Yi Liu
2023-05-11 14:38 ` [PATCH v2 01/11] iommu: Add new iommu op to create domains owned by userspace Yi Liu
2023-05-19 8:47 ` Tian, Kevin
2023-05-19 18:45 ` Nicolin Chen
2023-05-24 5:02 ` Tian, Kevin
2023-05-24 5:23 ` Nicolin Chen
2023-05-24 7:48 ` Tian, Kevin
2023-05-25 1:41 ` Nicolin Chen
2023-06-06 14:08 ` Jason Gunthorpe
2023-06-06 19:43 ` Nicolin Chen
2023-06-07 0:14 ` Jason Gunthorpe
2023-05-11 14:38 ` [PATCH v2 02/11] iommu: Add nested domain support Yi Liu
2023-05-19 8:51 ` Tian, Kevin
2023-05-19 18:49 ` Nicolin Chen
2023-05-24 5:03 ` Tian, Kevin
2023-05-24 5:28 ` Nicolin Chen
2023-05-11 14:38 ` [PATCH v2 03/11] iommufd/hw_pagetable: Use domain_alloc_user op for domain allocation Yi Liu
2023-05-19 8:56 ` Tian, Kevin
2023-05-19 18:57 ` Nicolin Chen
2023-05-24 5:04 ` Tian, Kevin
2023-05-11 14:38 ` [PATCH v2 04/11] iommufd: Pass parent hwpt and user_data to iommufd_hw_pagetable_alloc() Yi Liu
2023-05-19 9:06 ` Tian, Kevin
2023-05-19 19:09 ` Nicolin Chen [this message]
2023-05-24 5:11 ` Tian, Kevin
2023-05-24 5:31 ` Nicolin Chen
2023-05-19 9:34 ` Tian, Kevin
2023-05-19 19:12 ` Nicolin Chen
2023-05-11 14:38 ` [PATCH v2 05/11] iommufd/hw_pagetable: Do not populate user-managed hw_pagetables Yi Liu
2023-05-11 14:38 ` [PATCH v2 06/11] iommufd: IOMMU_HWPT_ALLOC allocation with user data Yi Liu
2023-05-17 3:08 ` Liu, Jingqi
2023-05-19 19:34 ` Nicolin Chen
2023-05-19 9:41 ` Tian, Kevin
2023-05-19 19:48 ` Nicolin Chen
2023-05-24 5:16 ` Tian, Kevin
2023-05-24 5:40 ` Nicolin Chen
2023-05-24 7:55 ` Tian, Kevin
2023-05-11 14:38 ` [PATCH v2 07/11] iommufd: Add IOMMU_HWPT_INVALIDATE Yi Liu
2023-05-11 14:38 ` [PATCH v2 08/11] iommufd/selftest: Add domain_alloc_user() support in iommu mock Yi Liu
2023-05-11 14:38 ` [PATCH v2 09/11] iommufd/selftest: Add coverage for IOMMU_HWPT_ALLOC with user data Yi Liu
2023-05-11 14:38 ` [PATCH v2 10/11] iommufd/selftest: Add IOMMU_TEST_OP_MD_CHECK_IOTLB test op Yi Liu
2023-05-11 14:38 ` [PATCH v2 11/11] iommufd/selftest: Add coverage for IOMMU_HWPT_INVALIDATE ioctl Yi Liu
2023-05-19 9:56 ` [PATCH v2 00/11] iommufd: Add nesting infrastructure Tian, Kevin
2023-05-19 11:49 ` Jason Gunthorpe
2023-05-24 3:48 ` Tian, Kevin
2023-06-06 14:18 ` Jason Gunthorpe
2023-06-16 2:43 ` Tian, Kevin
2023-06-19 12:37 ` Jason Gunthorpe
2023-06-20 1:43 ` Tian, Kevin
2023-06-20 12:47 ` Jason Gunthorpe
2023-06-21 6:02 ` Tian, Kevin
2023-06-21 7:09 ` Liu, Yi L
2023-06-21 12:04 ` Jason Gunthorpe
2023-06-26 6:32 ` Tian, Kevin
2023-06-21 17:13 ` Nicolin Chen
2023-06-26 6:42 ` Tian, Kevin
2023-06-26 13:05 ` Jason Gunthorpe
2023-06-26 17:28 ` Nicolin Chen
2023-06-27 6:02 ` Tian, Kevin
2023-06-27 16:01 ` Jason Gunthorpe
2023-06-28 2:47 ` Tian, Kevin
2023-06-28 12:36 ` Jason Gunthorpe
2023-06-29 2:16 ` Tian, Kevin
2023-06-21 8:29 ` Duan, Zhenzhong
2023-06-21 12:07 ` Jason Gunthorpe
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ZGfJXFls5uNi3ziH@Asurada-Nvidia \
--to=nicolinc@nvidia.com \
--cc=alex.williamson@redhat.com \
--cc=baolu.lu@linux.intel.com \
--cc=chao.p.peng@linux.intel.com \
--cc=cohuck@redhat.com \
--cc=eric.auger@redhat.com \
--cc=iommu@lists.linux.dev \
--cc=jasowang@redhat.com \
--cc=jgg@nvidia.com \
--cc=joro@8bytes.org \
--cc=kevin.tian@intel.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-kselftest@vger.kernel.org \
--cc=lulu@redhat.com \
--cc=mjrosato@linux.ibm.com \
--cc=peterx@redhat.com \
--cc=robin.murphy@arm.com \
--cc=shameerali.kolothum.thodi@huawei.com \
--cc=suravee.suthikulpanit@amd.com \
--cc=yi.l.liu@intel.com \
--cc=yi.y.sun@linux.intel.com \
--cc=zhenzhong.duan@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.