All of lore.kernel.org
 help / color / mirror / Atom feed
From: Peter Xu <peterx@redhat.com>
To: David Hildenbrand <david@redhat.com>
Cc: linux-kernel@vger.kernel.org, linux-mm@kvack.org,
	Matthew Wilcox <willy@infradead.org>,
	Andrea Arcangeli <aarcange@redhat.com>,
	John Hubbard <jhubbard@nvidia.com>,
	Mike Rapoport <rppt@kernel.org>, Vlastimil Babka <vbabka@suse.cz>,
	"Kirill A . Shutemov" <kirill@shutemov.name>,
	Andrew Morton <akpm@linux-foundation.org>,
	Mike Kravetz <mike.kravetz@oracle.com>,
	James Houghton <jthoughton@google.com>,
	Hugh Dickins <hughd@google.com>
Subject: Re: [PATCH 3/7] mm/hugetlb: Add page_mask for hugetlb_follow_page_mask()
Date: Tue, 20 Jun 2023 10:40:56 -0400	[thread overview]
Message-ID: <ZJG6eDZNZFf4Xs7a@x1n> (raw)
In-Reply-To: <24f4a22e-7d3b-544b-320f-bba5abb92285@redhat.com>

On Tue, Jun 20, 2023 at 09:01:23AM +0200, David Hildenbrand wrote:
> On 19.06.23 23:43, Peter Xu wrote:
> > On Tue, Jun 13, 2023 at 05:53:42PM -0400, Peter Xu wrote:
> > > @@ -6506,6 +6507,7 @@ struct page *hugetlb_follow_page_mask(struct vm_area_struct *vma,
> > >   		 * because we hold the ptl lock and have verified pte_present().
> > >   		 */
> > >   		WARN_ON_ONCE(try_grab_page(page, flags));
> > > +		*page_mask = huge_page_mask(h);
> > 
> > Sorry, I was wrong this line.  It should be:
> > 
> > 		*page_mask = ~huge_page_mask(h) >> PAGE_SHIFT;
> > 
> 
> That's ... surprising. It feels like either page_mask or huge_page_mask()
> has a misleading name ....
> 
> h->mask = ~(huge_page_size(h) - 1);
> 
> 
> For PMDs, we do
> 
> ctx->page_mask = HPAGE_PMD_NR - 1;
> 
> 
> Maybe
> 
> *page_mask = PHYS_PFN(huge_page_size(h)) - 1;
> 
> Would be clearer.

Since I just posted a new version.. I'll see whether I should get that
cleaned up in a new one.

> 
> I guess "page_mask" should actually be "pfn_mask" ... but the meaning
> regarding PAGE_MASK are still inverted ...

Yes, pfn_mask can be at least slightly better.  I can add a patch to rename
it, or we can also do it on top as cleanups.

Thanks,

-- 
Peter Xu



  reply	other threads:[~2023-06-20 14:41 UTC|newest]

Thread overview: 39+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-06-13 21:53 [PATCH 0/7] mm/gup: Unify hugetlb, speed up thp Peter Xu
2023-06-13 21:53 ` [PATCH 1/7] mm/hugetlb: Handle FOLL_DUMP well in follow_page_mask() Peter Xu
2023-06-14 23:24   ` Mike Kravetz
2023-06-16  8:08   ` David Hildenbrand
2023-06-13 21:53 ` [PATCH 2/7] mm/hugetlb: Fix hugetlb_follow_page_mask() on permission checks Peter Xu
2023-06-14 15:31   ` David Hildenbrand
2023-06-14 15:46     ` Peter Xu
2023-06-14 15:57       ` David Hildenbrand
2023-06-15  0:11       ` Mike Kravetz
2023-06-13 21:53 ` [PATCH 3/7] mm/hugetlb: Add page_mask for hugetlb_follow_page_mask() Peter Xu
2023-06-15  0:17   ` Mike Kravetz
2023-06-16  8:11   ` David Hildenbrand
2023-06-19 21:43   ` Peter Xu
2023-06-20  7:01     ` David Hildenbrand
2023-06-20 14:40       ` Peter Xu [this message]
2023-06-13 21:53 ` [PATCH 4/7] mm/hugetlb: Prepare hugetlb_follow_page_mask() for FOLL_PIN Peter Xu
2023-06-14 14:57   ` David Hildenbrand
2023-06-14 15:11     ` Peter Xu
2023-06-14 15:17       ` David Hildenbrand
2023-06-14 15:31         ` Peter Xu
2023-06-14 15:47           ` David Hildenbrand
2023-06-14 15:51             ` Peter Xu
2023-06-15  0:25               ` Mike Kravetz
2023-06-15 19:42                 ` Peter Xu
2023-06-13 21:53 ` [PATCH 5/7] mm/gup: Cleanup next_page handling Peter Xu
2023-06-17 19:48   ` Lorenzo Stoakes
2023-06-17 20:00     ` Lorenzo Stoakes
2023-06-19 19:18       ` Peter Xu
2023-06-13 21:53 ` [PATCH 6/7] mm/gup: Accelerate thp gup even for "pages != NULL" Peter Xu
2023-06-14 14:58   ` Matthew Wilcox
2023-06-14 15:19     ` Peter Xu
2023-06-14 15:35       ` Peter Xu
2023-06-17 20:27   ` Lorenzo Stoakes
2023-06-19 19:37     ` Peter Xu
2023-06-19 20:24       ` Peter Xu
2023-06-13 21:53 ` [PATCH 7/7] mm/gup: Retire follow_hugetlb_page() Peter Xu
2023-06-14 14:37   ` Jason Gunthorpe
2023-06-17 20:40   ` Lorenzo Stoakes
2023-06-19 19:41     ` Peter Xu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ZJG6eDZNZFf4Xs7a@x1n \
    --to=peterx@redhat.com \
    --cc=aarcange@redhat.com \
    --cc=akpm@linux-foundation.org \
    --cc=david@redhat.com \
    --cc=hughd@google.com \
    --cc=jhubbard@nvidia.com \
    --cc=jthoughton@google.com \
    --cc=kirill@shutemov.name \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=mike.kravetz@oracle.com \
    --cc=rppt@kernel.org \
    --cc=vbabka@suse.cz \
    --cc=willy@infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.