All of lore.kernel.org
 help / color / mirror / Atom feed
From: Peter Xu <peterx@redhat.com>
To: Jonathan Cameron <Jonathan.Cameron@huawei.com>,
	Paolo Bonzini <pbonzini@redhat.com>
Cc: "Paolo Bonzini" <pbonzini@redhat.com>,
	"David Hildenbrand" <david@redhat.com>,
	"Philippe Mathieu-Daudé" <philmd@linaro.org>,
	qemu-devel@nongnu.org, linuxarm@huawei.com
Subject: Re: [PATCH v2 0/4] physmem: Fix MemoryRegion for second access to cached MMIO Address Space
Date: Fri, 8 Mar 2024 15:36:46 +0800	[thread overview]
Message-ID: <ZerADmIeh6XnbOkG@x1n> (raw)
In-Reply-To: <20240307153710.30907-1-Jonathan.Cameron@huawei.com>

On Thu, Mar 07, 2024 at 03:37:06PM +0000, Jonathan Cameron wrote:
> v2: (Thanks to Peter Xu for reviewing!)
> - New patch 1 to rename addr1 to mr_addr in the interests of meaningful naming.
> - Take advantage of a cached address space only allow for a single MR to simplify
>   the new code.
> - Various cleanups of indentation etc.
> - Cover letter and some patch descriptions updated to reflect changes.
> - Changes all called out in specific patches.

All look good to me, thanks.  Having the new functions' first argument as
MemTxAttrs is slightly weird to me, but that's not a big deal and we can
clean it up later if wanted.  I guess it's good to fix this in 9.0 first as
it's a real bug even if not trivial to hit.

I queued it in my migration tree (with my "memory API" hat..).

I won't send a pull until next Monday.  Please shoot if there's any objections!

-- 
Peter Xu



  parent reply	other threads:[~2024-03-08  7:37 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-03-07 15:37 [PATCH v2 0/4] physmem: Fix MemoryRegion for second access to cached MMIO Address Space Jonathan Cameron via
2024-03-07 15:37 ` [PATCH v2 1/4] physmem: Rename addr1 to more informative mr_addr in flatview_read/write() and similar Jonathan Cameron via
2024-03-07 16:23   ` David Hildenbrand
2024-03-07 15:37 ` [PATCH v2 2/4] physmem: Reduce local variable scope in flatview_read/write_continue() Jonathan Cameron via
2024-03-07 16:23   ` David Hildenbrand
2024-03-07 16:50   ` Philippe Mathieu-Daudé
2024-03-07 15:37 ` [PATCH v2 3/4] physmem: Factor out body of flatview_read/write_continue() loop Jonathan Cameron via
2024-03-07 16:29   ` David Hildenbrand
2024-03-07 15:37 ` [PATCH v2 4/4] physmem: Fix wrong address in large address_space_read/write_cached_slow() Jonathan Cameron via
2024-03-08  8:59   ` David Hildenbrand
2024-03-08  7:36 ` Peter Xu [this message]
2024-03-08  8:59   ` [PATCH v2 0/4] physmem: Fix MemoryRegion for second access to cached MMIO Address Space David Hildenbrand
2024-03-08 16:16   ` Philippe Mathieu-Daudé

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ZerADmIeh6XnbOkG@x1n \
    --to=peterx@redhat.com \
    --cc=Jonathan.Cameron@huawei.com \
    --cc=david@redhat.com \
    --cc=linuxarm@huawei.com \
    --cc=pbonzini@redhat.com \
    --cc=philmd@linaro.org \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.