All of lore.kernel.org
 help / color / mirror / Atom feed
From: Wei Liu <wei.liu@kernel.org>
To: Nuno Das Neves <nunodasneves@linux.microsoft.com>
Cc: linux-hyperv@vger.kernel.org, linux-kernel@vger.kernel.org,
	haiyangz@microsoft.com, mhklinux@outlook.com,
	mhkelley58@gmail.com, kys@microsoft.com, wei.liu@kernel.org,
	decui@microsoft.com, catalin.marinas@arm.com, tglx@linutronix.de,
	daniel.lezcano@linaro.org, arnd@arndb.de
Subject: Re: [PATCH] hyperv-tlfs: Rename some HV_REGISTER_* defines for consistency
Date: Mon, 18 Mar 2024 04:59:16 +0000	[thread overview]
Message-ID: <ZffKJFHFmYRywBHe@liuwe-devbox-debian-v2> (raw)
In-Reply-To: <1710285687-9160-1-git-send-email-nunodasneves@linux.microsoft.com>

On Tue, Mar 12, 2024 at 04:21:27PM -0700, Nuno Das Neves wrote:
> Rename HV_REGISTER_GUEST_OSID to HV_REGISTER_GUEST_OS_ID. This matches
> the existing HV_X64_MSR_GUEST_OS_ID.
> 
> Rename HV_REGISTER_CRASH_* to HV_REGISTER_GUEST_CRASH_*. Including
> GUEST_ is consistent with other #defines such as
> HV_FEATURE_GUEST_CRASH_MSR_AVAILABLE. The new names also match the TLFS
> document more accurately, i.e. HvRegisterGuestCrash*.
> 
> Signed-off-by: Nuno Das Neves <nunodasneves@linux.microsoft.com>

Applied to hyperv-next. Thanks.

      reply	other threads:[~2024-03-18  4:59 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-03-12 23:21 [PATCH] hyperv-tlfs: Rename some HV_REGISTER_* defines for consistency Nuno Das Neves
2024-03-18  4:59 ` Wei Liu [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ZffKJFHFmYRywBHe@liuwe-devbox-debian-v2 \
    --to=wei.liu@kernel.org \
    --cc=arnd@arndb.de \
    --cc=catalin.marinas@arm.com \
    --cc=daniel.lezcano@linaro.org \
    --cc=decui@microsoft.com \
    --cc=haiyangz@microsoft.com \
    --cc=kys@microsoft.com \
    --cc=linux-hyperv@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mhkelley58@gmail.com \
    --cc=mhklinux@outlook.com \
    --cc=nunodasneves@linux.microsoft.com \
    --cc=tglx@linutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.