All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Yann E. MORIN" <yann.morin.1998@free.fr>
To: Arnout Vandecappelle <arnout@mind.be>
Cc: Ricardo Martincoski <ricardo.martincoski@datacom.com.br>,
	buildroot@buildroot.org
Subject: Re: [Buildroot] [PATCH] utils/check-package: emit library name along with check function name
Date: Mon, 1 Apr 2024 15:30:01 +0200	[thread overview]
Message-ID: <Zgq22Vpl4wE52kt4@landeda> (raw)
In-Reply-To: <e00353d3-683e-472e-822c-b6b5d612e6a8@mind.be>

Arnout, All,

On 2024-04-01 15:03 +0200, Arnout Vandecappelle via buildroot spake thusly:
> On 31/03/2024 22:33, Yann E. MORIN wrote:
[--SNIP--]
> > Fix that by storing both the library and function names together. The
> > leading "checkpackagelib." (with the trailing dot, 16 chars) is removed
> > for brevity, because it's present in all libs' names.
[--SNIP--]
> > -    objects = [[c[0], c[1](fname, flags.manual_url)] for c in internal_functions]
> > +    objects = [[f"{lib.__name__[16:]}::{c[0]}", c[1](fname, flags.manual_url)] for c in internal_functions]
>  Bikeshedding time! I think, since this is Python, we shouldn't use the C++
> convention of ::, but rather the Python convention of .

Ah, I don't do C++, so that was not my reference. ;-) I am not a fan of
using a dot, because it does not denote that one part is the filename,
and the other is a function (or any other type of object). But since
this is common pythonistic usage, I'll switch to a dot.

>  Otherwise, you can add my Reviewed-by: Arnout Vandecappelle <arnout@mind.be>

Thanks.

Regards,
Yann E. MORIN.

-- 
.-----------------.--------------------.------------------.--------------------.
|  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
| +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___               |
| +33 561 099 427 `------------.-------:  X  AGAINST      |  \e/  There is no  |
| http://ymorin.is-a-geek.org/ | _/*\_ | / \ HTML MAIL    |   v   conspiracy.  |
'------------------------------^-------^------------------^--------------------'
_______________________________________________
buildroot mailing list
buildroot@buildroot.org
https://lists.buildroot.org/mailman/listinfo/buildroot

  reply	other threads:[~2024-04-01 13:30 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-03-31 20:33 [Buildroot] [PATCH] utils/check-package: emit library name along with check function name Yann E. MORIN
2024-04-01 13:03 ` Arnout Vandecappelle via buildroot
2024-04-01 13:30   ` Yann E. MORIN [this message]
2024-04-01 18:54 ` Yann E. MORIN

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Zgq22Vpl4wE52kt4@landeda \
    --to=yann.morin.1998@free.fr \
    --cc=arnout@mind.be \
    --cc=buildroot@buildroot.org \
    --cc=ricardo.martincoski@datacom.com.br \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.