All of lore.kernel.org
 help / color / mirror / Atom feed
From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
To: Raag Jadav <raag.jadav@intel.com>
Cc: "Uwe Kleine-König" <u.kleine-koenig@pengutronix.de>,
	jarkko.nikula@linux.intel.com, mika.westerberg@linux.intel.com,
	linux-pwm@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v1] pwm: dwc: allow suspend/resume for 16 channels
Date: Fri, 12 Apr 2024 18:45:48 +0300	[thread overview]
Message-ID: <ZhlXLNlsHEWrxEjF@smile.fi.intel.com> (raw)
In-Reply-To: <Zhk-7Tp4HzF41Is5@black.fi.intel.com>

On Fri, Apr 12, 2024 at 06:38:24PM +0300, Raag Jadav wrote:
> On Fri, Apr 12, 2024 at 01:12:48PM +0200, Uwe Kleine-König wrote:
> > On Fri, Apr 12, 2024 at 11:38:12AM +0530, Raag Jadav wrote:

...

> > Otherwise I (only slightly) dislike
> > > +	struct dwc_pwm_drvdata *data;
> > because "data" is very generic. I'd call it ddata. But I don't feel
> > strong here. I'm happy if you change to "ddata" in v2, I will silently
> > apply anyhow if you prefer "data".
> 
> I think "data" is more readable, something like "ddata" would make me
> re-adjust my glasses ;)

ddata is _kinda_ idiomatic, there at least several drivers use this name
(as of my knowledge). I am bending towards Uwe's suggestion here.

-- 
With Best Regards,
Andy Shevchenko



  reply	other threads:[~2024-04-12 15:45 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-04-12  6:08 [PATCH v1] pwm: dwc: allow suspend/resume for 16 channels Raag Jadav
2024-04-12 11:12 ` Uwe Kleine-König
2024-04-12 15:32   ` Andy Shevchenko
2024-04-12 16:57     ` Uwe Kleine-König
2024-04-12 15:38   ` Raag Jadav
2024-04-12 15:45     ` Andy Shevchenko [this message]
2024-04-12 16:12       ` Raag Jadav
2024-04-12 15:35 ` Andy Shevchenko
2024-04-12 16:15   ` Raag Jadav
2024-04-12 16:45     ` Andy Shevchenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ZhlXLNlsHEWrxEjF@smile.fi.intel.com \
    --to=andriy.shevchenko@linux.intel.com \
    --cc=jarkko.nikula@linux.intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pwm@vger.kernel.org \
    --cc=mika.westerberg@linux.intel.com \
    --cc=raag.jadav@intel.com \
    --cc=u.kleine-koenig@pengutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.