From: Jiri Olsa <olsajiri@gmail.com>
To: Andrii Nakryiko <andrii@kernel.org>
Cc: bpf@vger.kernel.org, linux-mm@kvack.org,
akpm@linux-foundation.org, adobriyan@gmail.com,
shakeel.butt@linux.dev, hannes@cmpxchg.org, ak@linux.intel.com,
osandov@osandov.com, song@kernel.org
Subject: Re: [PATCH v2 bpf-next 01/10] lib/buildid: add single page-based file reader abstraction
Date: Thu, 25 Jul 2024 14:03:47 +0200 [thread overview]
Message-ID: <ZqI_I2iDLwNTJy4h@krava> (raw)
In-Reply-To: <20240724225210.545423-2-andrii@kernel.org>
On Wed, Jul 24, 2024 at 03:52:01PM -0700, Andrii Nakryiko wrote:
SNIP
> +static int freader_get_page(struct freader *r, u64 file_off)
> +{
> + pgoff_t pg_off = file_off >> PAGE_SHIFT;
> +
> + freader_put_page(r);
> +
> + r->page = find_get_page(r->mapping, pg_off);
> + if (!r->page)
> + return -EFAULT; /* page not mapped */
> +
> + r->page_addr = kmap_local_page(r->page);
> + r->file_off = file_off & PAGE_MASK;
> +
> + return 0;
> +}
> +
> +static const void *freader_fetch(struct freader *r, u64 file_off, size_t sz)
> +{
> + int err;
> +
> + /* provided internal temporary buffer should be sized correctly */
> + if (WARN_ON(r->buf && sz > r->buf_sz)) {
> + r->err = -E2BIG;
> + return NULL;
> + }
what's the benefit of having err, would it be easier just to return
error pointer like ERR_PTR(-E2BIG)
SNIP
> +static void freader_cleanup(struct freader *r)
> +{
> + freader_put_page(r);
> +}
> +
> /*
> * Parse build id from the note segment. This logic can be shared between
> * 32-bit and 64-bit system, because Elf32_Nhdr and Elf64_Nhdr are
> * identical.
> */
> -static int parse_build_id_buf(unsigned char *build_id,
> - __u32 *size,
> - const void *note_start,
> - Elf32_Word note_size)
> +static int parse_build_id_buf(struct freader *r,
> + unsigned char *build_id, __u32 *size,
> + u64 note_offs, Elf32_Word note_size)
> {
> - Elf32_Word note_offs = 0, new_offs;
> + const char note_name[] = "GNU";
could be static ?
SNIP
> int build_id_parse_buf(const void *buf, unsigned char *build_id, u32 buf_size)
> {
> - return parse_build_id_buf(build_id, NULL, buf, buf_size);
> + struct freader r;
> +
> + freader_init_from_mem(&r, buf, buf_size);
> +
> + return parse_build_id_buf(&r, build_id, NULL, 0, buf_size);
could use a coment in here why freader_cleanup is not needed
jirka
> }
>
> #if IS_ENABLED(CONFIG_STACKTRACE_BUILD_ID) || IS_ENABLED(CONFIG_VMCORE_INFO)
> --
> 2.43.0
>
>
next prev parent reply other threads:[~2024-07-25 12:03 UTC|newest]
Thread overview: 35+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-07-24 22:52 [PATCH v2 bpf-next 00/10] Harden and extend ELF build ID parsing logic Andrii Nakryiko
2024-07-24 22:52 ` [PATCH v2 bpf-next 01/10] lib/buildid: add single page-based file reader abstraction Andrii Nakryiko
2024-07-25 12:03 ` Jiri Olsa [this message]
2024-07-25 19:58 ` Andrii Nakryiko
2024-07-26 12:31 ` Jiri Olsa
2024-07-25 22:43 ` Andi Kleen
2024-07-27 0:26 ` Andrii Nakryiko
2024-07-24 22:52 ` [PATCH v2 bpf-next 02/10] lib/buildid: take into account e_phoff when fetching program headers Andrii Nakryiko
2024-07-25 12:03 ` Jiri Olsa
2024-07-25 19:59 ` Andrii Nakryiko
2024-07-25 22:45 ` Andi Kleen
2024-07-27 0:30 ` Andrii Nakryiko
2024-07-24 22:52 ` [PATCH v2 bpf-next 03/10] lib/buildid: remove single-page limit for PHDR search Andrii Nakryiko
2024-07-24 22:52 ` [PATCH v2 bpf-next 04/10] lib/buildid: rename build_id_parse() into build_id_parse_nofault() Andrii Nakryiko
2024-07-24 22:52 ` [PATCH v2 bpf-next 05/10] lib/buildid: implement sleepable build_id_parse() API Andrii Nakryiko
2024-07-25 22:46 ` Andi Kleen
2024-07-27 0:36 ` Andrii Nakryiko
2024-07-24 22:52 ` [PATCH v2 bpf-next 06/10] lib/buildid: don't limit .note.gnu.build-id to the first page in ELF Andrii Nakryiko
2024-07-24 22:52 ` [PATCH v2 bpf-next 07/10] lib/buildid: harden build ID parsing logic some more Andrii Nakryiko
2024-07-29 16:15 ` Jann Horn
2024-07-29 16:57 ` Andrii Nakryiko
2024-07-24 22:52 ` [PATCH v2 bpf-next 08/10] bpf: decouple stack_map_get_build_id_offset() from perf_callchain_entry Andrii Nakryiko
2024-07-24 22:52 ` [PATCH v2 bpf-next 09/10] bpf: wire up sleepable bpf_get_stack() and bpf_get_task_stack() helpers Andrii Nakryiko
2024-07-24 22:52 ` [PATCH v2 bpf-next 10/10] selftests/bpf: add build ID tests Andrii Nakryiko
2024-07-25 12:04 ` Jiri Olsa
2024-07-25 20:01 ` Andrii Nakryiko
2024-07-25 12:12 ` Jiri Olsa
2024-07-25 20:03 ` Andrii Nakryiko
2024-07-26 12:27 ` Jiri Olsa
2024-07-27 0:37 ` Andrii Nakryiko
2024-07-28 19:38 ` Jiri Olsa
2024-07-30 20:03 ` Andrii Nakryiko
2024-07-30 20:18 ` Jiri Olsa
2025-09-10 6:09 ` Saket Kumar Bhaskar
2025-09-10 14:18 ` Andrii Nakryiko
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ZqI_I2iDLwNTJy4h@krava \
--to=olsajiri@gmail.com \
--cc=adobriyan@gmail.com \
--cc=ak@linux.intel.com \
--cc=akpm@linux-foundation.org \
--cc=andrii@kernel.org \
--cc=bpf@vger.kernel.org \
--cc=hannes@cmpxchg.org \
--cc=linux-mm@kvack.org \
--cc=osandov@osandov.com \
--cc=shakeel.butt@linux.dev \
--cc=song@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.