All of lore.kernel.org
 help / color / mirror / Atom feed
From: Robert Richter <rrichter@amd.com>
To: Jonathan Cameron <Jonathan.Cameron@huawei.com>
Cc: Alison Schofield <alison.schofield@intel.com>,
	Vishal Verma <vishal.l.verma@intel.com>,
	Ira Weiny <ira.weiny@intel.com>,
	Dan Williams <dan.j.williams@intel.com>,
	Dave Jiang <dave.jiang@intel.com>,
	Davidlohr Bueso <dave@stgolabs.net>,
	linux-cxl@vger.kernel.org, linux-kernel@vger.kernel.org,
	Gregory Price <gourry@gourry.net>,
	"Fabio M. De Francesco" <fabio.m.de.francesco@linux.intel.com>,
	Terry Bowman <terry.bowman@amd.com>
Subject: Re: [PATCH v4 03/14] cxl/pci: Add comments to cxl_hdm_decode_init()
Date: Thu, 17 Apr 2025 15:11:06 +0200	[thread overview]
Message-ID: <aAD96vV3eSb481pM@rric.localdomain> (raw)
In-Reply-To: <20250314113337.000054b6@huawei.com>

On 14.03.25 11:33:37, Jonathan Cameron wrote:
> On Thu, 6 Mar 2025 17:44:37 +0100
> Robert Richter <rrichter@amd.com> wrote:
> 
> > There are various configuration cases of HDM decoder registers causing
> > different code paths. Add comments to cxl_hdm_decode_init() to better
> > explain them.
> > 
> > Signed-off-by: Robert Richter <rrichter@amd.com>
> > Tested-by: Gregory Price <gourry@gourry.net>
> Trivial comment inline.
> Otherwise I think this is fine.
> Reviewed-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>

> > +	/*
> > +	 * The HDM Decoder Capability exists but is globally disabled.
> 
> Single line comment syntax appropriate here.
> 
> > +	 */

Changed that.

Thanks for review.

-Robert

  reply	other threads:[~2025-04-17 13:11 UTC|newest]

Thread overview: 52+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-03-06 16:44 [PATCH v4 00/14] cxl: Address translation support, part 1: Cleanups and refactoring Robert Richter
2025-03-06 16:44 ` [PATCH v4 01/14] cxl: Remove else after return Robert Richter
2025-03-14 11:27   ` Jonathan Cameron
2025-04-15 21:27   ` Alison Schofield
2025-04-18 16:23   ` Fabio M. De Francesco
2025-03-06 16:44 ` [PATCH v4 02/14] cxl/pci: Moving code in cxl_hdm_decode_init() Robert Richter
2025-03-14 11:31   ` Jonathan Cameron
2025-04-15 21:29   ` Alison Schofield
2025-04-18 16:28   ` Fabio M. De Francesco
2025-03-06 16:44 ` [PATCH v4 03/14] cxl/pci: Add comments to cxl_hdm_decode_init() Robert Richter
2025-03-14 11:33   ` Jonathan Cameron
2025-04-17 13:11     ` Robert Richter [this message]
2025-04-15 21:30   ` Alison Schofield
2025-04-17 13:48   ` Gregory Price
2025-04-18 16:34   ` Fabio M. De Francesco
2025-03-06 16:44 ` [PATCH v4 04/14] cxl: Introduce parent_port_of() helper Robert Richter
2025-03-06 18:57   ` Dan Williams
2025-04-15 21:30   ` Alison Schofield
2025-04-21 17:49   ` Fabio M. De Francesco
2025-03-06 16:44 ` [PATCH v4 05/14] cxl/region: Rename function to cxl_find_decoder_early() Robert Richter
2025-03-06 19:51   ` Dan Williams
2025-03-06 16:44 ` [PATCH v4 06/14] cxl/region: Avoid duplicate call of cxl_find_decoder_early() Robert Richter
2025-03-06 20:01   ` Dan Williams
2025-03-06 16:44 ` [PATCH v4 07/14] cxl/region: Move find_cxl_root() to cxl_add_to_region() Robert Richter
2025-03-06 20:14   ` Dan Williams
2025-04-15 21:32   ` Alison Schofield
2025-04-21 21:21   ` Fabio M. De Francesco
2025-03-06 16:44 ` [PATCH v4 08/14] cxl/region: Factor out code to find the root decoder Robert Richter
2025-03-06 20:35   ` Dan Williams
2025-04-15 21:32   ` Alison Schofield
2025-04-22 16:09   ` Fabio M. De Francesco
2025-03-06 16:44 ` [PATCH v4 09/14] cxl/region: Factor out code to find a root decoder's region Robert Richter
2025-03-06 20:37   ` Dan Williams
2025-04-15 21:33   ` Alison Schofield
2025-04-23 15:32   ` Fabio M. De Francesco
2025-03-06 16:44 ` [PATCH v4 10/14] cxl/region: Add function to find a port's switch decoder by range Robert Richter
2025-03-06 20:55   ` Dan Williams
2025-03-06 16:44 ` [PATCH v4 11/14] cxl/region: Add a dev_warn() on registration failure Robert Richter
2025-03-06 20:57   ` Dan Williams
2025-04-15 21:34   ` Alison Schofield
2025-04-23 20:49   ` Fabio M. De Francesco
2025-03-06 16:44 ` [PATCH v4 12/14] cxl/region: Add a dev_err() on missing target list entries Robert Richter
2025-03-06 20:58   ` Dan Williams
2025-04-15 21:35   ` Alison Schofield
2025-04-23 20:50   ` Fabio M. De Francesco
2025-03-06 16:44 ` [PATCH v4 13/14] cxl: Add a dev_dbg() when a decoder was added to a port Robert Richter
2025-03-06 21:06   ` Dan Williams
2025-04-29 13:43     ` Robert Richter
2025-04-15 21:36   ` Alison Schofield
2025-03-06 16:44 ` [PATCH v4 14/14] cxl/acpi: Unify CFMWS memory log messages with SRAT messages Robert Richter
2025-03-06 21:12   ` Dan Williams
2025-04-15 23:23 ` [PATCH v4 00/14] cxl: Address translation support, part 1: Cleanups and refactoring Alison Schofield

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=aAD96vV3eSb481pM@rric.localdomain \
    --to=rrichter@amd.com \
    --cc=Jonathan.Cameron@huawei.com \
    --cc=alison.schofield@intel.com \
    --cc=dan.j.williams@intel.com \
    --cc=dave.jiang@intel.com \
    --cc=dave@stgolabs.net \
    --cc=fabio.m.de.francesco@linux.intel.com \
    --cc=gourry@gourry.net \
    --cc=ira.weiny@intel.com \
    --cc=linux-cxl@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=terry.bowman@amd.com \
    --cc=vishal.l.verma@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.