From: Oscar Salvador <osalvador@suse.de>
To: David Hildenbrand <david@redhat.com>
Cc: Donet Tom <donettom@linux.ibm.com>,
akpm@linux-foundation.org, clm@meta.com,
Jonathan.Cameron@huawei.com, alison.schofield@intel.com,
dakr@kernel.org, dave.jiang@intel.com,
gregkh@linuxfoundation.org, kamezawa.hiroyu@jp.fujitsu.com,
linux-kernel@vger.kernel.org, linux-mm@kvack.org,
rafael@kernel.org, ritesh.list@gmail.com, yury.norov@gmail.com,
ziy@nvidia.com
Subject: Re: [PATCH] drivers/base/node: Fix double free in register_one_node()
Date: Thu, 18 Sep 2025 15:28:18 +0200 [thread overview]
Message-ID: <aMwI8n2-w1J_AOiD@localhost.localdomain> (raw)
In-Reply-To: <5512b1b6-31f8-4322-8a5f-add8d1e9b22f@redhat.com>
On Thu, Sep 18, 2025 at 07:55:07AM +0200, David Hildenbrand wrote:
> Yes, that matches what other users (staring at mm/memory-tiers.c) do.
>
> I wonder if we should just inline register_node() into register_one_node().
>
> Then it's clearer that we perform a put_device() already in there.
>
> On top of that, we could then just s/register_one_node/register_node/
>
> And then we could do a similar cleanup for unregister_one_node /
> unregister_node where I don't consider the split function really valuable.
Yap, that makes sense to me as well.
--
Oscar Salvador
SUSE Labs
next prev parent reply other threads:[~2025-09-18 13:28 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-09-18 5:41 [PATCH] drivers/base/node: Fix double free in register_one_node() Donet Tom
2025-09-18 5:55 ` David Hildenbrand
2025-09-18 5:56 ` David Hildenbrand
2025-09-18 6:45 ` Donet Tom
2025-09-18 13:28 ` Oscar Salvador [this message]
2025-09-18 13:29 ` Oscar Salvador
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=aMwI8n2-w1J_AOiD@localhost.localdomain \
--to=osalvador@suse.de \
--cc=Jonathan.Cameron@huawei.com \
--cc=akpm@linux-foundation.org \
--cc=alison.schofield@intel.com \
--cc=clm@meta.com \
--cc=dakr@kernel.org \
--cc=dave.jiang@intel.com \
--cc=david@redhat.com \
--cc=donettom@linux.ibm.com \
--cc=gregkh@linuxfoundation.org \
--cc=kamezawa.hiroyu@jp.fujitsu.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=rafael@kernel.org \
--cc=ritesh.list@gmail.com \
--cc=yury.norov@gmail.com \
--cc=ziy@nvidia.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.