From: Imre Deak <imre.deak@intel.com>
To: Dmitry Baryshkov <dmitry.baryshkov@oss.qualcomm.com>
Cc: intel-gfx@lists.freedesktop.org, intel-xe@lists.freedesktop.org,
dri-devel@lists.freedesktop.org,
"Ville Syrjälä" <ville.syrjala@linux.intel.com>
Subject: Re: [PATCH v5 2/6] drm/dp: Add helpers to query the branch DSC max throughput/line-width
Date: Tue, 30 Sep 2025 14:38:09 +0300 [thread overview]
Message-ID: <aNvBIdJbaCBzKVt_@ideak-desk> (raw)
In-Reply-To: <6qj46wruaj5k2ywepsrkzfyyq4bsvcfmg7jhvrk4w2jkhcyorg@llo7bzmlarre>
On Tue, Sep 30, 2025 at 08:30:10AM +0300, Dmitry Baryshkov wrote:
> On Mon, Sep 29, 2025 at 01:10:17PM +0300, Imre Deak wrote:
> > On Mon, Sep 29, 2025 at 12:00:03PM +0300, Dmitry Baryshkov wrote:
> > > On Mon, Sep 29, 2025 at 09:36:44AM +0300, Imre Deak wrote:
> > > > Add helpers to query the DP DSC sink device's per-slice throughput as
> > > > well as a DSC branch device's overall throughput and line-width
> > > > capabilities.
> > > >
> > > > v2 (Ville):
> > > > - Rename pixel_clock to peak_pixel_rate, document what the value means
> > > > in case of MST tiled displays.
> > > > - Fix name of drm_dp_dsc_branch_max_slice_throughput() to
> > > > drm_dp_dsc_sink_max_slice_throughput().
> > > > v3:
> > > > - Fix the DSC branch device minimum valid line width value from 2560
> > > > to 5120 pixels.
> > > > - Fix drm_dp_dsc_sink_max_slice_throughput()'s pixel_clock parameter
> > > > name to peak_pixel_rate in header file.
> > > > - Add handling for throughput mode 0 granular delta, defined by DP
> > > > Standard v2.1a.
> > >
> > > This one got sent as a separate V5, without a proper changelog. What has
> > > changed?
> >
> > This is v3 of the patch, the changes are listed under v3. The patchset's
> > version is v5.
>
> Ugh. How one does relate this v3 (which is not mentioned anywhere) and
> v5 of the series? This is totally counterintuitive. A usual
> recommendation is to send the full series and to send it as a new
> thread, sending all the patches in one go.
It's a common practice on intel-gfx to send a new version of one patch
on top of the last patchset version in that patchset's thread. For
matching the patch version to the patchset version I can change the
patch version log above to be like:
v2 (Ville):
- Rename pixel_clock to peak_pixel_rate ...
v3-v4:
- No changes
v5:
- Fix the DSC branch device minimum valid line width value ...
> > > > Cc: dri-devel@lists.freedesktop.org
> > > > Suggested-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
> > > > Signed-off-by: Imre Deak <imre.deak@intel.com>
> > > > ---
> > > > drivers/gpu/drm/display/drm_dp_helper.c | 156 ++++++++++++++++++++++++
> > > > include/drm/display/drm_dp.h | 3 +
> > > > include/drm/display/drm_dp_helper.h | 5 +
> > > > 3 files changed, 164 insertions(+)
> > > >
> > >
> > > --
> > > With best wishes
> > > Dmitry
>
> --
> With best wishes
> Dmitry
next prev parent reply other threads:[~2025-09-30 11:38 UTC|newest]
Thread overview: 29+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-09-26 21:12 [PATCH v4 0/6] drm/i915/dp: Work around a DSC pixel throughput issue Imre Deak
2025-09-26 21:12 ` [PATCH v4 1/6] drm/dp: Add quirk for Synaptics DSC throughput link-bpp limit Imre Deak
2025-09-26 21:12 ` [PATCH v4 2/6] drm/dp: Add helpers to query the branch DSC max throughput/line-width Imre Deak
2025-09-29 6:36 ` [PATCH v5 " Imre Deak
2025-09-29 9:00 ` Dmitry Baryshkov
2025-09-29 10:10 ` Imre Deak
2025-09-30 5:30 ` Dmitry Baryshkov
2025-09-30 11:38 ` Imre Deak [this message]
2025-09-30 20:04 ` Dmitry Baryshkov
2025-09-30 21:03 ` Imre Deak
2025-09-29 10:12 ` Ville Syrjälä
2025-09-29 10:47 ` Imre Deak
2025-09-26 21:12 ` [PATCH v4 3/6] drm/i915/dp: Calculate DSC slice count based on per-slice peak throughput Imre Deak
2025-09-26 21:12 ` [PATCH v4 4/6] drm/i915/dp: Pass DPCD device descriptor to intel_dp_get_dsc_sink_cap() Imre Deak
2025-09-26 21:12 ` [PATCH v4 5/6] drm/i915/dp: Verify branch devices' overall pixel throughput/line width Imre Deak
2025-09-26 21:12 ` [PATCH v4 6/6] drm/i915/dp: Handle Synaptics DSC throughput link-bpp quirk Imre Deak
2025-09-26 21:56 ` ✗ CI.checkpatch: warning for drm/i915/dp: Work around a DSC pixel throughput issue (rev5) Patchwork
2025-09-26 21:57 ` ✓ CI.KUnit: success " Patchwork
2025-09-26 22:04 ` ✓ i915.CI.BAT: " Patchwork
2025-09-26 22:33 ` ✓ Xe.CI.BAT: " Patchwork
2025-09-27 3:08 ` ✓ i915.CI.Full: " Patchwork
2025-09-27 5:36 ` ✗ Xe.CI.Full: failure " Patchwork
2025-09-29 7:12 ` ✗ CI.checkpatch: warning for drm/i915/dp: Work around a DSC pixel throughput issue (rev6) Patchwork
2025-09-29 7:13 ` ✓ CI.KUnit: success " Patchwork
2025-09-29 7:24 ` ✓ i915.CI.BAT: " Patchwork
2025-09-29 9:02 ` ✗ i915.CI.Full: failure " Patchwork
2025-09-29 9:22 ` ✓ Xe.CI.BAT: success " Patchwork
2025-09-29 9:40 ` ✓ Xe.CI.Full: " Patchwork
2025-09-29 21:47 ` [PATCH v4 0/6] drm/i915/dp: Work around a DSC pixel throughput issue Sharma, Swati2
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=aNvBIdJbaCBzKVt_@ideak-desk \
--to=imre.deak@intel.com \
--cc=dmitry.baryshkov@oss.qualcomm.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=intel-gfx@lists.freedesktop.org \
--cc=intel-xe@lists.freedesktop.org \
--cc=ville.syrjala@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.