From: "Luck, Tony" <tony.luck@intel.com>
To: Reinette Chatre <reinette.chatre@intel.com>
Cc: Fenghua Yu <fenghuay@nvidia.com>,
Maciej Wieczor-Retman <maciej.wieczor-retman@intel.com>,
Peter Newman <peternewman@google.com>,
James Morse <james.morse@arm.com>,
Babu Moger <babu.moger@amd.com>,
"Drew Fustini" <dfustini@baylibre.com>,
Dave Martin <Dave.Martin@arm.com>, Chen Yu <yu.c.chen@intel.com>,
<x86@kernel.org>, <linux-kernel@vger.kernel.org>,
<patches@lists.linux.dev>
Subject: Re: [PATCH v12 20/31] fs/resctrl: Refactor mkdir_mondata_subdir()
Date: Tue, 28 Oct 2025 11:40:33 -0700 [thread overview]
Message-ID: <aQEOIfMFo1Dqv-sP@agluck-desk3> (raw)
In-Reply-To: <820cd2b6-b71b-435b-bc67-c35318f869e2@intel.com>
On Tue, Oct 28, 2025 at 10:40:44AM -0700, Reinette Chatre wrote:
> Modifying mon_add_all_files() sounds good. I assume the node activation (kernfs_active())
> will still be done by the caller which would have this new function return a struct kernfs_node *?
> If so, I think it will make code easier to read if name implies that a new kn is created.
> Since the caller is already mkdir_mondata_subdir(), what do you think of _mkdir_mondata_subdir()?
Reinette,
This section of fs/resctrl/rdtgroup.c now looks like this. Call sites
are now free of duplicated code. Thanks for the nudge to do this.
-Tony
---
/*
* Create a directory for a domain and populate it with monitor files.
*/
static struct kernfs_node *_mkdir_mondata_subdir(struct kernfs_node *parent_kn, char *name,
struct rdt_domain_hdr *hdr,
struct rdt_resource *r,
struct rdtgroup *prgrp, int domid)
{
struct rmid_read rr = {0};
struct kernfs_node *kn;
struct mon_data *priv;
struct mon_evt *mevt;
int ret;
kn = kernfs_create_dir(parent_kn, name, parent_kn->mode, prgrp);
if (IS_ERR(kn))
return kn;
ret = rdtgroup_kn_set_ugid(kn);
if (ret)
goto out_destroy;
for_each_mon_event(mevt) {
if (mevt->rid != r->rid || !mevt->enabled)
continue;
priv = mon_get_kn_priv(r->rid, domid, mevt, !hdr);
if (WARN_ON_ONCE(!priv)) {
ret = -EINVAL;
goto out_destroy;
}
ret = mon_addfile(kn, mevt->name, priv);
if (ret)
goto out_destroy;
if (hdr && resctrl_is_mbm_event(mevt->evtid))
mon_event_read(&rr, r, hdr, prgrp, &hdr->cpu_mask, mevt, true);
}
return kn;
out_destroy:
kernfs_remove(kn);
return ERR_PTR(ret);
}
static int mkdir_mondata_subdir_snc(struct kernfs_node *parent_kn,
struct rdt_domain_hdr *hdr,
struct rdt_resource *r, struct rdtgroup *prgrp)
{
struct kernfs_node *ckn, *kn;
struct rdt_l3_mon_domain *d;
char name[32];
if (!domain_header_is_valid(hdr, RESCTRL_MON_DOMAIN, RDT_RESOURCE_L3))
return -EINVAL;
d = container_of(hdr, struct rdt_l3_mon_domain, hdr);
sprintf(name, "mon_%s_%02d", r->name, d->ci_id);
kn = kernfs_find_and_get(parent_kn, name);
if (kn) {
/*
* rdtgroup_mutex will prevent this directory from being
* removed. No need to keep this hold.
*/
kernfs_put(kn);
} else {
kn = _mkdir_mondata_subdir(parent_kn, name, NULL, r, prgrp, d->ci_id);
if (IS_ERR(kn))
return PTR_ERR(kn);
}
sprintf(name, "mon_sub_%s_%02d", r->name, hdr->id);
ckn = _mkdir_mondata_subdir(kn, name, hdr, r, prgrp, hdr->id);
if (IS_ERR(ckn)) {
kernfs_remove(kn);
return PTR_ERR(ckn);
}
kernfs_activate(kn);
return 0;
}
static int mkdir_mondata_subdir(struct kernfs_node *parent_kn,
struct rdt_domain_hdr *hdr,
struct rdt_resource *r, struct rdtgroup *prgrp)
{
struct kernfs_node *kn;
char name[32];
lockdep_assert_held(&rdtgroup_mutex);
if (r->rid == RDT_RESOURCE_L3 && r->mon_scope == RESCTRL_L3_NODE)
return mkdir_mondata_subdir_snc(parent_kn, hdr, r, prgrp);
sprintf(name, "mon_%s_%02d", r->name, hdr->id);
kn = _mkdir_mondata_subdir(parent_kn, name, hdr, r, prgrp, hdr->id);
if (IS_ERR(kn))
return PTR_ERR(kn);
kernfs_activate(kn);
return 0;
}
next prev parent reply other threads:[~2025-10-28 18:40 UTC|newest]
Thread overview: 64+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-10-13 22:33 [PATCH v12 00/31] x86,fs/resctrl telemetry monitoring Tony Luck
2025-10-13 22:33 ` [PATCH v12 01/31] x86,fs/resctrl: Improve domain type checking Tony Luck
2025-10-23 4:07 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 02/31] x86/resctrl: Move L3 initialization into new helper function Tony Luck
2025-10-13 22:33 ` [PATCH v12 03/31] x86/resctrl: Refactor domain_remove_cpu_mon() ready for new domain types Tony Luck
2025-10-23 4:08 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 04/31] x86/resctrl: Clean up domain_remove_cpu_ctrl() Tony Luck
2025-10-13 22:33 ` [PATCH v12 05/31] x86,fs/resctrl: Refactor domain create/remove using struct rdt_domain_hdr Tony Luck
2025-10-23 4:15 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 06/31] x86,fs/resctrl: Use struct rdt_domain_hdr when reading counters Tony Luck
2025-10-23 4:17 ` Reinette Chatre
2025-10-23 20:27 ` Luck, Tony
2025-10-13 22:33 ` [PATCH v12 07/31] x86,fs/resctrl: Rename struct rdt_mon_domain and rdt_hw_mon_domain Tony Luck
2025-10-23 4:18 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 08/31] x86,fs/resctrl: Rename some L3 specific functions Tony Luck
2025-10-23 4:21 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 09/31] fs/resctrl: Make event details accessible to functions when reading events Tony Luck
2025-10-13 22:33 ` [PATCH v12 10/31] x86,fs/resctrl: Handle events that can be read from any CPU Tony Luck
2025-10-23 4:22 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 11/31] x86,fs/resctrl: Support binary fixed point event counters Tony Luck
2025-10-13 22:33 ` [PATCH v12 12/31] x86,fs/resctrl: Add an architectural hook called for each mount Tony Luck
2025-10-13 22:33 ` [PATCH v12 13/31] x86,fs/resctrl: Add and initialize rdt_resource for package scope monitor Tony Luck
2025-10-23 4:33 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 14/31] x86/resctrl: Discover hardware telemetry events Tony Luck
2025-10-23 4:28 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 15/31] x86,fs/resctrl: Fill in details of events for guid 0x26696143 and 0x26557651 Tony Luck
2025-10-23 4:28 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 16/31] x86,fs/resctrl: Add architectural event pointer Tony Luck
2025-10-23 4:34 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 17/31] x86/resctrl: Find and enable usable telemetry events Tony Luck
2025-10-23 4:35 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 18/31] fs/resctrl: Split L3 dependent parts out of __mon_event_count() Tony Luck
2025-10-23 4:37 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 19/31] x86/resctrl: Read telemetry events Tony Luck
2025-10-23 4:47 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 20/31] fs/resctrl: Refactor mkdir_mondata_subdir() Tony Luck
2025-10-23 17:45 ` Reinette Chatre
2025-10-27 23:00 ` Luck, Tony
2025-10-28 16:00 ` Reinette Chatre
2025-10-28 17:14 ` Luck, Tony
2025-10-28 17:40 ` Reinette Chatre
2025-10-28 18:40 ` Luck, Tony [this message]
2025-10-28 23:55 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 21/31] fs/resctrl: Refactor rmdir_mondata_subdir_allrdtgrp() Tony Luck
2025-10-23 17:45 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 22/31] x86,fs/resctrl: Handle domain creation/deletion for RDT_RESOURCE_PERF_PKG Tony Luck
2025-10-23 17:46 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 23/31] x86/resctrl: Add energy/perf choices to rdt boot option Tony Luck
2025-10-23 17:45 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 24/31] x86/resctrl: Handle number of RMIDs supported by RDT_RESOURCE_PERF_PKG Tony Luck
2025-10-23 17:48 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 25/31] fs/resctrl: Move allocation/free of closid_num_dirty_rmid[] Tony Luck
2025-10-23 17:49 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 26/31] x86,fs/resctrl: Compute number of RMIDs as minimum across resources Tony Luck
2025-10-13 22:33 ` [PATCH v12 27/31] fs/resctrl: Move RMID initialization to first mount Tony Luck
2025-10-23 17:49 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 28/31] x86/resctrl: Enable RDT_RESOURCE_PERF_PKG Tony Luck
2025-10-23 17:50 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 29/31] fs/resctrl: Provide interface to create architecture specific debugfs area Tony Luck
2025-10-23 17:50 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 30/31] x86/resctrl: Add debugfs files to show telemetry aggregator status Tony Luck
2025-10-23 17:50 ` Reinette Chatre
2025-10-13 22:33 ` [PATCH v12 31/31] x86,fs/resctrl: Update documentation for telemetry events Tony Luck
2025-10-23 17:52 ` Reinette Chatre
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=aQEOIfMFo1Dqv-sP@agluck-desk3 \
--to=tony.luck@intel.com \
--cc=Dave.Martin@arm.com \
--cc=babu.moger@amd.com \
--cc=dfustini@baylibre.com \
--cc=fenghuay@nvidia.com \
--cc=james.morse@arm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=maciej.wieczor-retman@intel.com \
--cc=patches@lists.linux.dev \
--cc=peternewman@google.com \
--cc=reinette.chatre@intel.com \
--cc=x86@kernel.org \
--cc=yu.c.chen@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.