All of lore.kernel.org
 help / color / mirror / Atom feed
From: Dan Carpenter <dan.carpenter@linaro.org>
To: Julioccps <julio191096@gmail.com>
Cc: hvaibhav.linux@gmail.com, johan@kernel.org, elder@kernel.org,
	gregkh@linuxfoundation.org, greybus-dev@lists.linaro.org,
	linux-staging@lists.linux.dev, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3] staging: greybus: arche-apb-ctrl: switch to device_property_read_bool
Date: Fri, 5 Dec 2025 10:26:36 +0300	[thread overview]
Message-ID: <aTKJLAZaPjEcS17l@stanley.mountain> (raw)
In-Reply-To: <20251204231110.65847-1-julio191096@gmail.com>

On Thu, Dec 04, 2025 at 08:11:10PM -0300, Julioccps wrote:
> Switch from the deprecated of_property_read_bool() to the common
> device_property_read_bool() API. This makes the driver agnostic to
> the underlying firmware interface (DT or ACPI) and simplifies the
> logic.
> 
> Since the driver is no longer strictly dependent on Device Tree,
> include <linux/mod_devicetable.h> directly for the struct
> of_device_id definition, instead of relying on implicit inclusion
> via <linux/of_irq.h>, which has been removed as it is unused.
> 
> Also rename apb_ctrl_get_devtree_data() to apb_ctrl_get_fw_data()
> to better reflect the agnostic nature of the new implementation.
> 
> Signed-off-by: Julio Cesar Carvalho de Paula Souza <julio191096@gmail.com>

This doesn't match your From header.

> ---
> hanges in v3:
>   - Added version history (changelog) required by the subsystem maintainer.
> 
> Changes in v2:
>   - Updated the subject line to match the subsystem standard.
>   - Updated Signed-off-by to use full real name.
> 
>  drivers/staging/greybus/arche-apb-ctrl.c | 11 ++++++-----
>  1 file changed, 6 insertions(+), 5 deletions(-)
> 
> diff --git a/drivers/staging/greybus/arche-apb-ctrl.c b/drivers/staging/greybus/arche-apb-ctrl.c
> index 90ab32638d3f..eea9648a461c 100644
> --- a/drivers/staging/greybus/arche-apb-ctrl.c
> +++ b/drivers/staging/greybus/arche-apb-ctrl.c
> @@ -10,13 +10,14 @@
>  #include <linux/delay.h>
>  #include <linux/gpio/consumer.h>
>  #include <linux/interrupt.h>
> -#include <linux/of_irq.h>
>  #include <linux/module.h>
>  #include <linux/pinctrl/consumer.h>
>  #include <linux/platform_device.h>
>  #include <linux/pm.h>
> +#include <linux/property.h>
>  #include <linux/regulator/consumer.h>
>  #include <linux/spinlock.h>
> +#include <linux/mod_devicetable.h>
>  #include "arche_platform.h"
>  
>  static void apb_bootret_deassert(struct device *dev);
> @@ -314,7 +315,7 @@ static ssize_t state_show(struct device *dev,
>  
>  static DEVICE_ATTR_RW(state);
>  
> -static int apb_ctrl_get_devtree_data(struct platform_device *pdev,
> +static int apb_ctrl_get_fw_data(struct platform_device *pdev,
>  				     struct arche_apb_ctrl_drvdata *apb)
                                   ^^
This line needs to be indented differently now.

>  {
>  	struct device *dev = &pdev->dev;

regards,
dan carpenter

      reply	other threads:[~2025-12-05  7:26 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-12-04 23:11 [PATCH v3] staging: greybus: arche-apb-ctrl: switch to device_property_read_bool Julioccps
2025-12-05  7:26 ` Dan Carpenter [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=aTKJLAZaPjEcS17l@stanley.mountain \
    --to=dan.carpenter@linaro.org \
    --cc=elder@kernel.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=greybus-dev@lists.linaro.org \
    --cc=hvaibhav.linux@gmail.com \
    --cc=johan@kernel.org \
    --cc=julio191096@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-staging@lists.linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.