On Mon, Jun 29, 2026 at 02:44:57PM +0200, Thomas Zimmermann wrote: > Hi > > Am 29.06.26 um 14:27 schrieb Thierry Reding: > > On Thu, Jun 25, 2026 at 11:39:38AM +0200, Thomas Zimmermann wrote: > > > Implement drm_of_get_panel_orientation() to retrieve a panel's > > > rotation property as enum drm_panel_orientation. The code has > > > been taken from of_drm_get_panel_orientation(), so convert that > > > helper over. Callers of the old helper can be converted as well. > > > > > > Signed-off-by: Thomas Zimmermann > > > --- > > > drivers/gpu/drm/drm_of.c | 44 +++++++++++++++++++++++++++++++++++++ > > > drivers/gpu/drm/drm_panel.c | 26 ++-------------------- > > > include/drm/drm_of.h | 11 ++++++++++ > > > 3 files changed, 57 insertions(+), 24 deletions(-) > > So you're effectively renaming of_drm_get_panel_orientation() to > > drm_of_get_panel_orientation(), while moving it to drm_of.c, and then > > you keep of_drm_get_panel_orientation() as an alias. > > > > I don't understand the use of this. Maybe if we really need to move this > > out of drm_panel.c to make it more widely available, fine. Maybe we also > > want the drm_of_ prefix instead of of_drm_, also fine, I suppose. But in > > that case we should just go ahead and update all callers of the old > > helper and get rid of it while we're at it. No use in keeping around > > aliases/duplicates. > > I'm all for it. i though this would be a different issue. Yeah, understandably. Can't always do everything within one series. In this case it seems fairly simple to do and we're early in the release cycle, so there shouldn't be too much in terms of conflicts or new users yet, so seems like an opportune time. > > > > I've attached a patch to do just that. Feel free to integrate it into > > the series, or we can apply after your series is merged. > > Thanks. > > Let me split of theĀ  first 5 patches in series and merge them. They are the > fixes and hardening patches and seem ready to be merged. I'll prepare a > separate series for the panel orientation with your changes and it can go in > separately. If we touch all the panel drivers, we should make sure that the > panel maintainers get another chance of looking over it. I think I'll need to send a new version which explicitly includes drm_of.h for all the panels that use the new function. My build tests were missing some drivers and others include the file implicitly via some other headers. Not sure if maintainers really need to look at these since it's literally just switching out the of_drm prefix for drm_of, but yeah, can't hurt to send out a series for review. Thierry