From: Oleg Nesterov <oleg@redhat.com>
To: Renzo Davoli <renzo@cs.unibo.it>
Cc: "Dmitry V. Levin" <ldv@strace.io>,
linux-kernel@vger.kernel.org,
Andrew Morton <akpm@linux-foundation.org>,
Shuah Khan <shuah@kernel.org>, Alexey Gladkov <legion@kernel.org>,
Eugene Syromyatnikov <evgsyr@gmail.com>,
Mike Frysinger <vapier@gentoo.org>,
Davide Berardi <berardi.dav@gmail.com>,
strace-devel@lists.strace.io
Subject: Re: [PATCH 1/5] ptrace: add PTRACE_SYSCALL_INFO_SECCOMP_SKIP
Date: Fri, 3 Jul 2026 11:58:11 +0200 [thread overview]
Message-ID: <akeHszRYTr0pq0S1@redhat.com> (raw)
In-Reply-To: <akaNiN1tzB7K3doN@cs.unibo.it>
On 07/02, Renzo Davoli wrote:
>
> On Thu, Jul 02, 2026 at 04:47:08PM +0200, Oleg Nesterov wrote:
> > On 07/02, Oleg Nesterov wrote:
> > Wdyt about something like below?
>
> I like it.
Good,
> I have one comment:
> > + if (ptrace_get_syscall_info_op(child) != info.op) {
> > + if (info.op != PTRACE_SYSCALL_INFO_EXIT)
> > + return -EINVAL;
> > + force = true;
> > + }
>
> I have found the behavior "negative syscall number => skip syscall" defined
> only for PTRACE_EVENT_SECCOMP in the manual. I'd restrict the option to this
> case, for safety.
Well, this simply means that the manual is incomplete. And whatever we do, we
will need to update it anyway when/if we add the new behaviour.
I don't think it makes any sense to restrict the new feature to _SECCOMP...
> A minimal detail: I'd also rename "force" into "skip" or "skip_syscall", just
> for the sake of readability.
Ok, I agree with any naming.
> Dmitry: does this proposal have counter effects for strace?
Oleg.
next prev parent reply other threads:[~2026-07-03 9:58 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-01 15:05 [PATCH 0/5] ptrace_set_syscall_info: add support for seccomp syscall skipping and instruction pointer modification Renzo Davoli
2026-07-01 15:05 ` [PATCH 1/5] ptrace: add PTRACE_SYSCALL_INFO_SECCOMP_SKIP Renzo Davoli
2026-07-02 8:43 ` Oleg Nesterov
2026-07-02 9:09 ` Renzo Davoli
2026-07-02 9:58 ` Oleg Nesterov
2026-07-02 11:07 ` Dmitry V. Levin
2026-07-02 11:31 ` Oleg Nesterov
2026-07-02 11:39 ` Oleg Nesterov
2026-07-02 14:47 ` Oleg Nesterov
2026-07-02 16:10 ` Renzo Davoli
2026-07-03 9:58 ` Oleg Nesterov [this message]
2026-07-06 14:16 ` Dmitry V. Levin
2026-07-01 15:05 ` [PATCH 2/5] selftests/ptrace: add a test case for PTRACE_SYSCALL_INFO_SECCOMP_SKIP Renzo Davoli
2026-07-01 15:05 ` [PATCH 3/5] asm/ptrace.h: add instruction_pointer_set Renzo Davoli
2026-07-01 15:05 ` [PATCH 4/5] ptrace: add PTRACE_SYSCALL_INFO_FLAG_SET_IP Renzo Davoli
2026-07-01 15:05 ` [PATCH 5/5] selftests/ptrace: add a test case for PTRACE_SYSCALL_INFO_FLAG_SET_IP Renzo Davoli
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=akeHszRYTr0pq0S1@redhat.com \
--to=oleg@redhat.com \
--cc=akpm@linux-foundation.org \
--cc=berardi.dav@gmail.com \
--cc=evgsyr@gmail.com \
--cc=ldv@strace.io \
--cc=legion@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=renzo@cs.unibo.it \
--cc=shuah@kernel.org \
--cc=strace-devel@lists.strace.io \
--cc=vapier@gentoo.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.