From: Breno Leitao <leitao@debian.org>
To: Mateusz Guzik <mjguzik@gmail.com>
Cc: Alexander Viro <viro@zeniv.linux.org.uk>,
Christian Brauner <brauner@kernel.org>,
oleg@redhat.com, josh@joshtriplett.org, Jan Kara <jack@suse.cz>,
jlayton@kernel.org, axboe@kernel.dk, shakeel.butt@linux.dev,
linux-fsdevel@vger.kernel.org, linux-kernel@vger.kernel.org,
kernel-team@meta.com
Subject: Re: [PATCH v3] fs/pipe: unify the page pools into a single per-pipe pool
Date: Fri, 10 Jul 2026 01:37:56 -0700 [thread overview]
Message-ID: <alCvQuSpsRHV6JQc@gmail.com> (raw)
In-Reply-To: <CAGudoHHEKHzdc6nQCNKP6jN=K7oOaeAKso83At_X_==L76Zd6w@mail.gmail.com>
On Thu, Jul 09, 2026 at 03:53:21PM +0200, Mateusz Guzik wrote:
> On Thu, Jul 9, 2026 at 3:38 PM Breno Leitao <leitao@debian.org> wrote:
> > anon_pipe_trim_pool_and_unlock() trims the pool under that same lock
> > before dropping it, then frees the excess.
>
> One nit, but probably not worth respining: the naming is slightly off
> in that either both routines or neither of them should mention 'pool',
> as opposed to just one side doing it.
>
> Perhaps Christian would be kind enough to either
> s/anon_pipe_prefill_and_lock/anon_pipe_prefill_pool_and_lock/ or
> s/anon_pipe_trim_pool_and_unlock/anon_pipe_trim_and_unlock/
>
> >
> > A huge thanks to Mateusz Guzik <mjguzik@gmail.com> who has been
> > a solid collaborator.
>
> well I wrote like twice that this kind of credit is not necessary
> here, but i'm not going to insist :-P
>
> that said, the patch reads fine to me now, so:
> Reviewed-by: Mateusz Guzik <mjguzik@gmail.com>
Ack, let me respin it with the two items above fixed.
Thanks for the review,
prev parent reply other threads:[~2026-07-10 8:38 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-09 13:38 [PATCH v3] fs/pipe: unify the page pools into a single per-pipe pool Breno Leitao
2026-07-09 13:53 ` Mateusz Guzik
2026-07-10 8:37 ` Breno Leitao [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alCvQuSpsRHV6JQc@gmail.com \
--to=leitao@debian.org \
--cc=axboe@kernel.dk \
--cc=brauner@kernel.org \
--cc=jack@suse.cz \
--cc=jlayton@kernel.org \
--cc=josh@joshtriplett.org \
--cc=kernel-team@meta.com \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mjguzik@gmail.com \
--cc=oleg@redhat.com \
--cc=shakeel.butt@linux.dev \
--cc=viro@zeniv.linux.org.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.