From: Patrick Steinhardt <ps@pks.im>
To: Junio C Hamano <gitster@pobox.com>
Cc: git@vger.kernel.org
Subject: Re: [PATCH 5/5] odb: make creation of on-disk structures pluggable
Date: Tue, 4 Aug 2026 09:21:15 +0200 [thread overview]
Message-ID: <anGS69L4vh3TsDlP@pks.im> (raw)
In-Reply-To: <xmqqbjbtv5y6.fsf@gitster.g>
On Sun, Jul 26, 2026 at 01:42:09PM -0700, Junio C Hamano wrote:
> Patrick Steinhardt <ps@pks.im> writes:
> > @@ -271,6 +289,7 @@ struct odb_source_files *odb_source_files_new(struct object_database *odb,
> >
> > files->base.free = odb_source_files_free;
> > files->base.close = odb_source_files_close;
> > + files->base.create_on_disk = odb_source_files_create_on_disk;
> > files->base.prepare = odb_source_files_prepare;
> > files->base.read_object_info = odb_source_files_read_object_info;
> > files->base.read_object_stream = odb_source_files_read_object_stream;
>
> If we are going to write a brand new object backing store that does
> not use an on-disk filesystem (or a network filesystem, for that
> matter) but still requires some sort of "initialization", for
> example, an object database in the cloud that needs provisioning
> before its first use, would this virtual function be the ideal place
> to do so?
It would, even though...
> I wonder if we can give it a name better suited to its purpose by
> moving away from the '_on_disk' suffix.
... the name is admittedly a bit misleading. I couldn't really come up
with a better name though, and the `on_disk()` suffix is what we already
use in the reference subsystem, too (see `ref_store_create_on_disk()`).
So I'm inclined to leave the name as-is for the sake of consistency.
Patrick
next prev parent reply other threads:[~2026-08-04 7:21 UTC|newest]
Thread overview: 68+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-24 3:48 [PATCH 0/5] odb: make creation of object database pluggable Patrick Steinhardt
2026-07-24 3:48 ` [PATCH 1/5] loose: load loose object map for the correct source Patrick Steinhardt
2026-07-24 17:26 ` Junio C Hamano
2026-07-28 20:14 ` Justin Tobler
2026-07-30 12:47 ` Toon Claes
2026-08-04 7:21 ` Patrick Steinhardt
2026-07-24 3:48 ` [PATCH 2/5] setup: detangle loading of loose object maps Patrick Steinhardt
2026-07-24 18:41 ` Junio C Hamano
2026-08-04 7:21 ` Patrick Steinhardt
2026-07-28 20:32 ` Justin Tobler
2026-07-30 14:27 ` Toon Claes
2026-08-04 7:21 ` Patrick Steinhardt
2026-07-24 3:48 ` [PATCH 3/5] setup: defer object database creation Patrick Steinhardt
2026-07-24 18:50 ` Junio C Hamano
2026-08-04 7:21 ` Patrick Steinhardt
2026-07-28 21:13 ` Justin Tobler
2026-08-04 7:21 ` Patrick Steinhardt
2026-08-04 7:28 ` Patrick Steinhardt
2026-07-24 3:48 ` [PATCH 4/5] odb/source: introduce function to map source type to name Patrick Steinhardt
2026-07-26 20:34 ` Junio C Hamano
2026-08-04 7:21 ` Patrick Steinhardt
2026-07-24 3:48 ` [PATCH 5/5] odb: make creation of on-disk structures pluggable Patrick Steinhardt
2026-07-26 20:42 ` Junio C Hamano
2026-08-04 7:21 ` Patrick Steinhardt [this message]
2026-07-28 21:23 ` Justin Tobler
2026-08-04 8:29 ` [PATCH v2 0/5] odb: make creation of object database pluggable Patrick Steinhardt
2026-08-04 8:29 ` [PATCH v2 1/5] loose: load loose object map for the correct source Patrick Steinhardt
2026-08-04 8:29 ` [PATCH v2 2/5] setup: detangle loading of loose object maps Patrick Steinhardt
2026-08-04 8:29 ` [PATCH v2 3/5] setup: defer object database creation Patrick Steinhardt
2026-08-04 18:48 ` Toon Claes
2026-08-05 7:27 ` Patrick Steinhardt
2026-08-04 8:29 ` [PATCH v2 4/5] odb/source: introduce function to map source type to name Patrick Steinhardt
2026-08-04 8:29 ` [PATCH v2 5/5] odb: make creation of on-disk structures pluggable Patrick Steinhardt
2026-08-04 16:36 ` [PATCH v2 0/5] odb: make creation of object database pluggable Justin Tobler
2026-08-05 9:28 ` [PATCH v3 0/6] " Patrick Steinhardt
2026-08-05 9:28 ` [PATCH v3 1/6] loose: load loose object map for the correct source Patrick Steinhardt
2026-08-05 9:28 ` [PATCH v3 2/6] setup: detangle loading of loose object maps Patrick Steinhardt
2026-08-05 9:28 ` [PATCH v3 3/6] setup: handle ODB-related environment variables in `odb_new()` Patrick Steinhardt
2026-08-05 13:29 ` Toon Claes
2026-08-06 6:04 ` Patrick Steinhardt
2026-08-05 9:28 ` [PATCH v3 4/6] setup: defer object database creation Patrick Steinhardt
2026-08-05 14:21 ` Toon Claes
2026-08-06 6:02 ` Patrick Steinhardt
2026-08-05 9:28 ` [PATCH v3 5/6] odb/source: introduce function to map source type to name Patrick Steinhardt
2026-08-05 9:28 ` [PATCH v3 6/6] odb: make creation of on-disk structures pluggable Patrick Steinhardt
2026-08-05 15:57 ` Toon Claes
2026-08-06 7:50 ` [PATCH v4 0/6] odb: make creation of object database pluggable Patrick Steinhardt
2026-08-06 7:50 ` [PATCH v4 1/6] loose: load loose object map for the correct source Patrick Steinhardt
2026-08-06 7:51 ` [PATCH v4 2/6] setup: detangle loading of loose object maps Patrick Steinhardt
2026-08-06 7:51 ` [PATCH v4 3/6] setup: handle ODB-related environment variables in `odb_new()` Patrick Steinhardt
2026-08-06 7:51 ` [PATCH v4 4/6] setup: defer object database creation Patrick Steinhardt
2026-08-06 14:23 ` Toon Claes
2026-08-06 14:54 ` Patrick Steinhardt
2026-08-06 17:39 ` Junio C Hamano
2026-08-06 7:51 ` [PATCH v4 5/6] odb/source: introduce function to map source type to name Patrick Steinhardt
2026-08-06 7:51 ` [PATCH v4 6/6] odb: make creation of on-disk structures pluggable Patrick Steinhardt
2026-08-06 14:26 ` [PATCH v4 0/6] odb: make creation of object database pluggable Toon Claes
2026-08-07 3:34 ` [PATCH v5 " Patrick Steinhardt
2026-08-07 3:34 ` [PATCH v5 1/6] loose: load loose object map for the correct source Patrick Steinhardt
2026-08-07 3:34 ` [PATCH v5 2/6] setup: detangle loading of loose object maps Patrick Steinhardt
2026-08-07 3:34 ` [PATCH v5 3/6] setup: handle ODB-related environment variables in `odb_new()` Patrick Steinhardt
2026-08-07 3:34 ` [PATCH v5 4/6] setup: defer object database creation Patrick Steinhardt
2026-08-07 4:28 ` Junio C Hamano
2026-08-07 7:16 ` Toon Claes
2026-08-07 3:34 ` [PATCH v5 5/6] odb/source: introduce function to map source type to name Patrick Steinhardt
2026-08-07 3:34 ` [PATCH v5 6/6] odb: make creation of on-disk structures pluggable Patrick Steinhardt
2026-08-07 7:17 ` [PATCH v5 0/6] odb: make creation of object database pluggable Toon Claes
2026-08-07 9:10 ` Patrick Steinhardt
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=anGS69L4vh3TsDlP@pks.im \
--to=ps@pks.im \
--cc=git@vger.kernel.org \
--cc=gitster@pobox.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.