From: Alice Ryhl <aliceryhl@google.com>
To: Beata Michalska <beata.michalska@arm.com>
Cc: ojeda@kernel.org, dakr@kernel.org, gregkh@linuxfoundation.org,
rafael@kernel.org, boqun@kernel.org, gary@garyguo.net,
bjorn3_gh@protonmail.com, lossin@kernel.org,
a.hindborg@kernel.org, tmgross@umich.edu,
daniel.almeida@collabora.com, boris.brezillon@collabora.com,
work@onurozkan.dev, samitolvanen@google.com,
rust-for-linux@vger.kernel.org, driver-core@lists.linux.dev,
linux-kernel@vger.kernel.org, linux-pm@vger.kernel.org
Subject: Re: [PATCH v2 1/3] rust: add runtime PM support
Date: Thu, 6 Aug 2026 06:41:36 +0000 [thread overview]
Message-ID: <anQsoIbL6dGWmzbL@google.com> (raw)
In-Reply-To: <anHarTAFv-c4qx4h@arm.com>
On Tue, Aug 04, 2026 at 02:27:25PM +0200, Beata Michalska wrote:
> On Tue, Aug 04, 2026 at 08:13:13AM +0000, Alice Ryhl wrote:
> > On Tue, Jul 21, 2026 at 05:34:02PM +0200, Beata Michalska wrote:
> > > +define_pm_ops!(
> > > + // PM state change
> > > + runtime_suspend,
> > > + runtime_resume,
> > > +);
> >
> > I think using a macro to define this trait is overkill. Just write it
> > out:
> >
> > pub trait PMOps: Sized {
> > /// Type of a bus device
> > type DeviceType: AsBusDevice<device::Bound>;
> > /// Type of the data associated with a PM transitions:
> > type RuntimePayloadType: Send;
> >
> > fn runtime_suspend<'a>(
> > _dev: &'a Self::DeviceType,
> > _payload: Option<Self::RuntimePayloadType>,
> > ) -> Result<Option<Self::RuntimePayloadType>, (Option<Self::RuntimePayloadType>, Error)> {
> > build_error!(VTABLE_DEFAULT_ERROR)
> > }
> >
> > fn runtime_resume<'a>(
> > _dev: &'a Self::DeviceType,
> > _payload: Option<Self::RuntimePayloadType>,
> > ) -> Result<Option<Self::RuntimePayloadType>, (Option<Self::RuntimePayloadType>, Error)> {
> > build_error!(VTABLE_DEFAULT_ERROR)
> > }
> > }
> >
> > This is a lot easier to read.
> It is, though there are more collbacks, that I would expect to be added at some
> point, so macro is just to avoid several code blocks that would only differ in
> function name.
> But I do see your point.
> Happy to change that if you still believe there is no much point to it.
I generally believe that for traits such as this one where end-users are
likely to look up the definition, it's much more important that it's
easy to read when you look up the source, than it being easy to write.
Therefore, I think it should not use a macro, even if there are many
methods.
Alice
next prev parent reply other threads:[~2026-08-06 6:41 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-21 15:34 [PATCH v2 0/3] Rust: add runtime PM support Beata Michalska
2026-07-21 15:34 ` [PATCH v2 1/3] rust: " Beata Michalska
2026-07-27 14:56 ` Onur Özkan
2026-07-29 9:07 ` Beata Michalska
2026-07-29 13:58 ` Onur Özkan
2026-08-03 9:30 ` Beata Michalska
2026-08-04 8:06 ` Alice Ryhl
2026-08-04 12:27 ` Beata Michalska
2026-08-04 8:13 ` Alice Ryhl
2026-08-04 12:27 ` Beata Michalska
2026-08-06 6:41 ` Alice Ryhl [this message]
2026-07-21 15:34 ` [PATCH v2 2/3] rust: platform: wire runtime PM callbacks Beata Michalska
2026-08-04 8:02 ` Alice Ryhl
2026-08-04 12:26 ` Beata Michalska
2026-08-04 9:16 ` Alice Ryhl
2026-08-04 12:28 ` Beata Michalska
2026-08-06 6:45 ` Alice Ryhl
2026-07-21 15:34 ` [PATCH v2 3/3] drm/tyr: enable runtime PM Beata Michalska
2026-07-27 15:00 ` Onur Özkan
2026-07-29 9:13 ` Beata Michalska
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=anQsoIbL6dGWmzbL@google.com \
--to=aliceryhl@google.com \
--cc=a.hindborg@kernel.org \
--cc=beata.michalska@arm.com \
--cc=bjorn3_gh@protonmail.com \
--cc=boqun@kernel.org \
--cc=boris.brezillon@collabora.com \
--cc=dakr@kernel.org \
--cc=daniel.almeida@collabora.com \
--cc=driver-core@lists.linux.dev \
--cc=gary@garyguo.net \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=lossin@kernel.org \
--cc=ojeda@kernel.org \
--cc=rafael@kernel.org \
--cc=rust-for-linux@vger.kernel.org \
--cc=samitolvanen@google.com \
--cc=tmgross@umich.edu \
--cc=work@onurozkan.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.