All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Lorenzo Stoakes (ARM)" <ljs@kernel.org>
To: Tal Zussman <tz2294@columbia.edu>
Cc: Matthew Wilcox <willy@infradead.org>,
	 Andrew Morton <akpm@linux-foundation.org>,
	Chris Li <chrisl@kernel.org>, Kairui Song <kasong@tencent.com>,
	 Kemeng Shi <shikemeng@huaweicloud.com>,
	Nhat Pham <nphamcs@gmail.com>, Baoquan He <baoquan.he@linux.dev>,
	 Barry Song <baohua@kernel.org>,
	Youngjun Park <youngjun.park@lge.com>,
	 David Hildenbrand <david@kernel.org>,
	"Liam R. Howlett" <liam@infradead.org>,
	 Vlastimil Babka <vbabka@kernel.org>,
	Mike Rapoport <rppt@kernel.org>,
	 Suren Baghdasaryan <surenb@google.com>,
	Michal Hocko <mhocko@suse.com>, Christoph Hellwig <hch@lst.de>,
	 Johannes Weiner <hannes@cmpxchg.org>,
	Yosry Ahmed <yosry@kernel.org>,
	 Chengming Zhou <chengming.zhou@linux.dev>,
	linux-mm@kvack.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 4/6] mm/page_io: rename bio_associate_blkg_from_page()
Date: Mon, 10 Aug 2026 13:55:49 +0100	[thread overview]
Message-ID: <annKQgxGQvQe04iO@lucifer> (raw)
In-Reply-To: <612ed1ce-e7a7-410e-9ad7-256e77bc867c@columbia.edu>

On Fri, Aug 07, 2026 at 10:30:22PM +0300, Tal Zussman wrote:
> On 8/7/26 2:56 PM, Matthew Wilcox wrote:
> > On Thu, Aug 06, 2026 at 06:55:36PM -0400, Tal Zussman wrote:
> >> This function takes a folio. Rename it to
> >> bio_associate_blkg_from_folio() accordingly. While at it, convert the
> >> macro in the !CONFIG_MEMCG || !CONFIG_BLK_CGROUP case to a function.
> >>
> >> Signed-off-by: Tal Zussman <tz2294@columbia.edu>
> >
> > Reviewed-by: Matthew Wilcox (Oracle) <willy@infradead.org>
> >
> >> -static void bio_associate_blkg_from_page(struct bio *bio, struct folio *folio)
> >> +static void bio_associate_blkg_from_folio(struct bio *bio, struct folio *folio)
> >
> > It's s shame this isn't const-qualified (after all, we don't modify the folio).
> > That needs folio_memcg_charged() to take a const folio pointer, which it
> > could.  And folio_memcg_blkg_css() and folio_memcg().  That's a followup
> > patch though.
> >
>
> I had the same thought when looking at this and went all the way down the
> callchain to dump_page(). I didn't want to flood the list with patches, but
> happy to send a couple follow-up patches once this is in mm-new.

Churn that achieves good things is OK :) (but of course, I would say that
;)


--
Cheers, Lorenzo


  reply	other threads:[~2026-08-10 12:56 UTC|newest]

Thread overview: 35+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-06 22:55 [PATCH 0/6] mm/page_io: folio conversion cleanups Tal Zussman
2026-08-06 22:55 ` [PATCH 1/6] mm/page_io: convert write completion handlers to folios Tal Zussman
2026-08-07 16:49   ` Johannes Weiner
2026-08-07 18:42     ` Matthew Wilcox
2026-08-10 12:50   ` Lorenzo Stoakes (ARM)
2026-08-06 22:55 ` [PATCH 2/6] mm: remove PageReclaim Tal Zussman
2026-08-07 16:50   ` Johannes Weiner
2026-08-07 18:48   ` Matthew Wilcox
2026-08-07 19:27     ` Tal Zussman
2026-08-10 11:38       ` David Hildenbrand (Arm)
2026-08-10 12:51         ` Lorenzo Stoakes (ARM)
2026-08-06 22:55 ` [PATCH 3/6] mm/page_io: use swap entries directly in zeromap helpers Tal Zussman
2026-08-07 16:53   ` Johannes Weiner
2026-08-07 18:50   ` Matthew Wilcox
2026-08-10 12:55   ` Lorenzo Stoakes (ARM)
2026-08-10 13:14     ` Tal Zussman
2026-08-10 14:49       ` Lorenzo Stoakes (ARM)
2026-08-06 22:55 ` [PATCH 4/6] mm/page_io: rename bio_associate_blkg_from_page() Tal Zussman
2026-08-07 16:53   ` Johannes Weiner
2026-08-07 18:56   ` Matthew Wilcox
2026-08-07 19:30     ` Tal Zussman
2026-08-10 12:55       ` Lorenzo Stoakes (ARM) [this message]
2026-08-10 12:57   ` Lorenzo Stoakes (ARM)
2026-08-06 22:55 ` [PATCH 5/6] mm/page_io: refer to folios in swap_writeout() comments Tal Zussman
2026-08-07 16:54   ` Johannes Weiner
2026-08-07 18:59   ` Matthew Wilcox
2026-08-10 12:57   ` Lorenzo Stoakes (ARM)
2026-08-06 22:55 ` [PATCH 6/6] mm/swap: rename __swap_writepage() to __swap_writeout() Tal Zussman
2026-08-07 17:01   ` Johannes Weiner
2026-08-07 19:05     ` Matthew Wilcox
2026-08-10 11:19       ` Tal Zussman
2026-08-07 19:44     ` Tal Zussman
2026-08-10 12:59       ` Lorenzo Stoakes (ARM)
2026-08-10 17:34     ` Christoph Hellwig
2026-08-07 19:06   ` Matthew Wilcox

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=annKQgxGQvQe04iO@lucifer \
    --to=ljs@kernel.org \
    --cc=akpm@linux-foundation.org \
    --cc=baohua@kernel.org \
    --cc=baoquan.he@linux.dev \
    --cc=chengming.zhou@linux.dev \
    --cc=chrisl@kernel.org \
    --cc=david@kernel.org \
    --cc=hannes@cmpxchg.org \
    --cc=hch@lst.de \
    --cc=kasong@tencent.com \
    --cc=liam@infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=mhocko@suse.com \
    --cc=nphamcs@gmail.com \
    --cc=rppt@kernel.org \
    --cc=shikemeng@huaweicloud.com \
    --cc=surenb@google.com \
    --cc=tz2294@columbia.edu \
    --cc=vbabka@kernel.org \
    --cc=willy@infradead.org \
    --cc=yosry@kernel.org \
    --cc=youngjun.park@lge.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.