From: "Roger Pau Monné" <roger@xenproject.org>
To: Jan Beulich <jbeulich@suse.com>
Cc: dmukhin@ford.com, xen-devel@lists.xenproject.org,
andrew.cooper3@citrix.com, anthony.perard@vates.tech,
julien@xen.org, michal.orzel@amd.com, sstabellini@kernel.org
Subject: Re: [PATCH v3] xen/common: add keyhandler to show Xen command line
Date: Wed, 12 Aug 2026 10:03:37 +0200 [thread overview]
Message-ID: <anwo2QtEh9tObNDD@macbook.local> (raw)
In-Reply-To: <ba78a8a1-6862-41b0-a6a5-cae7eada3627@suse.com>
On Wed, Aug 12, 2026 at 09:28:46AM +0200, Jan Beulich wrote:
> On 11.08.2026 22:56, dmukhin@ford.com wrote:
> > On Tue, Aug 11, 2026 at 10:05:17AM +0200, Roger Pau Monné wrote:
> >> On Mon, Aug 10, 2026 at 04:04:01PM -0700, dmukhin@ford.com wrote:
> >>> +static int __init cf_check misc_init(void)
> >>> +{
> >>> + register_keyhandler('X', show_hypervisor_info,
> >>> + "show hypervisor information", 0);
> >>
> >> "show hypervisor information" seems too generic to me, almost all
> >> debug keys could be defined by this sentence TBH. I think this needs
> >> to be more specific, but I'm not sure what's the plan regarding this
> >> key. Is there an intention to print more stuff here, or just the
> >> command line? Knowing the full set of information to be printed might
> >> help come up with a better name.
> >
> > I will update to "show_cmdline" since I originally planed to expose Xen
> > command line only so it is possible to better debug a system when dom0
> > becomes almost unresponsive.
>
> Yet as indicated already on v1 (I think) - a precious debug key character
> for just the command line seems rather wasteful to me. If it's only the
> command line, and if that _really_ needs exposing via a debug key (i.e.
> if there are reasonable scenarios where "xl info" cannot be used), perhaps
> attach it to e.g. the 'h' key output?
I was going to say that we should not overload the 'h' key with
printing a possibly long string, but I see we already print a bunch of
information there, like the buildid and the compiler banner.
One option would be to introduce a new debug character, and move the
printing of the buildid and the banner to that key, together with the
command line. Then 'h' output will be cleaner and just print the list
of installed handlers. That would give the new key more content, and
help cleanup the output from the 'h' debug key at the same time.
Thanks, Roger.
next prev parent reply other threads:[~2026-08-12 8:04 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-10 23:04 [PATCH v3] xen/common: add keyhandler to show Xen command line dmukhin
2026-08-11 8:05 ` Roger Pau Monné
2026-08-11 20:56 ` dmukhin
2026-08-12 7:28 ` Jan Beulich
2026-08-12 8:03 ` Roger Pau Monné [this message]
2026-08-12 8:19 ` Jan Beulich
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=anwo2QtEh9tObNDD@macbook.local \
--to=roger@xenproject.org \
--cc=andrew.cooper3@citrix.com \
--cc=anthony.perard@vates.tech \
--cc=dmukhin@ford.com \
--cc=jbeulich@suse.com \
--cc=julien@xen.org \
--cc=michal.orzel@amd.com \
--cc=sstabellini@kernel.org \
--cc=xen-devel@lists.xenproject.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.