All of lore.kernel.org
 help / color / mirror / Atom feed
From: Peter Xu <peterx@redhat.com>
To: Yanfei Xu <yanfei.xu@bytedance.com>
Cc: qemu-devel@nongnu.org, farosas@suse.de, lizhijian@fujitsu.com,
	jinpu.wang@cloud.ionos.com, isyanfei.xu@gmail.com
Subject: Re: [PATCH v2 3/3] migration/rdma: Retry control sends on full queue
Date: Fri, 21 Aug 2026 10:25:10 -0400	[thread overview]
Message-ID: <aohfxvS-msX0NWmt@x1.local> (raw)
In-Reply-To: <aohcYFgiDXpCWAlg@x1.local>

On Fri, Aug 21, 2026 at 10:10:40AM -0400, Peter Xu wrote:
> > +    switch (wr_id) {
> > +    case RDMA_WRID_RDMA_WRITE:
> > +        wr_desc = "RDMA write";
> > +        break;
> > +    case RDMA_WRID_SEND_CONTROL:
> > +        wr_desc = "control send";
> > +        break;
> > +    default:
> > +        wr_desc = "send work request";
> > +        break;
> 
> Do we have other possibility?  I thought it should be either WRITE or SEND,
> if so, we could g_assert_not_reached().

Some side discussion..

Since we're talking about the wrids, IIUC the whole RDMA wrid space is a
bit messy. E.g. RDMA_WRID_SEND_CONTROL is used without having
RDMA_WRID_CONTROL (2000, rather than 2022) for SEND control messages.

IIUC the two-layered wrid name space is confusing, maybe we can rewrite the
wrid allocation to only use one namespace with very limited wrid
possibilities, selecting rdma->wr_data[] index based on the few
possibilities.  My gut feeling is that's much easier to read.

In all cases, this will be a separate discussion, not relevant to this
series alone, but I want to see if I'm the only one got confused by these
two-layered RDMA_WRID_*.

Thanks,

-- 
Peter Xu



  reply	other threads:[~2026-08-21 14:25 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-21 13:35 [PATCH v2 0/3] migration/rdma: Misc RDMA migration fixes Yanfei Xu
2026-08-21 13:35 ` [PATCH v2 1/3] migration/rdma: Fix write-side shutdown Yanfei Xu
2026-08-21 13:35 ` [PATCH v2 2/3] migration/rdma: Post initial receive before accepting Yanfei Xu
2026-08-21 13:35 ` [PATCH v2 3/3] migration/rdma: Retry control sends on full queue Yanfei Xu
2026-08-21 14:10   ` Peter Xu
2026-08-21 14:25     ` Peter Xu [this message]
2026-08-23  2:38       ` Yanfei Xu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=aohfxvS-msX0NWmt@x1.local \
    --to=peterx@redhat.com \
    --cc=farosas@suse.de \
    --cc=isyanfei.xu@gmail.com \
    --cc=jinpu.wang@cloud.ionos.com \
    --cc=lizhijian@fujitsu.com \
    --cc=qemu-devel@nongnu.org \
    --cc=yanfei.xu@bytedance.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.