All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Roger Pau Monné" <roger@xenproject.org>
To: Jan Beulich <jbeulich@suse.com>
Cc: "xen-devel@lists.xenproject.org" <xen-devel@lists.xenproject.org>,
	Andrew Cooper <andrew.cooper3@citrix.com>,
	Teddy Astie <teddy.astie@vates.tech>
Subject: Re: [PATCH v5 1/2] x86/CPU: re-arrange tail of early_cpu_init()
Date: Wed, 2 Sep 2026 09:32:04 +0200	[thread overview]
Message-ID: <apfQ9H8NjODTBD4f@macbook.local> (raw)
In-Reply-To: <347cd6bc-e10e-4696-a1d2-1aaa84811370@suse.com>

On Wed, Aug 19, 2026 at 01:45:31PM +0200, Jan Beulich wrote:
> Some early setup doesn't need re-doing after ucode load. Move the call to
> initialize_cpu_data() slightly up and add a conditional return point.
> 
> Signed-off-by: Jan Beulich <jbeulich@suse.com>

Acked-by: Roger Pau Monné <roger@xenproject.org>

> ---
> The parameter being named "verbose" may be a little irritating for this
> use, yet renaming would incur extra churn.
> 
> Clearly an alternative would be to split the function. I can't, however,
> seem to be able to think of a good name for the part that would be invoked
> post-ucode-loading. Maybe early_cpu_reinit(), except that calling that
> from early_cpu_init() then still feel somewhat odd.

No strong opinion.  The code that doesn't need redoing seems so little
that splitting this might not (yet?) be necessary.

Thanks, Roger.


  reply	other threads:[~2026-09-02  7:32 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-19 11:44 [PATCH v5 0/2] x86/time: avoid early uses of NOW() to return zero Jan Beulich
2026-08-19 11:45 ` [PATCH v5 1/2] x86/CPU: re-arrange tail of early_cpu_init() Jan Beulich
2026-09-02  7:32   ` Roger Pau Monné [this message]
2026-08-19 11:45 ` [PATCH v5 2/2] x86/time: avoid early uses of NOW() to return zero Jan Beulich
2026-09-02  7:54   ` Roger Pau Monné
2026-09-02  8:40     ` Jan Beulich
2026-09-02  9:15       ` Roger Pau Monné
2026-09-02  9:31         ` Jan Beulich
2026-09-02 14:20     ` Jan Beulich

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=apfQ9H8NjODTBD4f@macbook.local \
    --to=roger@xenproject.org \
    --cc=andrew.cooper3@citrix.com \
    --cc=jbeulich@suse.com \
    --cc=teddy.astie@vates.tech \
    --cc=xen-devel@lists.xenproject.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.