From: Baoquan He <baoquan.he@linux.dev>
To: "Barry Song (Xiaomi)" <baohua@kernel.org>
Cc: akpm@linux-foundation.org, axelrasmussen@google.com,
baolin.wang@linux.alibaba.com, chenridong@xiaomi.com,
david@kernel.org, hannes@cmpxchg.org, kasong@tencent.com,
lianux.mm@gmail.com, linux-kernel@vger.kernel.org,
linux-mm@kvack.org, ljs@kernel.org, lyugaofei@xiaomi.com,
mhocko@kernel.org, qi.zheng@linux.dev, shakeel.butt@linux.dev,
stevensd@chromium.org, wangzicheng@honor.com, weixugc@google.com,
yuanchu@google.com
Subject: Re: [PATCH v2 2/2] mm/mglru: make retry logic explicit in isolate_folios()
Date: Thu, 3 Sep 2026 15:41:51 +0800 [thread overview]
Message-ID: <apkkvyLNEt4_ETiz@fedora> (raw)
In-Reply-To: <20260903070500.76379-1-baohua@kernel.org>
On 09/03/26 at 03:05pm, Barry Song (Xiaomi) wrote:
> On Thu, Sep 3, 2026 at 9:27 AM Baoquan He <baoquan.he@linux.dev> wrote:
> >
> [...]
> >
> > Thanks, Barry. These number is very convincing. The retry for swappiness
> > 0 is worthy. Then the patchset feels like doing two things: refactoring
> > the for() loop; improving the eviction for swappiness 0/201 by adding a
> > retry and this also makes them be consistent with (1, 200). While the
> > cover letter subject, patch 1 and patch 2 feels like it's not easy to
> > match them to the corresponding part. Maybe merging them to one patch,
> > or rearranging them? Just personal opinion.
> >
>
> Hi Baoquan,
>
> Thanks very much for your suggestions and review.
> We have two patches:
>
> 1. `mm/mglru: make type fallback logic explicit in isolate_folios()`
> 2. `mm/mglru: make retry logic explicit in isolate_folios()`
>
> One handles fallback, while the other handles retry. I think this
> separation makes the logic clearer. Could we keep the current
> separation?
Yeah, it's also fine to me. Thanks for the effort.
>
> But we may really need Andrew's kind help to squash the change
> you found below:
>
>
> From 1fb8046662a8b23be1b87a21cc9964e9ff9e1eb0 Mon Sep 17 00:00:00 2001
> From: "Barry Song (Xiaomi)" <baohua@kernel.org>
> Date: Thu, 3 Sep 2026 14:48:52 +0800
> Subject: [PATCH] mm: revert slight behavior change for swappiness 1-200
>
> Baoquan's review found that we unexpectedly introduced a slight behavior
> change for swappiness 1-200. We could now have a case like:
>
> 1. First scan -> `scanned != 0`
> 2. Second scan -> `scanned = 0`
> 3. Type fallback
>
> Step 3 was impossible before. Let's remove this possibility.
>
> Reported-by: Baoquan He <baoquan.he@linux.dev>
> Closes: https://lore.kernel.org/linux-mm/apfZQE1X6zGAsBb_@fedora/
> Signed-off-by: Barry Song (Xiaomi) <baohua@kernel.org>
> ---
> mm/vmscan.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/mm/vmscan.c b/mm/vmscan.c
> index bf2786c7247d..ba7adf36e69f 100644
> --- a/mm/vmscan.c
> +++ b/mm/vmscan.c
> @@ -4939,7 +4939,7 @@ static int isolate_folios(unsigned long nr_to_scan, struct lruvec *lruvec,
> * We are running out of the current reclaim type. Fall back to
> * the other type if allowed.
> */
> - if (!scanned && type_fallback_allowed) {
> + if (!scanned && !tried && type_fallback_allowed) {
> type = !type;
> tried = true;
> type_fallback_allowed = false;
> --
> 2.39.3 (Apple Git-146)
>
prev parent reply other threads:[~2026-09-03 7:42 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-29 7:42 [PATCH v2 0/2] mm/mglru: clean up isolate_folios for readability and clarity Barry Song (Xiaomi)
2026-08-29 7:42 ` [PATCH v2 1/2] mm/mglru: make type fallback logic explicit in isolate_folios() Barry Song (Xiaomi)
2026-08-31 8:34 ` Baolin Wang
2026-08-31 12:04 ` Lian Wang
2026-09-02 6:53 ` Baoquan He
2026-08-29 7:42 ` [PATCH v2 2/2] mm/mglru: make retry " Barry Song (Xiaomi)
2026-08-31 8:44 ` Baolin Wang
2026-09-02 8:07 ` Baoquan He
2026-09-02 9:20 ` Barry Song
2026-09-02 10:16 ` Baoquan He
2026-09-02 22:08 ` Barry Song
2026-09-03 1:27 ` Baoquan He
2026-09-03 7:05 ` Barry Song (Xiaomi)
2026-09-03 7:41 ` Baoquan He [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=apkkvyLNEt4_ETiz@fedora \
--to=baoquan.he@linux.dev \
--cc=akpm@linux-foundation.org \
--cc=axelrasmussen@google.com \
--cc=baohua@kernel.org \
--cc=baolin.wang@linux.alibaba.com \
--cc=chenridong@xiaomi.com \
--cc=david@kernel.org \
--cc=hannes@cmpxchg.org \
--cc=kasong@tencent.com \
--cc=lianux.mm@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=ljs@kernel.org \
--cc=lyugaofei@xiaomi.com \
--cc=mhocko@kernel.org \
--cc=qi.zheng@linux.dev \
--cc=shakeel.butt@linux.dev \
--cc=stevensd@chromium.org \
--cc=wangzicheng@honor.com \
--cc=weixugc@google.com \
--cc=yuanchu@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.