All of lore.kernel.org
 help / color / mirror / Atom feed
From: Peter Fang <peter.fang@intel.com>
To: Dave Hansen <dave.hansen@intel.com>
Cc: Xiaoyao Li <xiaoyao.li@intel.com>,
	Dave Hansen <dave.hansen@linux.intel.com>,
	Kiryl Shutsemau <kas@kernel.org>,
	"Rick Edgecombe" <rick.p.edgecombe@intel.com>,
	Kuppuswamy Sathyanarayanan
	<sathyanarayanan.kuppuswamy@linux.intel.com>,
	Thomas Gleixner <tglx@kernel.org>, Ingo Molnar <mingo@redhat.com>,
	Borislav Petkov <bp@alien8.de>, <x86@kernel.org>,
	"H. Peter Anvin" <hpa@zytor.com>, <linux-kernel@vger.kernel.org>,
	<linux-coco@lists.linux.dev>, <kvm@vger.kernel.org>,
	Binbin Wu <binbin.wu@linux.intel.com>,
	Tony Lindgren <tony.lindgren@linux.intel.com>,
	Sean Christopherson <seanjc@google.com>,
	Artem Bityutskiy <artem.bityutskiy@intel.com>
Subject: Re: [PATCH v4 3/4] virt: tdx-guest: Use a variable to store the Quote buffer size
Date: Tue, 22 Sep 2026 09:30:31 -0700	[thread overview]
Message-ID: <arKtJxNMYHYSfXuO@intel.com> (raw)
In-Reply-To: <7ddf42ab-2f78-4edd-be39-ff9e5156d51c@intel.com>

On Tue, Sep 22, 2026 at 07:59:55AM -0700, Dave Hansen wrote:
> On 9/22/26 03:05, Xiaoyao Li wrote:
> >> @@ -417,7 +416,8 @@ static int __init tdx_guest_init(void)
> >>  	if (ret)
> >>  		goto deinit_mr;
> >>  
> >> -	quote_data = alloc_quote_buf();
> >> +	quote_data_len = PAGE_ALIGN(GET_QUOTE_BUF_SIZE);
> >> +	quote_data = alloc_quote_buf(quote_data_len);
> > since quote_data_len is a global variable, it looks no need to pass it around.
> > 
> > Same for free_quote_buf()
> 
> It's not the end of the world, but... global variable == bad. Plus,
> handing global variables around can actually make the code flow more clear.
> 
> I'd much rather have a quote_data_len() with a static function variable.
> Oh, and, btw... "quote_data_len" is the wrong name. It's literally *not*
> "the length of the quote data" itself because it has the header metadata
> included in there.

Thanks. I'll apply the static function variable pattern suggested in
patch 4, and think of a better name.

The pointer to this buffer is "void *quote_data" which probably needs a
better name too.

  reply	other threads:[~2026-09-22 16:30 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-15  9:25 [PATCH v4 0/4] tdx-guest: Make Quote buffer size dynamic Peter Fang
2026-09-15  9:26 ` [PATCH v4 1/4] x86/tdx: Add helper to query maximum TD Quote size Peter Fang
2026-09-21 22:14   ` Dave Hansen
2026-09-22 16:06     ` Peter Fang
2026-09-15  9:26 ` [PATCH v4 2/4] virt: tdx-guest: Calculate the Quote buffer size safely Peter Fang
2026-09-16 12:26   ` Kiryl Shutsemau
2026-09-15  9:26 ` [PATCH v4 3/4] virt: tdx-guest: Use a variable to store the Quote buffer size Peter Fang
2026-09-16 12:30   ` Kiryl Shutsemau
2026-09-22 10:05   ` Xiaoyao Li
2026-09-22 14:59     ` Dave Hansen
2026-09-22 16:30       ` Peter Fang [this message]
2026-09-22 17:34         ` Dave Hansen
2026-09-22 21:36           ` Peter Fang
2026-09-22 21:40             ` Dave Hansen
2026-09-22 19:46       ` Edgecombe, Rick P
2026-09-22 22:38         ` Dave Hansen
2026-09-15  9:26 ` [PATCH v4 4/4] virt: tdx-guest: Allocate Quote buffer dynamically Peter Fang
2026-09-16 12:31   ` Kiryl Shutsemau
2026-09-17  9:23     ` Peter Fang
2026-09-21 22:47   ` Dave Hansen
2026-09-22 16:20     ` Peter Fang
2026-09-15 14:07 ` [PATCH v4 0/4] tdx-guest: Make Quote buffer size dynamic Sean Christopherson
2026-09-15 16:11   ` Edgecombe, Rick P
2026-09-15 23:04     ` Peter Fang
2026-09-16  0:06       ` Edgecombe, Rick P
2026-09-16  0:34         ` Peter Fang
2026-09-16  0:36           ` Edgecombe, Rick P
2026-09-16  0:50             ` Peter Fang
2026-09-16  1:20               ` Edgecombe, Rick P

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=arKtJxNMYHYSfXuO@intel.com \
    --to=peter.fang@intel.com \
    --cc=artem.bityutskiy@intel.com \
    --cc=binbin.wu@linux.intel.com \
    --cc=bp@alien8.de \
    --cc=dave.hansen@intel.com \
    --cc=dave.hansen@linux.intel.com \
    --cc=hpa@zytor.com \
    --cc=kas@kernel.org \
    --cc=kvm@vger.kernel.org \
    --cc=linux-coco@lists.linux.dev \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=rick.p.edgecombe@intel.com \
    --cc=sathyanarayanan.kuppuswamy@linux.intel.com \
    --cc=seanjc@google.com \
    --cc=tglx@kernel.org \
    --cc=tony.lindgren@linux.intel.com \
    --cc=x86@kernel.org \
    --cc=xiaoyao.li@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.