All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Alvin Šipraga" <alvin.sipraga@analog.com>
To: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
Cc: Mark Brown <broonie@kernel.org>, linux-sound@vger.kernel.org
Subject: Re: [PATCH v2 9/9] ASoC: soc-dai: rename snd_soc_dai_action() to snd_soc_dai_active_update()
Date: Thu, 24 Sep 2026 11:33:39 +0200	[thread overview]
Message-ID: <arTuaAU7VfXvZ4In@analog.com> (raw)
In-Reply-To: <87cxubjpqu.wl-kuninori.morimoto.gx@renesas.com>

On Fri, Sep 18, 2026 at 01:46:17AM +0000, Kuninori Morimoto wrote:
> We have snd_soc_dai_action() to update .active. and in the same time,
> we have snd_soc_dai_active() to get    .active.
> They are confusing name. Let's rename _action() to _active_update().
> 
> And in the same time, we have snd_soc_dai_action() and has its wrapper
> macro _activate/deactivate(). But callers are using both original/wrapper.
> Let's remove wrapper to remove confusion.
> 
> It is used only from ASoC framework, let's move it to soc-internal.h
> 
> Signed-off-by: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>

Reviewed-by: Alvin Šipraga <alvin.sipraga@analog.com>

  reply	other threads:[~2026-09-24  9:33 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-18  1:40 [PATCH v2 0/9] ASoC: add new DAI functions Kuninori Morimoto
2026-09-18  1:41 ` [PATCH v2 1/9] ASoC: soc-dai: use snd_soc_dai_stream_active() Kuninori Morimoto
2026-09-24  9:34   ` Alvin Šipraga
2026-09-18  1:41 ` [PATCH v2 2/9] ASoC: soc-dai: add snd_soc_dai_id() Kuninori Morimoto
2026-09-18  1:43 ` [PATCH v2 3/9] ASoC: soc-dai: add snd_soc_dai_to_component() Kuninori Morimoto
2026-09-18  1:43 ` [PATCH v2 4/9] ASoC: soc-dai: add snd_soc_dai_to_driver() Kuninori Morimoto
2026-09-18  1:43 ` [PATCH v2 5/9] ASoC: soc-dai: add snd_soc_dai_{to/from}_list() Kuninori Morimoto
2026-09-18  1:44 ` [PATCH v2 6/9] ASoC: soc-dai: add snd_soc_dai_get_symmetric_xxx() Kuninori Morimoto
2026-09-24  9:35   ` Alvin Šipraga
2026-09-18  1:45 ` [PATCH v2 7/9] ASoC: soc-dai: add snd_soc_dai_{set/to}_priv() Kuninori Morimoto
2026-09-18  1:45 ` [PATCH v2 8/9] ASoC: soc-dai: add snd_soc_dai_get_bclk[_ratio]() Kuninori Morimoto
2026-09-24  9:36   ` Alvin Šipraga
2026-09-18  1:46 ` [PATCH v2 9/9] ASoC: soc-dai: rename snd_soc_dai_action() to snd_soc_dai_active_update() Kuninori Morimoto
2026-09-24  9:33   ` Alvin Šipraga [this message]
2026-09-28 12:36 ` [PATCH v2 0/9] ASoC: add new DAI functions Mark Brown

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=arTuaAU7VfXvZ4In@analog.com \
    --to=alvin.sipraga@analog.com \
    --cc=broonie@kernel.org \
    --cc=kuninori.morimoto.gx@renesas.com \
    --cc=linux-sound@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.