From: Joe Damato <joe@dama.to>
To: Filip Balluch <fballuch@redhat.com>
Cc: anthony.l.nguyen@intel.com, przemyslaw.kitszel@intel.com,
andrew+netdev@lunn.ch, davem@davemloft.net, edumazet@google.com,
kuba@kernel.org, pabeni@redhat.com,
intel-wired-lan@lists.osuosl.org, netdev@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH] e1000e: rename init/exit module functions to avoid confusion with e1000
Date: Tue, 29 Sep 2026 16:13:23 -0700 [thread overview]
Message-ID: <arxGE+eYEmkxNQ61@devvm20253.cco0.facebook.com> (raw)
In-Reply-To: <20260915122639.64936-1-fballuch@redhat.com>
On Tue, Sep 15, 2026 at 02:26:38PM +0200, Filip Balluch wrote:
> The e1000e driver uses e1000_init_module and e1000_exit_module as its
> module init/exit function names, which are identical to those used by the
> older e1000 driver. Rename them to e1000e_init_module and
> e1000e_exit_module to clearly distinguish e1000e from the legacy e1000
> driver.
>
> Signed-off-by: Filip Balluch <fballuch@redhat.com>
> ---
> drivers/net/ethernet/intel/e1000e/netdev.c | 16 ++++++++--------
> 1 file changed, 8 insertions(+), 8 deletions(-)
Reviewed-by: Joe Damato <joe@dama.to>
prev parent reply other threads:[~2026-09-29 23:13 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-15 12:26 [PATCH] e1000e: rename init/exit module functions to avoid confusion with e1000 Filip Balluch
2026-09-15 12:26 ` [PATCH] i40e: fix freeing of TX rings on RX allocation failure Filip Balluch
2026-09-21 15:30 ` Loktionov, Aleksandr
2026-09-16 6:01 ` [PATCH] e1000e: rename init/exit module functions to avoid confusion with e1000 Loktionov, Aleksandr
2026-09-29 23:13 ` Joe Damato [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=arxGE+eYEmkxNQ61@devvm20253.cco0.facebook.com \
--to=joe@dama.to \
--cc=andrew+netdev@lunn.ch \
--cc=anthony.l.nguyen@intel.com \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=fballuch@redhat.com \
--cc=intel-wired-lan@lists.osuosl.org \
--cc=kuba@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=przemyslaw.kitszel@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.