All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Bernatowicz, Marcin" <marcin.bernatowicz@linux.intel.com>
To: "Laguna, Lukasz" <lukasz.laguna@intel.com>,
	igt-dev@lists.freedesktop.org
Cc: kamil.konieczny@linux.intel.com, adam.miszczak@linux.intel.com,
	jakub1.kolakowski@intel.com, michal.wajdeczko@intel.com,
	michal.winiarski@intel.com, narasimha.c.v@intel.com,
	piotr.piorkowski@intel.com, satyanarayana.k.v.p@intel.com,
	tomasz.lis@intel.com
Subject: Re: [PATCH i-g-t 3/3] tests/xe/xe_sriov_flr: Improve clear-ggtt subcheck initialization
Date: Wed, 20 Nov 2024 17:20:56 +0100	[thread overview]
Message-ID: <b69ab053-064c-47d9-8c2c-7ad2fd6ce60f@linux.intel.com> (raw)
In-Reply-To: <a0865a0a-40ad-478a-b930-f67e73676b82@intel.com>



On 11/20/2024 11:53 AM, Laguna, Lukasz wrote:
> On 11/19/2024 16:55, Marcin Bernatowicz wrote:
>> Mark the ggtt-clear subcheck as SKIP when prerequisites, such as scanning
>> GGTT provisioned offsets, are not met. Asserting in these cases falsely
>> implies that FLR is broken, while the test has not even started.
>>
>> Signed-off-by: Marcin Bernatowicz<marcin.bernatowicz@linux.intel.com>
>> Cc: Adam Miszczak<adam.miszczak@linux.intel.com>
>> Cc: C V Narasimha<narasimha.c.v@intel.com>
>> Cc: Jakub Kolakowski<jakub1.kolakowski@intel.com>
>> Cc: K V P Satyanarayana<satyanarayana.k.v.p@intel.com>
>> Cc: Lukasz Laguna<lukasz.laguna@intel.com>
>> Cc: Michał Wajdeczko<michal.wajdeczko@intel.com>
>> Cc: Michał Winiarski<michal.winiarski@intel.com>
>> Cc: Piotr Piórkowski<piotr.piorkowski@intel.com>
>> Cc: Tomasz Lis<tomasz.lis@intel.com>
>> ---
>>   tests/intel/xe_sriov_flr.c | 11 ++++++++---
>>   1 file changed, 8 insertions(+), 3 deletions(-)
>>
>> diff --git a/tests/intel/xe_sriov_flr.c b/tests/intel/xe_sriov_flr.c
>> index 1049cffec..502691765 100644
>> --- a/tests/intel/xe_sriov_flr.c
>> +++ b/tests/intel/xe_sriov_flr.c
>> @@ -393,7 +393,12 @@ static int populate_ggtt_pte_offsets(struct ggtt_data *gdata)
>>   		if (vf_id == 0)
>>   			continue;
>>   
>> -		igt_assert(vf_id >= 1 && vf_id <= num_vfs);
>> +		if (vf_id < 1 || vf_id > num_vfs) {
>> +			set_skip_reason(&gdata->base, "Unexpected VF%u at range entry %u [%#lx-%#lx], num_vfs=%u\n",
> 
> nit: Unexpected VF ID (%u)...
> 
>> +					vf_id, i, ranges[i].start, ranges[i].end, num_vfs);
>> +			free(ranges);
>> +			return -1;
>> +		}
>>   
>>   		if (gdata->pte_offsets[vf_id].end) {
>>   			set_skip_reason(&gdata->base, "Duplicate GGTT PTE offset range for VF%u\n",
>> @@ -410,7 +415,7 @@ static int populate_ggtt_pte_offsets(struct ggtt_data *gdata)
>>   
>>   	for (int vf_id = 1; vf_id <= num_vfs; ++vf_id)
>>   		if (!gdata->pte_offsets[vf_id].end) {
>> -			set_fail_reason(&gdata->base,
>> +			set_skip_reason(&gdata->base,
>>   					"Failed to find VF%u provisioned GGTT PTE offset range\n",
>>   					vf_id);
>>   			return -1;
>> @@ -440,7 +445,7 @@ static void ggtt_subcheck_init(struct subcheck_data *data)
>>   
>>   		populate_ggtt_pte_offsets(gdata);
>>   	} else {
>> -		set_fail_reason(data, "xe_mmio is NULL\n");
>> +		set_skip_reason(data, "xe_mmio is NULL\n");
>>   	}
>>   }
>>   
> 
> Looks good overall,but I see that we still fail in case of other 
> prerequisites not met (LMEM, GGTT write/read, no access to MMIO, etc). 
> Maybe we should skip in these cases too?

Makes sense, I'll extend the skips to the init/prepare phase for all checks.

Marcin

> 
> Lukasz
> 
> 


  reply	other threads:[~2024-11-20 16:21 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-11-19 15:55 [PATCH i-g-t 0/3] Improvements for xe_sriov_flr test and xe_mmio lib Marcin Bernatowicz
2024-11-19 15:55 ` [PATCH i-g-t 1/3] lib/xe/xe_mmio: Replace open-coded init/cleanup with existing functions Marcin Bernatowicz
2024-11-20 11:02   ` Laguna, Lukasz
2024-11-19 15:55 ` [PATCH i-g-t 2/3] lib/xe/xe_sriov_provisioning: Refactor range handling and logging Marcin Bernatowicz
2024-11-20 10:33   ` Laguna, Lukasz
2024-11-19 15:55 ` [PATCH i-g-t 3/3] tests/xe/xe_sriov_flr: Improve clear-ggtt subcheck initialization Marcin Bernatowicz
2024-11-20 10:53   ` Laguna, Lukasz
2024-11-20 16:20     ` Bernatowicz, Marcin [this message]
2024-11-20  0:30 ` ✗ CI.xeBAT: failure for Improvements for xe_sriov_flr test and xe_mmio lib Patchwork
2024-11-20  0:46 ` ✗ Fi.CI.BAT: " Patchwork

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=b69ab053-064c-47d9-8c2c-7ad2fd6ce60f@linux.intel.com \
    --to=marcin.bernatowicz@linux.intel.com \
    --cc=adam.miszczak@linux.intel.com \
    --cc=igt-dev@lists.freedesktop.org \
    --cc=jakub1.kolakowski@intel.com \
    --cc=kamil.konieczny@linux.intel.com \
    --cc=lukasz.laguna@intel.com \
    --cc=michal.wajdeczko@intel.com \
    --cc=michal.winiarski@intel.com \
    --cc=narasimha.c.v@intel.com \
    --cc=piotr.piorkowski@intel.com \
    --cc=satyanarayana.k.v.p@intel.com \
    --cc=tomasz.lis@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.