All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jan Beulich <jbeulich@suse.com>
To: dmukhin@xen.org
Cc: andrew.cooper3@citrix.com, anthony.perard@vates.tech,
	julien@xen.org, michal.orzel@amd.com, roger.pau@citrix.com,
	sstabellini@kernel.org, dmukhin@ford.com,
	xen-devel@lists.xenproject.org
Subject: Re: [PATCH v2] xen/domain: introduce DOMID_ANY
Date: Tue, 23 Sep 2025 00:43:54 +0200	[thread overview]
Message-ID: <c3a3bb25-b37f-4ccc-b71b-3bd5f5b8a3ef@suse.com> (raw)
In-Reply-To: <aNHGCmItdmjEAdZK@kraken>

On 22.09.2025 23:56, dmukhin@xen.org wrote:
> On Mon, Sep 22, 2025 at 05:23:37PM +0200, Jan Beulich wrote:
>> On 20.09.2025 19:47, dmukhin@xen.org wrote:
>>> From: Denis Mukhin <dmukhin@ford.com> 
>>>
>>> Add a new symbol DOMID_ANY aliasing DOMID_INVALID to improve the readability
>>> of the code.
>>>
>>> Update all relevant domid_alloc() call sites.
>>>
>>> Amends: 2d5065060710 ("xen/domain: unify domain ID allocation")
>>> Signed-off-by: Denis Mukhin <dmukhin@ford.com>
>>> ---
>>> Changes since v1:
>>> - moved DOMID_ANY from the public header
>>
>> This addresses my comment, but not Andrew's subsequent response, specifically
>> aiming at ...
> 
> AFAIU, toolstack should start using DOMID_ANY instead of 0 in
> XEN_DOMCTL_createdomain.
> 
> I was planning to send a separate patch to address it if that's OK.
> 
>>
>>> --- a/tools/tests/domid/harness.h
>>> +++ b/tools/tests/domid/harness.h
>>> @@ -41,6 +41,7 @@ extern unsigned long find_next_zero_bit(const unsigned long *addr,
>>>  
>>>  #define DOMID_FIRST_RESERVED            (100)
>>>  #define DOMID_INVALID                   (101)
>>> +#define DOMID_ANY                       DOMID_INVALID
>>
>> ... avoiding the need for any such secondary definitions.
> 
> In the current design, unit test harness.h has to define DOMID_ANY.
> Enabling xen/domain.h to compile for unit test is a separate task, IMO.

That wasn't suggested as an option. The #define wants to move back to
the public header, but be properly guarded there. See the v1 replies
you got.

Jan


  reply	other threads:[~2025-09-22 22:44 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-09-20 17:47 [PATCH v2] xen/domain: introduce DOMID_ANY dmukhin
2025-09-22 15:23 ` Jan Beulich
2025-09-22 21:56   ` dmukhin
2025-09-22 22:43     ` Jan Beulich [this message]
2025-09-24  2:55       ` dmukhin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=c3a3bb25-b37f-4ccc-b71b-3bd5f5b8a3ef@suse.com \
    --to=jbeulich@suse.com \
    --cc=andrew.cooper3@citrix.com \
    --cc=anthony.perard@vates.tech \
    --cc=dmukhin@ford.com \
    --cc=dmukhin@xen.org \
    --cc=julien@xen.org \
    --cc=michal.orzel@amd.com \
    --cc=roger.pau@citrix.com \
    --cc=sstabellini@kernel.org \
    --cc=xen-devel@lists.xenproject.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.