All of lore.kernel.org
 help / color / mirror / Atom feed
From: Thomas Huth <thuth@redhat.com>
To: "Philippe Mathieu-Daudé" <philmd@linaro.org>, qemu-devel@nongnu.org
Cc: qemu-riscv@nongnu.org, qemu-s390x@nongnu.org,
	Markus Armbruster <armbru@redhat.com>,
	qemu-arm@nongnu.org, qemu-ppc@nongnu.org
Subject: Re: [PATCH v4 3/7] hw/boards: Rename no_sdcard -> auto_create_sdcard
Date: Wed, 5 Feb 2025 08:04:45 +0100	[thread overview]
Message-ID: <c3fe91f8-4a4f-41cc-aacc-d76ea33ade52@redhat.com> (raw)
In-Reply-To: <20250204200934.65279-4-philmd@linaro.org>

On 04/02/2025 21.09, Philippe Mathieu-Daudé wrote:
> Invert the 'no_sdcard' logic, renaming it as the more explicit
> "auto_create_sdcard". Machines are supposed to create a SD Card
> drive when this flag is set. In many cases it doesn't make much
> sense (as boards don't expose SD Card host controller), but this
> is patch only aims to expose that nonsense; so no logical change
> intended (mechanical patch using gsed).
> 
> Most of the changes are:
> 
>    -    mc->no_sdcard = ON_OFF_AUTO_OFF;
>    +    mc->auto_create_sdcard = true;
> 
> Except in
>   . hw/core/null-machine.c
>   . hw/arm/xilinx_zynq.c
>   . hw/s390x/s390-virtio-ccw.c
> where the disabled option is manually removed (since default):
> 
>    -    mc->no_sdcard = ON_OFF_AUTO_ON;
>    +    mc->auto_create_sdcard = false;

You might want to remove that "+" line now, since you remove the setting now 
instead of setting it to "false"

Anyway:
Reviewed-by: Thomas Huth <thuth@redhat.com>



  reply	other threads:[~2025-02-05  7:05 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-02-04 20:09 [PATCH v4 0/7] hw/boards: Try to make sense of MachineClass::no_sdcard flag Philippe Mathieu-Daudé
2025-02-04 20:09 ` [PATCH v4 1/7] hw/boards: Convert no_sdcard flag to OnOffAuto tri-state Philippe Mathieu-Daudé
2025-02-04 20:09 ` [PATCH v4 2/7] hw/boards: Explicit no_sdcard=false as ON_OFF_AUTO_OFF Philippe Mathieu-Daudé
2025-02-04 20:09 ` [PATCH v4 3/7] hw/boards: Rename no_sdcard -> auto_create_sdcard Philippe Mathieu-Daudé
2025-02-05  7:04   ` Thomas Huth [this message]
2025-02-04 20:09 ` [PATCH v4 4/7] hw/boards: Remove all invalid uses of auto_create_sdcard=true Philippe Mathieu-Daudé
2025-02-04 20:09 ` [PATCH v4 5/7] hw/arm: " Philippe Mathieu-Daudé
2025-02-05  7:14   ` Thomas Huth
2025-02-04 20:09 ` [PATCH v4 6/7] hw/riscv: " Philippe Mathieu-Daudé
2025-02-04 20:09 ` [PATCH v4 7/7] hw/boards: Ensure machine setting auto_create_sdcard expose a SD Bus Philippe Mathieu-Daudé
2025-02-10 20:37 ` [PATCH v4 0/7] hw/boards: Try to make sense of MachineClass::no_sdcard flag Philippe Mathieu-Daudé

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=c3fe91f8-4a4f-41cc-aacc-d76ea33ade52@redhat.com \
    --to=thuth@redhat.com \
    --cc=armbru@redhat.com \
    --cc=philmd@linaro.org \
    --cc=qemu-arm@nongnu.org \
    --cc=qemu-devel@nongnu.org \
    --cc=qemu-ppc@nongnu.org \
    --cc=qemu-riscv@nongnu.org \
    --cc=qemu-s390x@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.