From: Jan Beulich <jbeulich@suse.com>
To: Jason Andryuk <jason.andryuk@amd.com>
Cc: "Daniel P. Smith" <dpsmith@apertussolutions.com>,
xen-devel@lists.xenproject.org
Subject: Re: [PATCH 2/4] xsm/silo: Support hwdom/control domains
Date: Fri, 13 Jun 2025 08:20:47 +0200 [thread overview]
Message-ID: <c7df3ed4-9c29-45b2-8be7-9f5d08560d1f@suse.com> (raw)
In-Reply-To: <fc719213-3ac4-4f3a-ab20-47b2170b2a1f@amd.com>
On 12.06.2025 18:56, Jason Andryuk wrote:
> On 2025-06-12 03:52, Jan Beulich wrote:
>> On 11.06.2025 06:20, Jason Andryuk wrote:
>>> On 2025-06-11 09:17, Jan Beulich wrote:
>>>> On 11.06.2025 00:57, Jason Andryuk wrote:
>>>>> --- a/xen/xsm/silo.c
>>>>> +++ b/xen/xsm/silo.c
>>>>> @@ -20,6 +20,12 @@
>>>>> #define XSM_NO_WRAPPERS
>>>>> #include <xsm/dummy.h>
>>>>>
>>>>> +static bool is_priv_domain(const struct domain *d)
>>>>> +{
>>>>> + return is_xenstore_domain(d) || is_hardware_domain(d) ||
>>>>> + is_control_domain(d);
>>>>> +}
>>>>
>>>> This construct expands to two evaluate_nospec(), which likely isn't
>>>> wanted. Some open-coding may be pretty much unavoidable here.
>>>
>>> Thanks, yes, good point.
>>>
>>>> (I'm
>>>> surprised it's not three, i.e. I find it odd that is_xenstore_domain()
>>>> doesn't also use that guard.)
>>>
>>> It looks okay to me. There were only 2 uses until I added a 3rd in the
>>> dom0less code. The XSM check has evaluate_nospec() and the other 2 uses
>>> aren't security critical - Setting a domain info flag, and __init code
>>> for dom0less. Maybe moving the evaluate_nospec() would be safer in case
>>> use grows in the future, but it looks okay to me today.
>>
>> When some of the hardening was first introduced, actual use sites were
>> indeed taken into account. That wasn't quite right though, I think. Any
>> such construct ought to be safe to use anywhere. For uses with clearly
>> no concerns towards speculative abuse, a 2nd lightweight form of such
>> constructs should then exist, imo. As to your use of "security critical":
>> I'm not convinced you what mean is covering the potential of speculative
>> abuse of involved code paths.
>
> I can't parse this last sentence, and I think it's your main point.
Oh, sorry - the "you" and "what" ought to have swapped places.
> XSM -> don't speculate around permission checks. That's what I meant by
> "security critical".
>
> The __init code is inaccessible to users, so it doesn't matter.
>
> if ( is_xenstore_domain(d) )
> continue;
>
> getdomaininfo sets a flag, so I don't see this making a security
> difference. It's not controlling loads or code paths.
Right, but this is what I said should imo not have been done: Make a
predicate speculation-safe (or not) based on its present uses. It's
imo more likely than not that a new use being added won't result in
the predicate being looked at, re-considering its safety for the new
use.
And indeed there's a 3rd use, in xsm_default_action():
case XSM_XS_PRIV:
if ( action == XSM_XS_PRIV &&
evaluate_nospec(is_xenstore_domain(src)) )
return 0;
fallthrough;
It should not have been necessary to open-code the speculation safety
here, just like such isn't required a few lines later:
case XSM_PRIV:
if ( is_control_domain(src) )
return 0;
return -EPERM;
I am, btw, also not convinced the uses of evaluate_nospec() are fully
correct here, in that they apply to only part of the if() conditions.
For "action == XSM_XS_PRIV" it's okay as long as
- the function is indeed inlined, and
- the function argument is compile-time constant.
For "target" the same applies, but there is more room there for the
latter of the constraints to not be met. The argument in favor of
the present arrangements likely was that our main concern here is
with the "success" paths. Yet such argumentation would again be
dependent upon all call sites fitting the assumption that on the
"failure" paths there would be nothing critical that follows.
Jan
next prev parent reply other threads:[~2025-06-13 6:21 UTC|newest]
Thread overview: 36+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-06-10 22:57 [PATCH 0/4] XSM changes for split hardware / control domain Jason Andryuk
2025-06-10 22:57 ` [PATCH 1/4] xen/xsm: Add XSM_HW_PRIV Jason Andryuk
2025-06-11 13:02 ` Jan Beulich
2025-06-11 3:13 ` Jason Andryuk
2025-06-12 7:36 ` Jan Beulich
2025-06-12 17:31 ` Jason Andryuk
2025-06-10 22:57 ` [PATCH 2/4] xsm/silo: Support hwdom/control domains Jason Andryuk
2025-06-11 13:17 ` Jan Beulich
2025-06-11 4:20 ` Jason Andryuk
2025-06-12 7:52 ` Jan Beulich
2025-06-12 16:56 ` Jason Andryuk
2025-06-12 20:30 ` Jason Andryuk
2025-06-13 6:20 ` Jan Beulich [this message]
2025-06-10 22:57 ` [PATCH 3/4] xen: Add DOMAIN_CAPS_DEVICE_MODEL & XEN_DOMCTL_CDF_device_model Jason Andryuk
2025-06-11 8:25 ` Christian Lindig
2025-06-11 13:24 ` Jan Beulich
2025-06-11 4:35 ` Jason Andryuk
2025-06-13 22:47 ` Stefano Stabellini
2025-06-13 23:44 ` Demi Marie Obenour
2025-06-14 0:15 ` Stefano Stabellini
2025-06-16 5:58 ` Jan Beulich
2025-06-17 0:21 ` Stefano Stabellini
2025-06-10 22:57 ` [PATCH 4/4] xsm/dummy: Allow hwdom SYSCTL_readconsole/physinfo Jason Andryuk
2025-06-11 13:27 ` Jan Beulich
2025-06-11 4:48 ` Jason Andryuk
2025-06-13 22:51 ` Stefano Stabellini
2025-06-16 6:36 ` Jan Beulich
2025-06-17 0:10 ` Stefano Stabellini
2025-06-17 5:23 ` Jan Beulich
2025-06-19 0:36 ` Stefano Stabellini
2025-06-20 6:05 ` Jan Beulich
2025-07-07 21:52 ` Stefano Stabellini
2025-06-11 13:28 ` [PATCH 0/4] XSM changes for split hardware / control domain Jan Beulich
2025-06-11 5:08 ` Jason Andryuk
2025-06-12 7:33 ` Jan Beulich
2025-06-13 22:59 ` Stefano Stabellini
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=c7df3ed4-9c29-45b2-8be7-9f5d08560d1f@suse.com \
--to=jbeulich@suse.com \
--cc=dpsmith@apertussolutions.com \
--cc=jason.andryuk@amd.com \
--cc=xen-devel@lists.xenproject.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.