From: "Thomas Hellström" <thomas.hellstrom@linux.intel.com>
To: Matthew Auld <matthew.auld@intel.com>, intel-xe@lists.freedesktop.org
Cc: dri-devel@lists.freedesktop.org, Matthew Brost <matthew.brost@intel.com>
Subject: Re: [PATCH 1/7] drm/gpusvm: fix hmm_pfn_to_map_order() usage
Date: Thu, 20 Mar 2025 20:52:56 +0100 [thread overview]
Message-ID: <d4803e357b7c7c2e17969c3df80dec70d25f947c.camel@linux.intel.com> (raw)
In-Reply-To: <20250320172956.168358-10-matthew.auld@intel.com>
On Thu, 2025-03-20 at 17:29 +0000, Matthew Auld wrote:
> Handle the case where the hmm range partially covers a huge page
> (like
> 2M), otherwise we can potentially end up doing something nasty like
> mapping memory which potentially is outside the range, and maybe not
> even mapped by the mm. Fix is based on the xe userptr code, which in
> a
> future patch will directly use gpusvm, so needs alignment here.
>
> Reported-by: Thomas Hellström <thomas.hellstrom@linux.intel.com>
> Signed-off-by: Matthew Auld <matthew.auld@intel.com>
> Cc: Matthew Brost <matthew.brost@intel.com>
> ---
> drivers/gpu/drm/drm_gpusvm.c | 25 +++++++++++++++++++++++--
> 1 file changed, 23 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/gpu/drm/drm_gpusvm.c
> b/drivers/gpu/drm/drm_gpusvm.c
> index 2451c816edd5..48993cef4a74 100644
> --- a/drivers/gpu/drm/drm_gpusvm.c
> +++ b/drivers/gpu/drm/drm_gpusvm.c
> @@ -817,6 +817,27 @@ drm_gpusvm_range_alloc(struct drm_gpusvm
> *gpusvm,
> return range;
> }
>
> +/*
> + * To allow skipping PFNs with the same flags (like when they belong
> to
> + * the same huge PTE) when looping over the pfn array, take a given
> a hmm_pfn,
> + * and return the largest order that will fit inside the PTE, but
> also crucially
> + * accounting for the original hmm range boundaries.
> + */
> +static unsigned int drm_gpusvm_hmm_pfn_to_order(unsigned long
> hmm_pfn,
> + unsigned long
> hmm_pfn_index,
> + unsigned long
> npages)
> +{
> + unsigned long size;
> +
> + size = 1UL << hmm_pfn_to_map_order(hmm_pfn);
> + size -= (hmm_pfn & ~HMM_PFN_FLAGS) & (size - 1);
> + hmm_pfn_index += size;
> + if (hmm_pfn_index > npages)
> + size -= (hmm_pfn_index - npages);
> +
> + return fls(size) - 1;
ilog2() for readability?
> +}
> +
> /**
> * drm_gpusvm_check_pages() - Check pages
> * @gpusvm: Pointer to the GPU SVM structure
> @@ -875,7 +896,7 @@ static bool drm_gpusvm_check_pages(struct
> drm_gpusvm *gpusvm,
> err = -EFAULT;
> goto err_free;
> }
> - i += 0x1 << hmm_pfn_to_map_order(pfns[i]);
> + i += 0x1 << drm_gpusvm_hmm_pfn_to_order(pfns[i], i,
> npages);
> }
>
> err_free:
> @@ -1408,7 +1429,7 @@ int drm_gpusvm_range_get_pages(struct
> drm_gpusvm *gpusvm,
> for (i = 0, j = 0; i < npages; ++j) {
> struct page *page = hmm_pfn_to_page(pfns[i]);
>
> - order = hmm_pfn_to_map_order(pfns[i]);
> + order = drm_gpusvm_hmm_pfn_to_order(pfns[i], i,
> npages);
> if (is_device_private_page(page) ||
> is_device_coherent_page(page)) {
> if (zdd != page->zone_device_data && i > 0)
> {
Either way
Reviewed-by: Thomas Hellström <thomas.hellstrom@linux.intel.com>
next prev parent reply other threads:[~2025-03-20 19:53 UTC|newest]
Thread overview: 25+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-03-20 17:29 [PATCH 0/7] Replace xe_hmm with gpusvm Matthew Auld
2025-03-20 17:29 ` [PATCH 1/7] drm/gpusvm: fix hmm_pfn_to_map_order() usage Matthew Auld
2025-03-20 19:52 ` Thomas Hellström [this message]
2025-03-20 20:40 ` Matthew Brost
2025-03-21 11:42 ` Matthew Auld
2025-03-20 17:29 ` [PATCH 2/7] drm/gpusvm: use more selective dma dir in get_pages() Matthew Auld
2025-03-20 19:31 ` Thomas Hellström
2025-03-20 19:37 ` Matthew Brost
2025-03-20 17:30 ` [PATCH 3/7] drm/gpusvm: mark pages as dirty Matthew Auld
2025-03-20 19:29 ` Thomas Hellström
2025-03-20 19:33 ` Matthew Brost
2025-03-21 11:37 ` Matthew Auld
2025-03-20 17:30 ` [PATCH 4/7] drm/gpusvm: pull out drm_gpusvm_pages substructure Matthew Auld
2025-03-20 20:43 ` Matthew Brost
2025-03-21 11:53 ` Matthew Auld
2025-03-20 17:30 ` [PATCH 5/7] drm/gpusvm: lower get/unmap pages Matthew Auld
2025-03-20 20:59 ` Matthew Brost
2025-03-20 17:30 ` [PATCH 6/7] drm/gpusvm: support basic_range Matthew Auld
2025-03-20 21:04 ` Matthew Brost
2025-03-20 17:30 ` [PATCH 7/7] drm/xe/userptr: replace xe_hmm with gpusvm Matthew Auld
2025-03-20 20:52 ` Matthew Brost
2025-03-25 9:50 ` Ghimiray, Himal Prasad
2025-03-20 17:37 ` ✓ CI.Patch_applied: success for Replace " Patchwork
2025-03-20 17:37 ` ✗ CI.checkpatch: warning " Patchwork
2025-03-20 17:38 ` ✗ CI.KUnit: failure " Patchwork
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d4803e357b7c7c2e17969c3df80dec70d25f947c.camel@linux.intel.com \
--to=thomas.hellstrom@linux.intel.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=intel-xe@lists.freedesktop.org \
--cc=matthew.auld@intel.com \
--cc=matthew.brost@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.