From: Eduard Zingerman <eddyz87@gmail.com>
To: Andrii Nakryiko <andrii@kernel.org>, bpf@vger.kernel.org
Cc: linux-mm@kvack.org, akpm@linux-foundation.org,
adobriyan@gmail.com, shakeel.butt@linux.dev, hannes@cmpxchg.org,
ak@linux.intel.com, osandov@osandov.com, song@kernel.org,
jannh@google.com, linux-fsdevel@vger.kernel.org,
willy@infradead.org
Subject: Re: [PATCH v6 bpf-next 00/10] Harden and extend ELF build ID parsing logic
Date: Fri, 23 Aug 2024 16:22:55 -0700 [thread overview]
Message-ID: <d9a46f4d54df8d5ac57011222ebdf21b0f15f52d.camel@gmail.com> (raw)
In-Reply-To: <20240814185417.1171430-1-andrii@kernel.org>
On Wed, 2024-08-14 at 11:54 -0700, Andrii Nakryiko wrote:
[...]
> Andrii Nakryiko (10):
> lib/buildid: harden build ID parsing logic
> lib/buildid: add single folio-based file reader abstraction
> lib/buildid: take into account e_phoff when fetching program headers
> lib/buildid: remove single-page limit for PHDR search
> lib/buildid: rename build_id_parse() into build_id_parse_nofault()
> lib/buildid: implement sleepable build_id_parse() API
> lib/buildid: don't limit .note.gnu.build-id to the first page in ELF
Never worked with lib/buildid before, so not sure how valuable my input is.
Anyways:
- I compared the resulting parser with ELF specification and available
documentation for buildid, all seems correct.
(with a small caveat that ELF defines Elf{32,64}_Ehdr->e_ehsize field
to encode actual size of the elf header, and e_phentsize
to encode actual size of the program header.
Parser uses sizeof(Elf{32,64}_{Ehdr,Phdr}) instead,
and this is how it was before, so probably does not matter).
- The `freader` abstraction nicely hides away difference between
sleepable and non-sleepable contexts.
(with a caveat, that freader_get_folio() uses read_cache_folio()
which is documented as expecting mapping->invalidate_lock to be held.
I assume that this is true for vma's passed to build_id_parse(), right?)
For what it's worth, full patch-set looks good to me.
Reviewed-by: Eduard Zingerman <eddyz87@gmail.com>
[...]
next prev parent reply other threads:[~2024-08-23 23:23 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-08-14 18:54 [PATCH v6 bpf-next 00/10] Harden and extend ELF build ID parsing logic Andrii Nakryiko
2024-08-14 18:54 ` [PATCH v6 bpf-next 01/10] lib/buildid: harden " Andrii Nakryiko
2024-08-14 18:54 ` [PATCH v6 bpf-next 02/10] lib/buildid: add single folio-based file reader abstraction Andrii Nakryiko
2024-08-14 18:54 ` [PATCH v6 bpf-next 03/10] lib/buildid: take into account e_phoff when fetching program headers Andrii Nakryiko
2024-08-14 18:54 ` [PATCH v6 bpf-next 04/10] lib/buildid: remove single-page limit for PHDR search Andrii Nakryiko
2024-08-14 18:54 ` [PATCH v6 bpf-next 05/10] lib/buildid: rename build_id_parse() into build_id_parse_nofault() Andrii Nakryiko
2024-08-14 18:54 ` [PATCH v6 bpf-next 06/10] lib/buildid: implement sleepable build_id_parse() API Andrii Nakryiko
2024-08-14 18:54 ` [PATCH v6 bpf-next 07/10] lib/buildid: don't limit .note.gnu.build-id to the first page in ELF Andrii Nakryiko
2024-08-14 18:54 ` [PATCH v6 bpf-next 08/10] bpf: decouple stack_map_get_build_id_offset() from perf_callchain_entry Andrii Nakryiko
2024-08-22 20:32 ` Eduard Zingerman
2024-08-14 18:54 ` [PATCH v6 bpf-next 09/10] bpf: wire up sleepable bpf_get_stack() and bpf_get_task_stack() helpers Andrii Nakryiko
2024-08-23 22:22 ` Eduard Zingerman
2024-08-26 16:19 ` Andrii Nakryiko
2024-08-14 18:54 ` [PATCH v6 bpf-next 10/10] selftests/bpf: add build ID tests Andrii Nakryiko
2024-08-22 22:30 ` Eduard Zingerman
2024-08-22 22:55 ` Andrii Nakryiko
2024-08-22 23:07 ` Eduard Zingerman
2024-08-23 23:22 ` Eduard Zingerman [this message]
2024-08-25 19:35 ` [PATCH v6 bpf-next 00/10] Harden and extend ELF build ID parsing logic Alexei Starovoitov
2024-08-26 21:30 ` Andrii Nakryiko
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d9a46f4d54df8d5ac57011222ebdf21b0f15f52d.camel@gmail.com \
--to=eddyz87@gmail.com \
--cc=adobriyan@gmail.com \
--cc=ak@linux.intel.com \
--cc=akpm@linux-foundation.org \
--cc=andrii@kernel.org \
--cc=bpf@vger.kernel.org \
--cc=hannes@cmpxchg.org \
--cc=jannh@google.com \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=osandov@osandov.com \
--cc=shakeel.butt@linux.dev \
--cc=song@kernel.org \
--cc=willy@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.