All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Ghimiray, Himal Prasad" <himal.prasad.ghimiray@intel.com>
To: <intel-xe@lists.freedesktop.org>,
	Rodrigo Vivi <rodrigo.vivi@intel.com>,
	Lucas De Marchi <lucas.demarchi@intel.com>,
	Michal Wajdeczko <michal.wajdeczko@intel.com>
Subject: Re: ✗ CI.KUnit: failure for Fix xe_force_wake_get() failure handling (rev6)
Date: Mon, 30 Sep 2024 13:05:48 +0530	[thread overview]
Message-ID: <d9fab8c6-9943-481a-839b-e95950bcc142@intel.com> (raw)
In-Reply-To: <172767623196.1133357.14970746584647639652@2413ebb6fbb6>



On 30-09-2024 11:33, Patchwork wrote:
> == Series Details ==
> 
> Series: Fix xe_force_wake_get() failure handling (rev6)
> URL   : https://patchwork.freedesktop.org/series/137982/
> State : failure
> 
> == Summary ==
> 
> + trap cleanup EXIT
> + /kernel/tools/testing/kunit/kunit.py run --kunitconfig /kernel/drivers/gpu/drm/xe/.kunitconfig
> ERROR:root:../drivers/gpu/drm/xe/xe_gt_idle.c:56:27: error: redefinition of ‘str_up_down’
>     56 | static inline const char *str_up_down(bool v)

Author: Michal Wajdeczko <michal.wajdeczko@intel.com>
Date:   10 weeks ago

     lib/string_choices: Add str_up_down() helper

     Add str_up_down() helper to return "up" or "down" string literal.

     Signed-off-by: Michal Wajdeczko <michal.wajdeczko@intel.com>
     Link: 
https://lore.kernel.org/r/20240725101841.574-1-michal.wajdeczko@intel.com
     Signed-off-by: Kees Cook <kees@kernel.org>

Is merged to drm-tip needs to be backported to drm-xe-next, along with 
removing local copy of str_up_down from xe_gt_idle.c.

Failure is not related https://patchwork.freedesktop.org/series/137982/.

>        |                           ^~~~~~~~~~~
> In file included from ../include/linux/string_helpers.h:7,
>                   from ../drivers/gpu/drm/xe/xe_assert.h:9,
>                   from ../drivers/gpu/drm/xe/xe_force_wake.h:9,
>                   from ../drivers/gpu/drm/xe/xe_gt_idle.c:8:
> ../include/linux/string_choices.h:62:27: note: previous definition of ‘str_up_down’ with type ‘const char *(bool)’ {aka ‘const char *(_Bool)’}
>     62 | static inline const char *str_up_down(bool v)
>        |                           ^~~~~~~~~~~
> make[7]: *** [../scripts/Makefile.build:229: drivers/gpu/drm/xe/xe_gt_idle.o] Error 1
> make[7]: *** Waiting for unfinished jobs....
> make[6]: *** [../scripts/Makefile.build:478: drivers/gpu/drm/xe] Error 2
> make[6]: *** Waiting for unfinished jobs....
> ../lib/iomap.c:156:5: warning: no previous prototype for ‘ioread64_lo_hi’ [-Wmissing-prototypes]
>    156 | u64 ioread64_lo_hi(const void __iomem *addr)
>        |     ^~~~~~~~~~~~~~
> ../lib/iomap.c:163:5: warning: no previous prototype for ‘ioread64_hi_lo’ [-Wmissing-prototypes]
>    163 | u64 ioread64_hi_lo(const void __iomem *addr)
>        |     ^~~~~~~~~~~~~~
> ../lib/iomap.c:170:5: warning: no previous prototype for ‘ioread64be_lo_hi’ [-Wmissing-prototypes]
>    170 | u64 ioread64be_lo_hi(const void __iomem *addr)
>        |     ^~~~~~~~~~~~~~~~
> ../lib/iomap.c:178:5: warning: no previous prototype for ‘ioread64be_hi_lo’ [-Wmissing-prototypes]
>    178 | u64 ioread64be_hi_lo(const void __iomem *addr)
>        |     ^~~~~~~~~~~~~~~~
> ../lib/iomap.c:264:6: warning: no previous prototype for ‘iowrite64_lo_hi’ [-Wmissing-prototypes]
>    264 | void iowrite64_lo_hi(u64 val, void __iomem *addr)
>        |      ^~~~~~~~~~~~~~~
> ../lib/iomap.c:272:6: warning: no previous prototype for ‘iowrite64_hi_lo’ [-Wmissing-prototypes]
>    272 | void iowrite64_hi_lo(u64 val, void __iomem *addr)
>        |      ^~~~~~~~~~~~~~~
> ../lib/iomap.c:280:6: warning: no previous prototype for ‘iowrite64be_lo_hi’ [-Wmissing-prototypes]
>    280 | void iowrite64be_lo_hi(u64 val, void __iomem *addr)
>        |      ^~~~~~~~~~~~~~~~~
> ../lib/iomap.c:288:6: warning: no previous prototype for ‘iowrite64be_hi_lo’ [-Wmissing-prototypes]
>    288 | void iowrite64be_hi_lo(u64 val, void __iomem *addr)
>        |      ^~~~~~~~~~~~~~~~~
> make[5]: *** [../scripts/Makefile.build:478: drivers/gpu/drm] Error 2
> make[4]: *** [../scripts/Makefile.build:478: drivers/gpu] Error 2
> make[3]: *** [../scripts/Makefile.build:478: drivers] Error 2
> make[3]: *** Waiting for unfinished jobs....
> make[2]: *** [/kernel/Makefile:1936: .] Error 2
> make[1]: *** [/kernel/Makefile:224: __sub-make] Error 2
> make: *** [Makefile:224: __sub-make] Error 2
> 
> [06:03:18] Configuring KUnit Kernel ...
> Generating .config ...
> Populating config with:
> $ make ARCH=um O=.kunit olddefconfig
> [06:03:23] Building KUnit Kernel ...
> Populating config with:
> $ make ARCH=um O=.kunit olddefconfig
> Building with:
> $ make all compile_commands.json ARCH=um O=.kunit --jobs=48
> + cleanup
> ++ stat -c %u:%g /kernel
> + chown -R 1003:1003 /kernel
> 
> 


  reply	other threads:[~2024-09-30  7:37 UTC|newest]

Thread overview: 54+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-09-30  5:31 [PATCH v6 00/25] Fix xe_force_wake_get() failure handling Himal Prasad Ghimiray
2024-09-30  5:31 ` [PATCH v6 01/25] drm/xe: Add member initialized_domains to xe_force_wake() Himal Prasad Ghimiray
2024-09-30 19:51   ` Michal Wajdeczko
2024-10-01  5:03     ` Ghimiray, Himal Prasad
2024-09-30  5:31 ` [PATCH v6 02/25] drm/xe/forcewake: Add a helper xe_force_wake_ref_has_domain() Himal Prasad Ghimiray
2024-09-30 20:04   ` Michal Wajdeczko
2024-10-01  5:06     ` Ghimiray, Himal Prasad
2024-09-30  5:31 ` [PATCH v6 03/25] drm/xe: Error handling in xe_force_wake_get() Himal Prasad Ghimiray
2024-10-03 12:23   ` Nilawar, Badal
2024-10-03 16:10     ` Ghimiray, Himal Prasad
2024-10-04  7:40       ` Nilawar, Badal
2024-10-07  3:14         ` Ghimiray, Himal Prasad
2024-09-30  5:31 ` [PATCH v6 04/25] drm/xe: Modify xe_force_wake_put to handle _get returned mask Himal Prasad Ghimiray
2024-09-30 20:13   ` Michal Wajdeczko
2024-09-30 20:15     ` Michal Wajdeczko
2024-10-01  5:11       ` Ghimiray, Himal Prasad
2024-10-04  3:21         ` Nilawar, Badal
2024-09-30 22:13   ` Matt Roper
2024-10-01  5:31     ` Ghimiray, Himal Prasad
2024-09-30  5:31 ` [PATCH v6 05/25] drm/xe/device: Update handling of xe_force_wake_get return Himal Prasad Ghimiray
2024-10-04  7:18   ` Nilawar, Badal
2024-10-07  3:40     ` Ghimiray, Himal Prasad
2024-09-30  5:31 ` [PATCH v6 06/25] drm/xe/hdcp: " Himal Prasad Ghimiray
2024-09-30  5:31 ` [PATCH v6 07/25] drm/xe/gsc: " Himal Prasad Ghimiray
2024-09-30  5:31 ` [PATCH v6 08/25] drm/xe/gt: " Himal Prasad Ghimiray
2024-09-30  5:31 ` [PATCH v6 09/25] drm/xe/xe_gt_idle: " Himal Prasad Ghimiray
2024-09-30  5:31 ` [PATCH v6 10/25] drm/xe/devcoredump: " Himal Prasad Ghimiray
2024-09-30  5:31 ` [PATCH v6 11/25] drm/xe/tests/mocs: Update xe_force_wake_get() return handling Himal Prasad Ghimiray
2024-09-30  5:31 ` [PATCH v6 12/25] drm/xe/mocs: Update handling of xe_force_wake_get return Himal Prasad Ghimiray
2024-09-30  5:31 ` [PATCH v6 13/25] drm/xe/xe_drm_client: " Himal Prasad Ghimiray
2024-09-30  5:31 ` [PATCH v6 14/25] drm/xe/xe_gt_debugfs: " Himal Prasad Ghimiray
2024-09-30  5:31 ` [PATCH v6 15/25] drm/xe/guc: " Himal Prasad Ghimiray
2024-09-30  5:31 ` [PATCH v6 16/25] drm/xe/huc: " Himal Prasad Ghimiray
2024-09-30  5:31 ` [PATCH v6 17/25] drm/xe/oa: Handle force_wake_get failure in xe_oa_stream_init() Himal Prasad Ghimiray
2024-09-30  5:31 ` [PATCH v6 18/25] drm/xe/pat: Update handling of xe_force_wake_get return Himal Prasad Ghimiray
2024-09-30  5:31 ` [PATCH v6 19/25] drm/xe/gt_tlb_invalidation_ggtt: " Himal Prasad Ghimiray
2024-09-30  5:31 ` [PATCH v6 20/25] drm/xe/xe_reg_sr: " Himal Prasad Ghimiray
2024-09-30  5:31 ` [PATCH v6 21/25] drm/xe/query: " Himal Prasad Ghimiray
2024-09-30  5:31 ` [PATCH v6 22/25] drm/xe/vram: " Himal Prasad Ghimiray
2024-09-30  5:31 ` [PATCH v6 23/25] drm/xe: forcewake debugfs open fails on xe_forcewake_get failure Himal Prasad Ghimiray
2024-09-30  5:31 ` [PATCH v6 24/25] drm/xe: Ensure __must_check for xe_force_wake_get() return Himal Prasad Ghimiray
2024-09-30  5:31 ` [PATCH v6 25/25] drm/xe: Change return type to void for xe_force_wake_put Himal Prasad Ghimiray
2024-09-30  6:02 ` ✓ CI.Patch_applied: success for Fix xe_force_wake_get() failure handling (rev6) Patchwork
2024-09-30  6:03 ` ✓ CI.checkpatch: " Patchwork
2024-09-30  6:03 ` ✗ CI.KUnit: failure " Patchwork
2024-09-30  7:35   ` Ghimiray, Himal Prasad [this message]
2024-09-30 20:55 ` ✓ CI.Patch_applied: success for Fix xe_force_wake_get() failure handling (rev7) Patchwork
2024-09-30 20:55 ` ✓ CI.checkpatch: " Patchwork
2024-09-30 20:57 ` ✓ CI.KUnit: " Patchwork
2024-09-30 21:08 ` ✓ CI.Build: " Patchwork
2024-09-30 21:10 ` ✗ CI.Hooks: failure " Patchwork
2024-09-30 21:12 ` ✓ CI.checksparse: success " Patchwork
2024-09-30 21:39 ` ✗ CI.BAT: failure " Patchwork
2024-10-01  6:20 ` ✗ CI.FULL: " Patchwork

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=d9fab8c6-9943-481a-839b-e95950bcc142@intel.com \
    --to=himal.prasad.ghimiray@intel.com \
    --cc=intel-xe@lists.freedesktop.org \
    --cc=lucas.demarchi@intel.com \
    --cc=michal.wajdeczko@intel.com \
    --cc=rodrigo.vivi@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.