All of lore.kernel.org
 help / color / mirror / Atom feed
From: Damien Le Moal <dlemoal@kernel.org>
To: Bart Van Assche <bvanassche@acm.org>,
	"Martin K . Petersen" <martin.petersen@oracle.com>
Cc: linux-scsi@vger.kernel.org, Christoph Hellwig <hch@lst.de>,
	Niklas Cassel <cassel@kernel.org>,
	Takashi Sakamoto <o-takashi@sakamocchi.jp>,
	Yihang Li <liyihang9@huawei.com>,
	"James E.J. Bottomley" <James.Bottomley@HansenPartnership.com>,
	HighPoint Linux Team <linux@highpoint-tech.com>,
	Brian King <brking@us.ibm.com>, Lee Duncan <lduncan@suse.com>,
	Chris Leech <cleech@redhat.com>,
	Mike Christie <michael.christie@oracle.com>,
	Kashyap Desai <kashyap.desai@broadcom.com>,
	Sumit Saxena <sumit.saxena@broadcom.com>,
	Shivasharan S <shivasharan.srikanteshwara@broadcom.com>,
	Chandrakanth patil <chandrakanth.patil@broadcom.com>,
	Sathya Prakash Veerichetty <sathya.prakash@broadcom.com>,
	Sreekanth Reddy <sreekanth.reddy@broadcom.com>,
	Suganath Prabu Subramani <suganath-prabu.subramani@broadcom.com>,
	Alan Stern <stern@rowland.harvard.edu>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Oliver Neukum <oneukum@suse.com>, Hannes Reinecke <hare@suse.de>,
	John Garry <john.g.garry@oracle.com>,
	Peter Wang <peter.wang@mediatek.com>,
	Manivannan Sadhasivam <manivannan.sadhasivam@linaro.org>,
	Avri Altman <avri.altman@wdc.com>,
	Andrew Halaney <ahalaney@redhat.com>,
	Bean Huo <beanhuo@micron.com>
Subject: Re: [PATCH v3 3/6] scsi: Rename .device_configure() into .sdev_configure()
Date: Wed, 9 Oct 2024 13:13:47 +0900	[thread overview]
Message-ID: <e7067f1e-a3ed-4110-970c-bc55f707c6e3@kernel.org> (raw)
In-Reply-To: <20241008205139.3743722-4-bvanassche@acm.org>

On 10/9/24 05:50, Bart Van Assche wrote:
> Improve naming consistency with the .sdev_prep() and .sdev_destroy()
> methods by renaming .device_configure() into .sdev_configure().
> 
> Cc: Christoph Hellwig <hch@lst.de>
> Reviewed-by: Damien Le Moal <dlemoal@kernel.org> # for the ATA changes
> Signed-off-by: Bart Van Assche <bvanassche@acm.org>

Acked-by: Damien Le Moal <dlemoal@kernel.org>

-- 
Damien Le Moal
Western Digital Research

  reply	other threads:[~2024-10-09  4:13 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-10-08 20:50 [PATCH v3 0/6] Replace the "slave_*" function names Bart Van Assche
2024-10-08 20:50 ` [PATCH v3 1/6] scsi: Rename .slave_alloc() and .slave_destroy() Bart Van Assche
2024-10-09  4:12   ` Damien Le Moal
2024-10-08 20:50 ` [PATCH v3 2/6] scsi: core: Rename .slave_alloc() and .slave_destroy() in the documentation Bart Van Assche
2024-10-08 23:00   ` Randy Dunlap
2024-10-08 23:05     ` Bart Van Assche
2024-10-08 23:26       ` Randy Dunlap
2024-10-08 23:51         ` Damien Le Moal
2024-10-09 17:42           ` Bart Van Assche
2024-10-09  4:13   ` Damien Le Moal
2024-10-08 20:50 ` [PATCH v3 3/6] scsi: Rename .device_configure() into .sdev_configure() Bart Van Assche
2024-10-09  4:13   ` Damien Le Moal [this message]
2024-10-08 20:50 ` [PATCH v3 4/6] scsi: Convert SCSI drivers to .sdev_configure() Bart Van Assche
2024-10-08 20:50 ` [PATCH v3 5/6] scsi: core: Remove the .slave_configure() method Bart Van Assche
2024-10-08 20:50 ` [PATCH v3 6/6] scsi: core: Update .slave_configure() references in the documentation Bart Van Assche

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=e7067f1e-a3ed-4110-970c-bc55f707c6e3@kernel.org \
    --to=dlemoal@kernel.org \
    --cc=James.Bottomley@HansenPartnership.com \
    --cc=ahalaney@redhat.com \
    --cc=avri.altman@wdc.com \
    --cc=beanhuo@micron.com \
    --cc=brking@us.ibm.com \
    --cc=bvanassche@acm.org \
    --cc=cassel@kernel.org \
    --cc=chandrakanth.patil@broadcom.com \
    --cc=cleech@redhat.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=hare@suse.de \
    --cc=hch@lst.de \
    --cc=john.g.garry@oracle.com \
    --cc=kashyap.desai@broadcom.com \
    --cc=lduncan@suse.com \
    --cc=linux-scsi@vger.kernel.org \
    --cc=linux@highpoint-tech.com \
    --cc=liyihang9@huawei.com \
    --cc=manivannan.sadhasivam@linaro.org \
    --cc=martin.petersen@oracle.com \
    --cc=michael.christie@oracle.com \
    --cc=o-takashi@sakamocchi.jp \
    --cc=oneukum@suse.com \
    --cc=peter.wang@mediatek.com \
    --cc=sathya.prakash@broadcom.com \
    --cc=shivasharan.srikanteshwara@broadcom.com \
    --cc=sreekanth.reddy@broadcom.com \
    --cc=stern@rowland.harvard.edu \
    --cc=suganath-prabu.subramani@broadcom.com \
    --cc=sumit.saxena@broadcom.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.