All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Dong, Zhanjun" <zhanjun.dong@intel.com>
To: Michal Wajdeczko <michal.wajdeczko@intel.com>,
	<intel-xe@lists.freedesktop.org>,
	Daniele Ceraolo Spurio <daniele.ceraolospurio@intel.com>
Subject: Re: [PATCH v4 2/2] drm/xe/guc: Update GuC log buffer type value
Date: Thu, 9 Oct 2025 10:38:55 -0400	[thread overview]
Message-ID: <e7972531-e105-41ed-90f7-5be793599631@intel.com> (raw)
In-Reply-To: <df58cadf-80d2-4c6b-92d9-beeb8630fc5a@intel.com>



On 2025-10-04 12:42 p.m., Michal Wajdeczko wrote:
> 
> 
> On 10/2/2025 5:03 PM, Zhanjun Dong wrote:
>> Update GuC log buffer type value, to align with the GuC specification.
>> Rename GUC_LOG_BUFFER_DEBUG to GUC_LOG_BUFFER_EVENT_LOG.
> 
> hmm, my copy of GuC specification has:
> 
> 	GENERAL = 0	/* Log event data */
> 	CRASH = 1	/* Raw crash data */
> 	ERROR_STATE_CAPTURE = 2	/* Error State Capture data */
> 
> so if the goal is to align (more) with the spec, maybe it should be (to keep them reasonable short):
> 
> 	GENERAL_LOG

1st, the issue is the "GENERAL" here give us no information about what 
it is,
GENERAL_LOG almost equal to _LOG.
2nd, here is within the enum define about log buffer type, so _LOG here 
also didn't tell us anything.

As you mentioned:
   GENERAL = 0	/* Log event data */
that's why I would like to use the name from comment

EVENT_LOG
This name tell us something and also aligned with spec.
or maybe
EVENT
as _LOG means nothing here
BTW, the previous name _DEBUG not aligns with spec, too generic and not 
provide much info.

> 	CRASH_DUMP
> 	ERROR_CAPTURE
That's fine

Regards,
Zhanjun Dong

> 
> + @Daniele
> 
> and btw, IMO this patch should be before the other one that cleanups macros
> 
>>
>> Signed-off-by: Zhanjun Dong <zhanjun.dong@intel.com>
>> ---
>>   drivers/gpu/drm/xe/abi/guc_log_abi.h | 2 +-
>>   drivers/gpu/drm/xe/xe_guc_log.c      | 2 +-
>>   2 files changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/drivers/gpu/drm/xe/abi/guc_log_abi.h b/drivers/gpu/drm/xe/abi/guc_log_abi.h
>> index 554630b7ccd9..1a487164b980 100644
>> --- a/drivers/gpu/drm/xe/abi/guc_log_abi.h
>> +++ b/drivers/gpu/drm/xe/abi/guc_log_abi.h
>> @@ -10,8 +10,8 @@
>>   
>>   /* GuC logging buffer types */
>>   enum guc_log_buffer_type {
>> +	GUC_LOG_BUFFER_EVENT_LOG,
>>   	GUC_LOG_BUFFER_CRASH_DUMP,
>> -	GUC_LOG_BUFFER_DEBUG,
>>   	GUC_LOG_BUFFER_CAPTURE,
>>   };
> 
>>   
>> diff --git a/drivers/gpu/drm/xe/xe_guc_log.c b/drivers/gpu/drm/xe/xe_guc_log.c
>> index fa1d490dca0d..900b39fc734f 100644
>> --- a/drivers/gpu/drm/xe/xe_guc_log.c
>> +++ b/drivers/gpu/drm/xe/xe_guc_log.c
>> @@ -293,7 +293,7 @@ u32 xe_guc_get_log_buffer_offset(struct xe_guc_log *log, enum guc_log_buffer_typ
>>   	case GUC_LOG_BUFFER_CRASH_DUMP:
>>   		offset += XE_GUC_LOG_EVENT_LOG_BUFFER_SIZE;
>>   		fallthrough;
>> -	case GUC_LOG_BUFFER_DEBUG:
>> +	case GUC_LOG_BUFFER_EVENT_LOG:
>>   		break;
>>   	}
>>   
> 


  reply	other threads:[~2025-10-09 14:39 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-10-02 15:03 [PATCH v4 0/2] drm/xe/guc: Cleanup GuC log buffer macros and helpers Zhanjun Dong
2025-10-02 15:03 ` [PATCH v4 1/2] drm/xe/guc: Add prefix to guc log buffer macros Zhanjun Dong
2025-10-02 16:00   ` Lucas De Marchi
2025-10-02 17:24     ` Lucas De Marchi
2025-10-07 16:44     ` Dong, Zhanjun
2025-10-07 17:08       ` Lucas De Marchi
2025-10-09 17:54         ` Dong, Zhanjun
2025-10-09 19:12           ` Michal Wajdeczko
2025-10-04 17:13   ` Michal Wajdeczko
2025-10-02 15:03 ` [PATCH v4 2/2] drm/xe/guc: Update GuC log buffer type value Zhanjun Dong
2025-10-04 16:42   ` Michal Wajdeczko
2025-10-09 14:38     ` Dong, Zhanjun [this message]
2025-10-02 15:35 ` ✓ CI.KUnit: success for drm/xe/guc: Cleanup GuC log buffer macros and helpers Patchwork
2025-10-02 16:18 ` ✓ Xe.CI.BAT: " Patchwork
2025-10-02 18:48 ` ✓ Xe.CI.Full: " Patchwork

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=e7972531-e105-41ed-90f7-5be793599631@intel.com \
    --to=zhanjun.dong@intel.com \
    --cc=daniele.ceraolospurio@intel.com \
    --cc=intel-xe@lists.freedesktop.org \
    --cc=michal.wajdeczko@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.