From: "Jürgen Groß" <jgross@suse.com>
To: Reinette Chatre <reinette.chatre@intel.com>,
linux-kernel@vger.kernel.org, x86@kernel.org
Cc: Thomas Gleixner <tglx@kernel.org>, Ingo Molnar <mingo@redhat.com>,
Borislav Petkov <bp@alien8.de>,
Dave Hansen <dave.hansen@linux.intel.com>,
"H. Peter Anvin" <hpa@zytor.com>, Tony Luck <tony.luck@intel.com>,
Dave Martin <Dave.Martin@arm.com>,
James Morse <james.morse@arm.com>,
Babu Moger <babu.moger@amd.com>
Subject: Re: [PATCH 1/5] x86/msr: Switch users of native_wrmsr() to native_wrmsrq()
Date: Thu, 2 Jul 2026 13:19:57 +0200 [thread overview]
Message-ID: <ea81e8bb-2bb4-4466-b70c-e9f6516558a2@suse.com> (raw)
In-Reply-To: <d6239cec-02dd-4b4e-bdd6-2bd6f88d8753@intel.com>
[-- Attachment #1.1.1: Type: text/plain, Size: 1358 bytes --]
On 01.07.26 20:39, Reinette Chatre wrote:
> Hi Juergen,
>
> On 6/28/26 11:39 PM, Juergen Gross wrote:
>> Switch all users of native_wrmsr() to native_wrmsrq() in order to
>> prepare removal of native_wrmsr().
>>
>> Signed-off-by: Juergen Gross <jgross@suse.com>
>> ---
>
> (just looking at resctrl changes ...)
>
>> diff --git a/arch/x86/kernel/cpu/resctrl/pseudo_lock.c b/arch/x86/kernel/cpu/resctrl/pseudo_lock.c
>> index 0408ac7f66fd..ad4c0d79ce1d 100644
>> --- a/arch/x86/kernel/cpu/resctrl/pseudo_lock.c
>> +++ b/arch/x86/kernel/cpu/resctrl/pseudo_lock.c
>> @@ -175,7 +175,7 @@ int resctrl_arch_pseudo_lock_fn(void *_plr)
>> * pseudo-locked followed by reading of kernel memory to load it
>> * into the cache.
>> */
>> - native_wrmsr(MSR_IA32_PQR_ASSOC, rmid_p, plr->closid);
>> + native_wrmsrq(MSR_IA32_PQR_ASSOC, rmid_p | ((u64)plr->closid << 32));
>>
>
> This is ok but I find that it could be easier to read if changed to:
> native_wrmsrq(MSR_IA32_PQR_ASSOC, (u64)plr->closid << 32 | rmid_p)
>
> Above matches existing and familiar pattern of "high << 32 | low" when preparing
> register values as found in, for example arch/x86/include/asm/msr.h, that matches
> the mental model of ordering registers from MSB to LSB.
> The extra parentheses seem unnecessary.
Okay, fine with me.
Juergen
[-- Attachment #1.1.2: OpenPGP public key --]
[-- Type: application/pgp-keys, Size: 3743 bytes --]
[-- Attachment #2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 495 bytes --]
next prev parent reply other threads:[~2026-07-02 11:19 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-06-29 6:39 [PATCH 0/5] x86/msr: Drop 32-bit interfaces of native MSR functions Juergen Gross
2026-06-29 6:39 ` [PATCH 1/5] x86/msr: Switch users of native_wrmsr() to native_wrmsrq() Juergen Gross
2026-07-01 18:39 ` Reinette Chatre
2026-07-02 11:19 ` Jürgen Groß [this message]
2026-06-29 6:39 ` [PATCH 2/5] x86/msr: Remove native_wrmsr() Juergen Gross
2026-06-29 6:39 ` [PATCH 3/5] x86/msr: Switch users of native_rdmsr() to native_rdmsrq() Juergen Gross
2026-06-29 6:39 ` [PATCH 4/5] x86/msr: Remove native_rdmsr() Juergen Gross
2026-06-29 6:39 ` [PATCH 5/5] x86/msr: Switch native_wrmsrq() from macro to inline function Juergen Gross
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ea81e8bb-2bb4-4466-b70c-e9f6516558a2@suse.com \
--to=jgross@suse.com \
--cc=Dave.Martin@arm.com \
--cc=babu.moger@amd.com \
--cc=bp@alien8.de \
--cc=dave.hansen@linux.intel.com \
--cc=hpa@zytor.com \
--cc=james.morse@arm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=reinette.chatre@intel.com \
--cc=tglx@kernel.org \
--cc=tony.luck@intel.com \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.