From: Cezary Rojewski <cezary.rojewski@intel.com>
To: Pierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>,
Kai Vehmanen <kai.vehmanen@linux.intel.com>
Cc: hdegoede@redhat.com, alsa-devel@alsa-project.org,
broonie@kernel.org, tiwai@suse.com
Subject: Re: [PATCH] ASoC: Intel: Unify HDAudio-ext bus initialization
Date: Thu, 21 Oct 2021 20:38:29 +0200 [thread overview]
Message-ID: <f9320fb8-4609-8399-9b57-440f6cfd48e3@intel.com> (raw)
In-Reply-To: <857438fc-1d63-84a8-f42a-79b082297035@linux.intel.com>
On 2021-10-21 7:19 PM, Pierre-Louis Bossart wrote:
>
>>> If it was just moving common parts, I would have no issue. My main
>>> objection is that you went one step further and started renaming stuff
>>> in rather confusing ways, e.g.
>>>
>>> -void sof_hda_bus_init(struct hdac_bus *bus, struct device *dev)
>>> +void sof_hda_bus_init(struct hda_bus *bus, struct pci_dev *pdev,
>>>
>>> - * snd_hdac_ext_bus_init - initialize a HD-audio extended bus
>>> + * snd_hda_ext_bus_init - initialize a HD-audio extended bus
>>
>> Reason for renaming snd_hdac_ext_bus_init() to snd_hda_ext_bus_init() is
>> argument type change: 'struct hdac_bus *' to struct hda_bus *'. Don't
>> believe that's confusing to anybody.
>
> it is confusing to me, myself and I. The main point is that it blurs
> layers.
>
> The hdaudio_ext library deals with Intel controller extensions for DMA
> management and does not need to know about a larger container.
Ok. Will leave the naming part for future patches while leaving argument
list as is.
...
>>> Even if there was, I also don't really see why/when we should start
>>> using hda_ext v. hdac_ext, the naming convention completely escapes me.
>>> It would seem logical to me to only use hdac_ext as an extension of
>>> hdac_, no?
>>>
>>> I also don't get what this means:
>>> + snd_hda_ext_bus_init(hbus, pci, NULL, ext_ops, "sklbus");
>>>
>>> what is 'sklbus' and what purpose are you trying to accomplish with this
>>> change?
>>>
>>
>> Well, please see the updated declaration of snd_hda_ext_bus_init() in
>> this very patch and then the existing code of
>> sound/soc/intel/skylake/skl.c - skl_create().
>> Last argument in updated declaration reads 'modelname'. Skylake-driver
>> has its own, SOF initializes it differently.
>
> Not sure why you have your own?
>
Not sure I understand the question. If you are talking about changing
string 'sklbus' to something else, then I don't believe mixing changes:
update to actual values assigned and assignment relocation in one patch
is good. I used 'sklbus' as that's what is being currently assigned to
->modelname within skl_create(). Such approach makes the change more
transparent.
Regards,
Czarek
next prev parent reply other threads:[~2021-10-21 18:40 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-10-18 19:21 [PATCH] ASoC: Intel: Unify HDAudio-ext bus initialization Cezary Rojewski
2021-10-18 21:18 ` Pierre-Louis Bossart
2021-10-19 8:00 ` Cezary Rojewski
2021-10-19 9:16 ` Kai Vehmanen
2021-10-19 12:19 ` Cezary Rojewski
2021-10-19 16:58 ` Pierre-Louis Bossart
2021-10-19 17:32 ` Cezary Rojewski
2021-10-19 18:42 ` Pierre-Louis Bossart
2021-10-21 11:02 ` Cezary Rojewski
2021-10-21 17:19 ` Pierre-Louis Bossart
2021-10-21 18:38 ` Cezary Rojewski [this message]
2021-10-21 19:08 ` Pierre-Louis Bossart
2021-10-24 17:42 ` kernel test robot
2021-10-24 17:42 ` kernel test robot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=f9320fb8-4609-8399-9b57-440f6cfd48e3@intel.com \
--to=cezary.rojewski@intel.com \
--cc=alsa-devel@alsa-project.org \
--cc=broonie@kernel.org \
--cc=hdegoede@redhat.com \
--cc=kai.vehmanen@linux.intel.com \
--cc=pierre-louis.bossart@linux.intel.com \
--cc=tiwai@suse.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.