From: Neil Armstrong <neil.armstrong@linaro.org>
To: Manivannan Sadhasivam <mani@kernel.org>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Rob Herring <robh@kernel.org>,
Krzysztof Kozlowski <krzk+dt@kernel.org>,
Conor Dooley <conor+dt@kernel.org>,
Geert Uytterhoeven <geert+renesas@glider.be>,
Magnus Damm <magnus.damm@gmail.com>,
Bartosz Golaszewski <brgl@kernel.org>,
Bjorn Helgaas <bhelgaas@google.com>,
Bjorn Andersson <andersson@kernel.org>,
Konrad Dybcio <konradybcio@kernel.org>,
linux-usb@vger.kernel.org, devicetree@vger.kernel.org,
linux-kernel@vger.kernel.org, linux-renesas-soc@vger.kernel.org,
linux-pci@vger.kernel.org, linux-arm-msm@vger.kernel.org
Subject: Re: [PATCH v3 3/9] pci: pwrctrl: rename pci-pwrctrl-slot as generic
Date: Mon, 9 Feb 2026 14:57:47 +0100 [thread overview]
Message-ID: <fd446018-3006-4c59-bc92-ae3929b8d402@linaro.org> (raw)
In-Reply-To: <ygvljxho4dh4zlkxcropjdczbyh45sexntosz2rvxdsxigmgmi@aeqhi4qit5ct>
On 2/9/26 12:33, Manivannan Sadhasivam wrote:
> On Fri, Feb 06, 2026 at 03:50:31PM +0100, Neil Armstrong wrote:
>> The driver is pretty generic and would fit for either
>> PCI Slots or PCI devices connected to PCI ports, so rename
>> the driver and module as pci-pwrctrl-generic.
>>
>> Suggested-by: Manivannan Sadhasivam <mani@kernel.org>
>> Signed-off-by: Neil Armstrong <neil.armstrong@linaro.org>
>> ---
>> drivers/pci/pwrctrl/Kconfig | 8 ++++----
>> drivers/pci/pwrctrl/Makefile | 4 ++--
>> drivers/pci/pwrctrl/{slot.c => generic.c} | 0
>
> I was expecting the rename inside the driver too :)
Oh yeah, will do in v4
Neil
>
> - Mani
>
>> 3 files changed, 6 insertions(+), 6 deletions(-)
>>
>> diff --git a/drivers/pci/pwrctrl/Kconfig b/drivers/pci/pwrctrl/Kconfig
>> index e0f999f299bb..0a93ac4cd11b 100644
>> --- a/drivers/pci/pwrctrl/Kconfig
>> +++ b/drivers/pci/pwrctrl/Kconfig
>> @@ -11,12 +11,12 @@ config PCI_PWRCTRL_PWRSEQ
>> select POWER_SEQUENCING
>> select PCI_PWRCTRL
>>
>> -config PCI_PWRCTRL_SLOT
>> - tristate "PCI Power Control driver for PCI slots"
>> +config PCI_PWRCTRL_GENERIC
>> + tristate "Generic PCI Power Control driver for PCI slots"
>> select PCI_PWRCTRL
>> help
>> - Say Y here to enable the PCI Power Control driver to control the power
>> - state of PCI slots.
>> + Say Y here to enable the generic PCI Power Control driver to control
>> + the power state of PCI slots.
>>
>> This is a generic driver that controls the power state of different
>> PCI slots. The voltage regulators powering the rails of the PCI slots
>> diff --git a/drivers/pci/pwrctrl/Makefile b/drivers/pci/pwrctrl/Makefile
>> index 13b02282106c..f6bb4fb9a410 100644
>> --- a/drivers/pci/pwrctrl/Makefile
>> +++ b/drivers/pci/pwrctrl/Makefile
>> @@ -5,7 +5,7 @@ pci-pwrctrl-core-y := core.o
>>
>> obj-$(CONFIG_PCI_PWRCTRL_PWRSEQ) += pci-pwrctrl-pwrseq.o
>>
>> -obj-$(CONFIG_PCI_PWRCTRL_SLOT) += pci-pwrctrl-slot.o
>> -pci-pwrctrl-slot-y := slot.o
>> +obj-$(CONFIG_PCI_PWRCTRL_GENERIC) += pci-pwrctrl-generic.o
>> +pci-pwrctrl-generic-y := generic.o
>>
>> obj-$(CONFIG_PCI_PWRCTRL_TC9563) += pci-pwrctrl-tc9563.o
>> diff --git a/drivers/pci/pwrctrl/slot.c b/drivers/pci/pwrctrl/generic.c
>> similarity index 100%
>> rename from drivers/pci/pwrctrl/slot.c
>> rename to drivers/pci/pwrctrl/generic.c
>>
>> --
>> 2.34.1
>>
>
next prev parent reply other threads:[~2026-02-09 13:57 UTC|newest]
Thread overview: 29+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-02-06 14:50 [PATCH v3 0/9] arm64: dts: qcom: Add support for the Ayaneo Pocket S2 Neil Armstrong
2026-02-06 14:50 ` [PATCH v3 1/9] dt-bindings: usb: document the Renesas UPD720201/UPD720202 USB 3.0 xHCI Host Controller Neil Armstrong
2026-02-10 2:37 ` Rob Herring (Arm)
2026-02-12 15:17 ` Bjorn Andersson
2026-02-13 8:25 ` Neil Armstrong
2026-02-06 14:50 ` [PATCH v3 2/9] pci: pwrctrl: slot: fix dev_err_probe() usage Neil Armstrong
2026-02-06 15:13 ` Bartosz Golaszewski
2026-02-06 14:50 ` [PATCH v3 3/9] pci: pwrctrl: rename pci-pwrctrl-slot as generic Neil Armstrong
2026-02-09 11:31 ` Manivannan Sadhasivam
2026-02-09 11:33 ` Manivannan Sadhasivam
2026-02-09 13:57 ` Neil Armstrong [this message]
2026-02-06 14:50 ` [PATCH v3 4/9] pci: pwrctrl: generic: support for the UPD720201/UPD720202 USB 3.0 xHCI Host Controller Neil Armstrong
2026-02-09 11:30 ` Manivannan Sadhasivam
2026-02-09 14:00 ` Neil Armstrong
2026-02-09 14:49 ` Manivannan Sadhasivam
2026-02-09 14:59 ` Neil Armstrong
2026-02-10 8:00 ` Manivannan Sadhasivam
2026-02-10 9:01 ` Neil Armstrong
2026-02-10 11:03 ` Manivannan Sadhasivam
2026-02-10 12:25 ` Dmitry Baryshkov
2026-02-06 14:50 ` [PATCH v3 5/9] arm64: defconfig: enable pci-pwrctrl-generic as module Neil Armstrong
2026-02-09 11:32 ` Manivannan Sadhasivam
2026-02-06 14:50 ` [PATCH v3 6/9] dt-binding: vendor-prefixes: document the Ayaneo brand Neil Armstrong
2026-02-06 14:50 ` [PATCH v3 7/9] dt-bindings: arm: qcom: document the Ayaneo Pocket S2 Neil Armstrong
2026-02-06 23:16 ` Rob Herring (Arm)
2026-02-06 14:50 ` [PATCH v3 8/9] arm64: dts: qcom: sm8650: Add sound DAI prefix for DP Neil Armstrong
2026-02-06 14:50 ` [PATCH v3 9/9] arm64: dts: qcom: add basic devicetree for Ayaneo Pocket S2 gaming console Neil Armstrong
2026-02-06 21:35 ` [PATCH v3 0/9] arm64: dts: qcom: Add support for the Ayaneo Pocket S2 Bjorn Helgaas
2026-02-09 9:15 ` Neil Armstrong
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=fd446018-3006-4c59-bc92-ae3929b8d402@linaro.org \
--to=neil.armstrong@linaro.org \
--cc=andersson@kernel.org \
--cc=bhelgaas@google.com \
--cc=brgl@kernel.org \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=geert+renesas@glider.be \
--cc=gregkh@linuxfoundation.org \
--cc=konradybcio@kernel.org \
--cc=krzk+dt@kernel.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=linux-renesas-soc@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=magnus.damm@gmail.com \
--cc=mani@kernel.org \
--cc=robh@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.