From: Michal Wajdeczko <michal.wajdeczko@intel.com>
To: "Piotr Piórkowski" <piotr.piorkowski@intel.com>
Cc: intel-xe@lists.freedesktop.org
Subject: Re: [PATCH 3/8] drm/xe/guc: Add support for threshold KLVs in to_string() helper
Date: Tue, 14 May 2024 18:15:15 +0200 [thread overview]
Message-ID: <fe150758-d89b-4e57-a0ad-46fd89239a52@intel.com> (raw)
In-Reply-To: <20240514082058.cigcuaiyqemm746t@intel.com>
On 14.05.2024 10:20, Piotr Piórkowski wrote:
> Michal Wajdeczko <michal.wajdeczko@intel.com> wrote on pon [2024-maj-06 15:38:09 +0200]:
>> Use MAKE_XE_GUC_KLV_THRESHOLDS_SET to generate missing conversion
>> of threshold KLV keys to string.
>>
>> Signed-off-by: Michal Wajdeczko <michal.wajdeczko@intel.com>
>> ---
>> drivers/gpu/drm/xe/xe_guc_klv_helpers.c | 9 +++++++++
>> 1 file changed, 9 insertions(+)
>>
>> diff --git a/drivers/gpu/drm/xe/xe_guc_klv_helpers.c b/drivers/gpu/drm/xe/xe_guc_klv_helpers.c
>> index ceca949932a0..cf7c5fed407d 100644
>> --- a/drivers/gpu/drm/xe/xe_guc_klv_helpers.c
>> +++ b/drivers/gpu/drm/xe/xe_guc_klv_helpers.c
>> @@ -8,6 +8,7 @@
>>
>> #include "abi/guc_klvs_abi.h"
>> #include "xe_guc_klv_helpers.h"
>> +#include "xe_guc_klv_thresholds_set.h"
>>
>> #define make_u64(hi, lo) ((u64)((u64)(u32)(hi) << 32 | (u32)(lo)))
>>
>> @@ -48,6 +49,14 @@ const char *xe_guc_klv_key_to_string(u16 key)
>> return "begin_db_id";
>> case GUC_KLV_VF_CFG_BEGIN_CONTEXT_ID_KEY:
>> return "begin_ctx_id";
>> +
>> + /* VF CFG threshold keys */
>> +#define define_threshold_key_to_string_case(TAG, NAME, ...) \
>> + case MAKE_GUC_KLV_VF_CFG_THRESHOLD_KEY(TAG): \
>> + return #NAME;
>> + MAKE_XE_GUC_KLV_THRESHOLDS_SET(define_threshold_key_to_string_case)
>> +#undef define_threshold_key_to_string_case
>
> In a review of an earlier patch, I already mentioned that placing the definition of this macro
> inside the switch worsens the readability of the code, but still:
will include empty lines for a better visibility
> Reviewed-by: Piotr Piórkowski <piotr.piorkowski@intel.com>
>> +
>> default:
>> return "(unknown)";
>> }
>> --
>> 2.43.0
>>
>
next prev parent reply other threads:[~2024-05-14 16:15 UTC|newest]
Thread overview: 29+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-05-06 13:38 [PATCH 0/8] PF: Support for adverse events notifications Michal Wajdeczko
2024-05-06 13:38 ` [PATCH 1/8] drm/xe/guc: Add more KLV helper macros Michal Wajdeczko
2024-05-14 6:57 ` Piotr Piórkowski
2024-05-06 13:38 ` [PATCH 2/8] drm/xe/guc: Introduce GuC KLV thresholds set Michal Wajdeczko
2024-05-14 8:08 ` Piotr Piórkowski
2024-05-14 16:14 ` Michal Wajdeczko
2024-05-06 13:38 ` [PATCH 3/8] drm/xe/guc: Add support for threshold KLVs in to_string() helper Michal Wajdeczko
2024-05-14 8:20 ` Piotr Piórkowski
2024-05-14 16:15 ` Michal Wajdeczko [this message]
2024-05-06 13:38 ` [PATCH 4/8] drm/xe/pf: Introduce functions to configure VF thresholds Michal Wajdeczko
2024-05-14 8:31 ` Piotr Piórkowski
2024-05-14 16:19 ` Michal Wajdeczko
2024-05-06 13:38 ` [PATCH 5/8] drm/xe/pf: Allow configuration of VF thresholds over debugfs Michal Wajdeczko
2024-05-14 9:03 ` Piotr Piórkowski
2024-05-06 13:38 ` [PATCH 6/8] drm/xe/guc: Add GUC2PF_ADVERSE_EVENT to ABI Michal Wajdeczko
2024-05-14 9:14 ` Piotr Piórkowski
2024-05-06 13:38 ` [PATCH 7/8] drm/xe/pf: Track adverse events notifications from GuC Michal Wajdeczko
2024-05-14 10:37 ` Piotr Piórkowski
2024-05-14 16:23 ` Michal Wajdeczko
2024-05-06 13:38 ` [PATCH 8/8] drm/xe/pf: Expose PF monitor details via debugfs Michal Wajdeczko
2024-05-14 10:38 ` Piotr Piórkowski
2024-05-06 16:05 ` ✓ CI.Patch_applied: success for PF: Support for adverse events notifications Patchwork
2024-05-06 16:05 ` ✗ CI.checkpatch: warning " Patchwork
2024-05-06 16:06 ` ✓ CI.KUnit: success " Patchwork
2024-05-06 16:19 ` ✓ CI.Build: " Patchwork
2024-05-06 16:22 ` ✗ CI.Hooks: failure " Patchwork
2024-05-06 16:26 ` ✓ CI.checksparse: success " Patchwork
2024-05-06 17:48 ` ✓ CI.BAT: " Patchwork
2024-05-06 19:38 ` ✓ CI.FULL: " Patchwork
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=fe150758-d89b-4e57-a0ad-46fd89239a52@intel.com \
--to=michal.wajdeczko@intel.com \
--cc=intel-xe@lists.freedesktop.org \
--cc=piotr.piorkowski@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.