From mboxrd@z Thu Jan 1 00:00:00 1970 From: Juan Quintela Subject: Re: [RFC PATCH 2/6] ram_blocks: Convert to a QLIST Date: Wed, 09 Jun 2010 10:19:16 +0200 Message-ID: References: <20100608191447.4451.47795.stgit@localhost.localdomain> <20100608191535.4451.48702.stgit@localhost.localdomain> <20100608212659.GS28492@x200.localdomain> <1276033548.3079.20.camel@x201> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Cc: Chris Wright , qemu-devel@nongnu.org, anthony@codemonkey.ws, kvm@vger.kernel.org To: Alex Williamson Return-path: Received: from mx1.redhat.com ([209.132.183.28]:62637 "EHLO mx1.redhat.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755568Ab0FIITU (ORCPT ); Wed, 9 Jun 2010 04:19:20 -0400 In-Reply-To: <1276033548.3079.20.camel@x201> (Alex Williamson's message of "Tue, 08 Jun 2010 15:45:48 -0600") Sender: kvm-owner@vger.kernel.org List-ID: Alex Williamson wrote: > On Tue, 2010-06-08 at 14:26 -0700, Chris Wright wrote: >> * Alex Williamson (alex.williamson@redhat.com) wrote: >> > extern int phys_ram_fd; >> > -extern uint8_t *phys_ram_dirty; >> > extern ram_addr_t ram_size; >> > -extern ram_addr_t last_ram_offset; >> > + >> > +typedef struct RAMBlock { >> > + uint8_t *host; >> > + ram_addr_t offset; >> > + ram_addr_t length; >> > + QLIST_ENTRY(RAMBlock) next; >> > +} RAMBlock; >> > + >> > +typedef struct RAMList { >> > + uint8_t *phys_dirty; >> > + ram_addr_t last_offset; >> > + QLIST_HEAD(ram, RAMBlock) blocks; >> > +} RAMList; >> > +extern RAMList ram; >> >> such a generic name for global namespace > > Well it is _the_ ram, but yea... ;) Suggestions? ram_block_list? Later, Juan. From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from [140.186.70.92] (port=41431 helo=eggs.gnu.org) by lists.gnu.org with esmtp (Exim 4.43) id 1OMGYy-0004sR-UY for qemu-devel@nongnu.org; Wed, 09 Jun 2010 04:23:47 -0400 Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.69) (envelope-from ) id 1OMGVM-00023l-Aw for qemu-devel@nongnu.org; Wed, 09 Jun 2010 04:19:25 -0400 Received: from mx1.redhat.com ([209.132.183.28]:58852) by eggs.gnu.org with esmtp (Exim 4.69) (envelope-from ) id 1OMGVM-00023Y-4Q for qemu-devel@nongnu.org; Wed, 09 Jun 2010 04:19:20 -0400 From: Juan Quintela In-Reply-To: <1276033548.3079.20.camel@x201> (Alex Williamson's message of "Tue, 08 Jun 2010 15:45:48 -0600") References: <20100608191447.4451.47795.stgit@localhost.localdomain> <20100608191535.4451.48702.stgit@localhost.localdomain> <20100608212659.GS28492@x200.localdomain> <1276033548.3079.20.camel@x201> Date: Wed, 09 Jun 2010 10:19:16 +0200 Message-ID: MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Subject: [Qemu-devel] Re: [RFC PATCH 2/6] ram_blocks: Convert to a QLIST List-Id: qemu-devel.nongnu.org List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , To: Alex Williamson Cc: Chris Wright , qemu-devel@nongnu.org, kvm@vger.kernel.org Alex Williamson wrote: > On Tue, 2010-06-08 at 14:26 -0700, Chris Wright wrote: >> * Alex Williamson (alex.williamson@redhat.com) wrote: >> > extern int phys_ram_fd; >> > -extern uint8_t *phys_ram_dirty; >> > extern ram_addr_t ram_size; >> > -extern ram_addr_t last_ram_offset; >> > + >> > +typedef struct RAMBlock { >> > + uint8_t *host; >> > + ram_addr_t offset; >> > + ram_addr_t length; >> > + QLIST_ENTRY(RAMBlock) next; >> > +} RAMBlock; >> > + >> > +typedef struct RAMList { >> > + uint8_t *phys_dirty; >> > + ram_addr_t last_offset; >> > + QLIST_HEAD(ram, RAMBlock) blocks; >> > +} RAMList; >> > +extern RAMList ram; >> >> such a generic name for global namespace > > Well it is _the_ ram, but yea... ;) Suggestions? ram_block_list? Later, Juan.