From: Junio C Hamano <gitster@pobox.com>
To: Jonathan Nieder <jrnieder@gmail.com>
Cc: Christian Couder <christian.couder@gmail.com>,
git@vger.kernel.org, Jeff King <peff@peff.net>,
Ben Peart <Ben.Peart@microsoft.com>,
Jonathan Tan <jonathantanmy@google.com>,
Nguyen Thai Ngoc Duy <pclouds@gmail.com>,
Mike Hommey <mh@glandium.org>,
Lars Schneider <larsxschneider@gmail.com>,
Eric Wong <e@80x24.org>,
Christian Couder <chriscool@tuxfamily.org>
Subject: Re: [PATCH 2/2] Git/Packet.pm: use 'if' instead of 'unless'
Date: Wed, 22 Nov 2017 12:48:06 +0900 [thread overview]
Message-ID: <xmqq1skrvurt.fsf@gitster.mtv.corp.google.com> (raw)
In-Reply-To: <20171121192440.GE3429@aiede.mtv.corp.google.com> (Jonathan Nieder's message of "Tue, 21 Nov 2017 11:24:40 -0800")
Jonathan Nieder <jrnieder@gmail.com> writes:
> [...]
>> --- a/perl/Git/Packet.pm
>> +++ b/perl/Git/Packet.pm
>> @@ -68,16 +68,16 @@ sub packet_bin_read {
>>
>> sub remove_final_lf_or_die {
>> my $buf = shift;
>> - unless ( $buf =~ s/\n$// ) {
>
> For readability, I find this whitespace within parens more distracting.
I personally find them distracting, too. This file seems full of
them so it is OK to be consistent with the existing practice in this
step, leaving the eventual clean-up (if we agree that it is a good
idea) to a later step that does it for the entire file contents.
Thanks.
next prev parent reply other threads:[~2017-11-22 3:48 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-11-21 16:09 [PATCH 1/2] Git/Packet.pm: rename packet_required_key_val_read() Christian Couder
2017-11-21 16:09 ` [PATCH 2/2] Git/Packet.pm: use 'if' instead of 'unless' Christian Couder
2017-11-21 19:24 ` Jonathan Nieder
2017-11-22 3:48 ` Junio C Hamano [this message]
2017-11-21 19:19 ` [PATCH 1/2] Git/Packet.pm: rename packet_required_key_val_read() Jonathan Nieder
2017-11-22 3:39 ` Junio C Hamano
2017-11-22 5:10 ` Jonathan Nieder
2017-11-22 6:28 ` Junio C Hamano
2017-11-22 7:07 ` Jonathan Nieder
2017-11-22 7:14 ` Christian Couder
2017-11-22 3:48 ` Junio C Hamano
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=xmqq1skrvurt.fsf@gitster.mtv.corp.google.com \
--to=gitster@pobox.com \
--cc=Ben.Peart@microsoft.com \
--cc=chriscool@tuxfamily.org \
--cc=christian.couder@gmail.com \
--cc=e@80x24.org \
--cc=git@vger.kernel.org \
--cc=jonathantanmy@google.com \
--cc=jrnieder@gmail.com \
--cc=larsxschneider@gmail.com \
--cc=mh@glandium.org \
--cc=pclouds@gmail.com \
--cc=peff@peff.net \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.