All of lore.kernel.org
 help / color / mirror / Atom feed
From: Junio C Hamano <gitster@pobox.com>
To: larsxschneider@gmail.com
Cc: git@vger.kernel.org, sunshine@sunshineco.com,
	sschuberth@gmail.com, Matthieu.Moy@grenoble-inp.fr,
	avila.jn@gmail.com, luke@diamand.org, dturner@twopensource.com
Subject: Re: [PATCH v4 1/4] add function test_must_fail_or_sigpipe and use it to fix flaky tests
Date: Fri, 06 Nov 2015 10:49:15 -0800	[thread overview]
Message-ID: <xmqqmvur2cb8.fsf@gitster.mtv.corp.google.com> (raw)
In-Reply-To: <xmqqr3k32dc9.fsf@gitster.mtv.corp.google.com> (Junio C. Hamano's message of "Fri, 06 Nov 2015 10:27:02 -0800")

Junio C Hamano <gitster@pobox.com> writes:

> Adding the third variant in the way this patch does is making things
> worse by inviting more mistakes.
>
> How about doing something like the attached to consolidate the
> existing two into one, and then build this third one on top?

Actually, I think this other variant I came up with is cleaner and
is more easily extensible.  It already has the support for sigpipe,
e.g. you can do

	test_must_fail ok=sigpipe git fetch ...

Of course, you can do

	test_must_fail_or_sigpipe () {
		test_must_fail ok=sigpipe "$@"
	}

if it is easier to read.  I do not have a very strong opinion either
way.

 t/test-lib-functions.sh | 28 +++++++++++++++++-----------
 1 file changed, 17 insertions(+), 11 deletions(-)

diff --git a/t/test-lib-functions.sh b/t/test-lib-functions.sh
index e8d3c0f..b732f87 100644
--- a/t/test-lib-functions.sh
+++ b/t/test-lib-functions.sh
@@ -560,11 +560,26 @@ test_line_count () {
 # the failure could be due to a segv.  We want a controlled failure.
 
 test_must_fail () {
+	case "$1" in
+	ok=*)
+		_test_ok=${1#ok=}
+		shift
+		;;
+	*)
+		_test_ok=
+		;;
+	esac
 	"$@"
 	exit_code=$?
-	if test $exit_code = 0; then
+	if ! case ",$_test_ok," in *,success,*) false;; esac &&
+	   test $exit_code = 0
+	then
 		echo >&2 "test_must_fail: command succeeded: $*"
 		return 1
+	elif ! case ",$_test_ok," in *,sigpipe,*) false;; esac &&
+	   test $exit_code = 141
+	then
+		return 0
 	elif test $exit_code -gt 129 && test $exit_code -le 192; then
 		echo >&2 "test_must_fail: died by signal: $*"
 		return 1
@@ -590,16 +605,7 @@ test_must_fail () {
 # because we want to notice if it fails due to segv.
 
 test_might_fail () {
-	"$@"
-	exit_code=$?
-	if test $exit_code -gt 129 && test $exit_code -le 192; then
-		echo >&2 "test_might_fail: died by signal: $*"
-		return 1
-	elif test $exit_code = 127; then
-		echo >&2 "test_might_fail: command not found: $*"
-		return 1
-	fi
-	return 0
+	test_must_fail ok=success "$@"
 }
 
 # Similar to test_must_fail and test_might_fail, but check that a

  reply	other threads:[~2015-11-06 18:49 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-11-06  8:58 [PATCH v4 0/4] Add Travis CI support larsxschneider
2015-11-06  8:58 ` [PATCH v4 1/4] add function test_must_fail_or_sigpipe and use it to fix flaky tests larsxschneider
2015-11-06 18:27   ` Junio C Hamano
2015-11-06 18:49     ` Junio C Hamano [this message]
2015-11-06  8:58 ` [PATCH v4 2/4] git-p4: add p4d timeout in tests larsxschneider
2015-11-06  9:23   ` Eric Sunshine
2015-11-06 13:20     ` Lars Schneider
2015-11-06  8:58 ` [PATCH v4 3/4] git-p4: retry kill/cleanup operations in tests with timeout larsxschneider
2015-11-06  9:28   ` Eric Sunshine
2015-11-06  9:47     ` Lars Schneider
2015-11-06 13:19     ` Lars Schneider
2015-11-06  8:58 ` [PATCH v4 4/4] Add Travis CI support larsxschneider
2015-11-06  9:56   ` Eric Sunshine
2015-11-06 13:18     ` Lars Schneider
     [not found]     ` <22B2C2B1-9260-4EC0-A4C5-C7F7DDD388BA@gmail.com>
2015-11-06 13:20       ` Sebastian Schuberth
2015-11-06 13:28         ` Lars Schneider
2015-11-06 13:36           ` Sebastian Schuberth
2015-11-06 13:55             ` Lars Schneider
2015-11-06 13:57               ` Sebastian Schuberth
2015-11-06 14:08                 ` Lars Schneider

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=xmqqmvur2cb8.fsf@gitster.mtv.corp.google.com \
    --to=gitster@pobox.com \
    --cc=Matthieu.Moy@grenoble-inp.fr \
    --cc=avila.jn@gmail.com \
    --cc=dturner@twopensource.com \
    --cc=git@vger.kernel.org \
    --cc=larsxschneider@gmail.com \
    --cc=luke@diamand.org \
    --cc=sschuberth@gmail.com \
    --cc=sunshine@sunshineco.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.