From: Junio C Hamano <gitster@pobox.com>
To: Jeff King <peff@peff.net>
Cc: git@vger.kernel.org
Subject: Re: [PATCH 5/7] delta_base_cache: drop special treatment of blobs
Date: Tue, 23 Aug 2016 15:18:42 -0700 [thread overview]
Message-ID: <xmqqshtvt9h9.fsf@gitster.mtv.corp.google.com> (raw)
In-Reply-To: <20160822215956.kuqnucvfodxjrawn@sigill.intra.peff.net> (Jeff King's message of "Mon, 22 Aug 2016 17:59:56 -0400")
Jeff King <peff@peff.net> writes:
> Let's run the same numbers without caring about object type
> at all (i.e., one LRU list, and always evicting whatever is
> at the head, regardless of type).
> ...
> So it seems like a clear winner, and that's what this patch
> implements.
>
> Signed-off-by: Jeff King <peff@peff.net>
> ---
Nice work. You make your readers expect some clever data structures
that may perform better than the obvious two-separate-list approach
and end up using the simplest way. Quite nice.
> sha1_file.c | 8 --------
> 1 file changed, 8 deletions(-)
>
> diff --git a/sha1_file.c b/sha1_file.c
> index c02e785..33564d6 100644
> --- a/sha1_file.c
> +++ b/sha1_file.c
> @@ -2175,14 +2175,6 @@ static void add_delta_base_cache(struct packed_git *p, off_t base_offset,
> list_entry(lru, struct delta_base_cache_entry, lru);
> if (delta_base_cached <= delta_base_cache_limit)
> break;
> - if (f->type == OBJ_BLOB)
> - release_delta_base_cache(f);
> - }
> - list_for_each(lru, &delta_base_cache_lru) {
> - struct delta_base_cache_entry *f =
> - list_entry(lru, struct delta_base_cache_entry, lru);
> - if (delta_base_cached <= delta_base_cache_limit)
> - break;
> release_delta_base_cache(f);
> }
next prev parent reply other threads:[~2016-08-23 22:18 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-08-22 21:57 [PATCH 0/7] tweaking the delta base cache Jeff King
2016-08-22 21:57 ` [PATCH 1/7] cache_or_unpack_entry: drop keep_cache parameter Jeff King
2016-08-23 21:45 ` Junio C Hamano
2016-08-22 21:57 ` [PATCH 2/7] clear_delta_base_cache_entry: use a more descriptive name Jeff King
2016-08-23 21:47 ` Junio C Hamano
2016-08-22 21:57 ` [PATCH 3/7] release_delta_base_cache: reuse existing detach function Jeff King
2016-08-23 21:49 ` Junio C Hamano
2016-08-24 17:41 ` Jeff King
2016-08-24 17:59 ` Junio C Hamano
2016-08-22 21:59 ` [PATCH 4/7] delta_base_cache: use list.h for LRU Jeff King
2016-08-22 23:18 ` Eric Wong
2016-08-23 0:48 ` Jeff King
2016-08-22 21:59 ` [PATCH 5/7] delta_base_cache: drop special treatment of blobs Jeff King
2016-08-23 22:18 ` Junio C Hamano [this message]
2016-08-22 22:00 ` [PATCH 6/7] delta_base_cache: use hashmap.h Jeff King
2016-08-23 22:26 ` Junio C Hamano
2016-08-22 22:01 ` [PATCH 7/7] t/perf: add basic perf tests for delta base cache Jeff King
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=xmqqshtvt9h9.fsf@gitster.mtv.corp.google.com \
--to=gitster@pobox.com \
--cc=git@vger.kernel.org \
--cc=peff@peff.net \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.