From: "chaithrika" <chaithrika@ti.com>
To: 'Mark Brown' <broonie@opensource.wolfsonmicro.com>
Cc: khilman@deeprootsystems.com, alsa-devel@alsa-project.org,
davinci-linux-open-source@linux.davincidsp.com
Subject: Re: [PATCH 1/2] ASoC: DaVinci: McASP driver enhacements
Date: Mon, 10 Aug 2009 10:37:58 +0530 [thread overview]
Message-ID: <020201ca1978$86fb5a70$94f20f50$@com> (raw)
In-Reply-To: <20090808081158.GC4519@sirena.org.uk>
On Sat, Aug 08, 2009 at 13:41:58, Mark Brown wrote:
> On Fri, Aug 07, 2009 at 10:07:42AM -0400, Chaithrika U S wrote:
>
> > This patch adds support for FIFO configuration.The platform member has a
> > version field which differentiates the McASP on different SoCs. The
patch
> > also adds another DAI format to the driver.
>
> You really should split out the DAI format addition into another patch -
> there's no code overlap between that and the rest of your changes.
OK. I will post a separate patch for this change.
> Aside from the issue Troy raised everything seems fine except for one
OK. I will submit a patch for that issue.
> small issue:
>
> > +
> > + /* McASP FIFO related */
> > + u8 txnumevt;
> > + u8 rxnumevt;
>
> These names don't seem particularly obvious. If they were chosen to
> match the datasheet name then it probably won't be a problem but
> otherwise something more like tx_fifo_depth might be easier for people
> to figure out.
>
Currently, the names are as per the peripheral datasheet. So, will
retain the same name.
Regards,
Chaithrika
prev parent reply other threads:[~2009-08-10 5:09 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-08-07 14:07 [PATCH 1/2] ASoC: DaVinci: McASP driver enhacements Chaithrika U S
2009-08-07 19:59 ` Troy Kisky
2009-08-10 4:58 ` chaithrika
2009-08-08 8:11 ` Mark Brown
2009-08-10 5:07 ` chaithrika [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to='020201ca1978$86fb5a70$94f20f50$@com' \
--to=chaithrika@ti.com \
--cc=alsa-devel@alsa-project.org \
--cc=broonie@opensource.wolfsonmicro.com \
--cc=davinci-linux-open-source@linux.davincidsp.com \
--cc=khilman@deeprootsystems.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox