From: Liam Girdwood <lrg@slimlogic.co.uk>
To: Lars-Peter Clausen <lars@metafoo.de>
Cc: Ralf Baechle <ralf@linux-mips.org>,
linux-mips@linux-mips.org, linux-kernel@vger.kernel.org,
Mark Brown <broonie@opensource.wolfsonmicro.com>,
alsa-devel@alsa-project.org
Subject: Re: [RFC][PATCH 21/26] alsa: ASoC: Add JZ4740 ASoC support
Date: Thu, 03 Jun 2010 18:03:29 +0100 [thread overview]
Message-ID: <1275584609.3118.26.camel@odin> (raw)
In-Reply-To: <4C07DD48.2050503@metafoo.de>
On Thu, 2010-06-03 at 18:50 +0200, Lars-Peter Clausen wrote:
> >> + config = snd_soc_dai_get_dma_data(rtd->dai->cpu_dai,
> substream);
> >> + if (!prtd->dma) {
> >> + const char *dma_channel_name;
> >> + if (substream->stream == SNDRV_PCM_STREAM_PLAYBACK)
> >> + dma_channel_name = "PCM Playback";
> >> + else
> >> + dma_channel_name = "PCM Capture";
> >> +
> >> + prtd->dma = jz4740_dma_request(substream,
> dma_channel_name);
> >>
> >
> > dma_channel_name variable is not required here. Just use the const
> char
> > * directly.
> >
> >
> I actually had it like that before, but I think it is much more readable
> in its current form.
I disagree, having the char pointer here just adds an extra level of
indirection and costs an extra two lines of code.
Liam
--
Freelance Developer, SlimLogic Ltd
ASoC and Voltage Regulator Maintainer.
http://www.slimlogic.co.uk
next prev parent reply other threads:[~2010-06-03 17:03 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <1275505397-16758-1-git-send-email-lars@metafoo.de>
2010-06-02 19:12 ` [RFC][PATCH 20/26] alsa: ASoC: Add JZ4740 codec driver Lars-Peter Clausen
2010-06-03 5:45 ` [alsa-devel] " Wan ZongShun
2010-06-03 12:03 ` Mark Brown
2010-06-03 12:32 ` Liam Girdwood
2010-06-03 12:50 ` Liam Girdwood
2010-06-03 16:58 ` Lars-Peter Clausen
2010-06-03 17:49 ` Mark Brown
2010-06-03 23:57 ` Lars-Peter Clausen
2010-06-03 23:59 ` Mark Brown
2010-06-02 19:12 ` [RFC][PATCH 21/26] alsa: ASoC: Add JZ4740 ASoC support Lars-Peter Clausen
2010-06-03 3:36 ` Wan ZongShun
2010-06-03 12:48 ` Liam Girdwood
2010-06-03 16:50 ` Lars-Peter Clausen
2010-06-03 17:03 ` Liam Girdwood [this message]
2010-06-03 17:16 ` Lars-Peter Clausen
2010-06-03 17:25 ` Liam Girdwood
2010-06-03 17:37 ` Lars-Peter Clausen
2010-06-03 18:14 ` Troy Kisky
2010-06-03 17:55 ` Mark Brown
2010-06-03 19:27 ` Lars-Peter Clausen
2010-06-02 19:15 ` [RFC][PATCH 26/26] alsa: ASoC: JZ4740: Add qi_lb60 board driver Lars-Peter Clausen
2010-06-03 17:57 ` Mark Brown
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1275584609.3118.26.camel@odin \
--to=lrg@slimlogic.co.uk \
--cc=alsa-devel@alsa-project.org \
--cc=broonie@opensource.wolfsonmicro.com \
--cc=lars@metafoo.de \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mips@linux-mips.org \
--cc=ralf@linux-mips.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox