From: Eldad Zack <eldad@fogrefinery.com>
To: Takashi Iwai <tiwai@suse.de>,
Clemens Ladisch <clemens@ladisch.de>,
Daniel Mack <zonque@gmail.com>
Cc: alsa-devel@alsa-project.org, Eldad Zack <eldad@fogrefinery.com>
Subject: [PATCH v3 00/11] ALSA: usb-audio: fix playback/capture concurrent usage
Date: Sun, 25 Aug 2013 17:43:08 +0200 [thread overview]
Message-ID: <1377445399-5678-1-git-send-email-eldad@fogrefinery.com> (raw)
Hi,
This patch series attempts to fix a long standing problem with the concurrent
usage of playback and capture on implicit feedback devices.
Applies against current for-next (HEAD 68538bf2bce557c3b5fe8c59b034d45352500db1 ).
v2:
http://mailman.alsa-project.org/pipermail/alsa-devel/2013-August/065649.html
v1:
http://mailman.alsa-project.org/pipermail/alsa-devel/2013-August/065517.html
* Changed "altset_idx" to "altsetting" thanks to Clemens' clarification.
#3: Thanks to Daniel's test, fixed a NULL dereference caused by userspace calling
snd_pcm_open() and then snd_pcm_close() immediately.
#8: subs->altset_idx was left intact, since it corresponds to the array index.
#10: this patch now removed subs->altset_idx, but also changes the check to be
performed against fmt->altsetting.
#11: New. This changes the name of snd_usb_endpoint member alt_idx to altsetting
for the same reason Clemens described.
Clemens and Daniel - thank you very much for your help!
Cheers,
Eldad
Eldad Zack (11):
ALSA: usb-audio: remove unused parameter from sync_ep_set_params
ALSA: usb-audio: remove deactivate_endpoints()
ALSA: usb-audio: prevent NULL dereference on stop trigger
ALSA: usb-audio: don't deactivate URBs on in-use EP
ALSA: usb-audio: void return type of snd_usb_endpoint_deactivate()
ALSA: usb-audio: clear SUBSTREAM_FLAG_SYNC_EP_STARTED on error
ALSA: usb-audio: correct ep use_count semantics (add set_param flag)
ALSA: usb-audio: conditional interface altsetting
ALSA: usb-audio: conditional concurrent usage of endpoint
ALSA: usb-audio: remove altset_idx from snd_usb_substream
ALSA: usb-audio: rename alt_idx to altsetting
sound/usb/card.h | 4 +-
sound/usb/endpoint.c | 82 ++++++++++++++++++-------
sound/usb/endpoint.h | 11 +++-
sound/usb/pcm.c | 168 ++++++++++++++++++++++++++++++++++++++-------------
sound/usb/pcm.h | 2 +
sound/usb/proc.c | 4 +-
6 files changed, 201 insertions(+), 70 deletions(-)
--
1.8.1.5
next reply other threads:[~2013-08-25 15:43 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-08-25 15:43 Eldad Zack [this message]
2013-08-25 15:43 ` [PATCH v3 01/11] ALSA: usb-audio: remove unused parameter from sync_ep_set_params Eldad Zack
2013-08-25 15:43 ` [PATCH v3 02/11] ALSA: usb-audio: remove deactivate_endpoints() Eldad Zack
2013-08-25 15:43 ` [PATCH v3 03/11] ALSA: usb-audio: prevent NULL dereference on stop trigger Eldad Zack
2013-08-25 15:45 ` [PATCH v3 04/11] ALSA: usb-audio: don't deactivate URBs on in-use EP Eldad Zack
2013-08-25 15:45 ` [PATCH v3 05/11] ALSA: usb-audio: void return type of snd_usb_endpoint_deactivate() Eldad Zack
2013-08-25 15:45 ` [PATCH v3 06/11] ALSA: usb-audio: clear SUBSTREAM_FLAG_SYNC_EP_STARTED on error Eldad Zack
2013-08-25 15:45 ` [PATCH v3 07/11] ALSA: usb-audio: correct ep use_count semantics (add set_param flag) Eldad Zack
2013-08-25 15:45 ` [PATCH v3 08/11] ALSA: usb-audio: conditional interface altsetting Eldad Zack
2013-08-25 15:45 ` [PATCH v3 09/11] ALSA: usb-audio: conditional concurrent usage of endpoint Eldad Zack
2013-08-25 15:45 ` [PATCH v3 10/11] ALSA: usb-audio: remove altset_idx from snd_usb_substream Eldad Zack
2013-08-25 15:45 ` [PATCH v3 11/11] ALSA: usb-audio: rename alt_idx to altsetting Eldad Zack
2013-08-25 21:10 ` [PATCH v3 00/11] ALSA: usb-audio: fix playback/capture concurrent usage Eldad Zack
2013-08-26 23:23 ` Nikolay Martynov
2013-09-01 8:54 ` Eldad Zack
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1377445399-5678-1-git-send-email-eldad@fogrefinery.com \
--to=eldad@fogrefinery.com \
--cc=alsa-devel@alsa-project.org \
--cc=clemens@ladisch.de \
--cc=tiwai@suse.de \
--cc=zonque@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox