Alsa-Devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Mark Brown <broonie@opensource.wolfsonmicro.com>
To: Joonyoung Shim <jy0922.shim@samsung.com>
Cc: alsa-devel@alsa-project.org,
	jassi brar <jassisinghbrar@gmail.com>,
	Jassi Brar <jassi.brar@samsung.com>,
	ben-linux@fluff.org
Subject: Re: [PATCH 1/7] S3C AUDIO: Rename s3c24xx_pcm prefix	to s3c_dma
Date: Fri, 6 Nov 2009 16:23:23 +0000	[thread overview]
Message-ID: <20091106162322.GD4938@sirena.org.uk> (raw)
In-Reply-To: <4AF25C8C.3020001@samsung.com>

On Thu, Nov 05, 2009 at 02:03:08PM +0900, Joonyoung Shim wrote:
> On 11/5/2009 1:16 PM, jassi brar wrote:

> > but if we try so, we have the following
> >  1) s3c24xx_pcm_dma_params -> s3c_dma_dma_params
> >  2) s3c24xx_pcm_preallocate_dma_buffer -> s3c_dma_preallocate_dma_buffer
> >  3) s3c24xx_pcm_dmamask -> s3c_dma_dmamask

> > none of which seem very nice.

> You can modify the names for the consistent prefix. If you
> use s3c_dma_ prefix, for example, s3c24xx_pcm_dma_params can be to 
> s3c_dma_params.

I tend to agree with this.  The actual rename needs to happen to free up
the PCM name for the driver for the PCM hardware.

> > These patches is not about changing naming conventions. Only changes, necessary
> > to have a clean and consistent namespace after integrating PCM driver, have
> > been made.

> Agree, but you already are changing the prefix from s3c24xx to s3c.

I also agree with this - if we're renaming this driver anyway then
changing the prefix for it while we're at it seems reasonable, it means
one less change in the future.

  reply	other threads:[~2009-11-06 16:23 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-11-05  1:34 [PATCH 1/7] S3C AUDIO: Rename s3c24xx_pcm prefix to s3c_dma Jassi Brar
2009-11-05  3:14 ` Joonyoung Shim
2009-11-05  4:16   ` jassi brar
2009-11-05  5:03     ` Joonyoung Shim
2009-11-06 16:23       ` Mark Brown [this message]
2009-11-07  3:46         ` jassi brar
2009-11-09  5:14           ` Joonyoung Shim
2009-11-09  5:31             ` jassi brar
2009-11-09  6:19               ` Joonyoung Shim
2009-11-09 12:05                 ` Mark Brown
  -- strict thread matches above, loose matches on Subject: below --
2009-11-11  4:44 Jassi Brar

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20091106162322.GD4938@sirena.org.uk \
    --to=broonie@opensource.wolfsonmicro.com \
    --cc=alsa-devel@alsa-project.org \
    --cc=ben-linux@fluff.org \
    --cc=jassi.brar@samsung.com \
    --cc=jassisinghbrar@gmail.com \
    --cc=jy0922.shim@samsung.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox