On Tue, May 08, 2012 at 02:55:57PM +0300, Peter Ujfalusi wrote: > +dmic_codec: dmic_codec@0 { /* generic DMIC codec */ > + compatible = "generic,dmic-codec"; > +}; Why is this called "dmic-codec" and not "dmic"? We probably need to have a think about this in the context of the handling of random on-board passive components in general - things like jacks and so on - is the most sensible thing to have a platform device for everything, or is that getting too noisy?